[PATCH] gnu: Add low-memory-monitor

  • Open
  • quality assurance status badge
Details
One participant
  • florhizome
Owner
unassigned
Submitted by
florhizome
Severity
normal
F
F
florhizome wrote on 10 Dec 2022 22:34
(address . guix-patches@gnu.org)(name . florhizome)(address . florhizome@posteo.net)
2a42531743f702776cdb3d71e0437ab22f9fcc0f.1670708018.git.florhizome@posteo.net
From: florhizome <florhizome@posteo.net>

* gnu/packages/freedesktop.scm (low-memory-monitor): New variable.
---
gnu/packages/freedesktop.scm | 43 ++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index f69b4b1e86..d3d66d5209 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1889,6 +1889,49 @@ (define-public libqmi
;; The qmicli tool is released under the GPLv2+ license.
(list license:lgpl2.0+ license:gpl2+))))
+(define-public low-memory-monitor
+ (package
+ (name "low-memory-monitor")
+ (version "2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/hadess/low-memory-monitor")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0431wzn9q2hnx0mwai8w3bcmbln8g76r7wyyhjbkamnl2sccl8jn"))))
+ (build-system meson-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-Dsystemdsystemunitdir=false")
+ #:glib-or-gtk? #t))
+ (native-inputs
+ (list (list glib "bin") gobject-introspection gtk-doc libxml2
+ pkg-config))
+ (inputs
+ (list glib libgudev eudev))
+ (home-page "https://gitlab.freedesktop.org/hadess/low-memory-monitor")
+
+ (synopsis "Daemon to send information about memory pressure to userspace")
+ (description
+ "Low Memory Monitor is an early boot daemon that will monitor memory
+pressure information coming from the kernel, and, when memory pressure means
+that memory isn't as readily available and would cause interactivity problems,
+ would:
+
+@itemize
+@item send D-Bus signals to user-space applications when memory is running low,
+
+@item if configured to do so and memory availability worsens, activate the
+ kernel's OOM killer.
+@end itemize
+
+It is designed for use on traditional Linux systems, with interactive user
+interfaces and D-Bus communication.")
+ (license license:gpl3)))
+
(define-public modem-manager
(package
(name "modem-manager")
--
2.38.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 59950@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59950
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch