[PATCH] add python-ogr2osm package

  • Open
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Patrick Noll
Owner
unassigned
Submitted by
Patrick Noll
Severity
normal
P
P
Patrick Noll wrote on 10 Dec 2022 05:37
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
HbqTcyLwnJjyy9QxUa6NnAxIoGt17jb-kDNzcf54Hw8n2-w02xfhJgX4bqpIK76APq07PlFpGC5iasvvVbrChU4ATli3OPfVKgkhTlkCijM=@patricknoll.com
gnu/packages/geo.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index b3a5c0df3f..cbe88bf9bc 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -770,6 +770,29 @@ (define-public python-geopandas
require a spatial database such as PostGIS.")
(license license:bsd-3)))

+(define-public python-ogr2osm
+ (package
+ (name "python-ogr2osm")
+ (version "1.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ogr2osm" version))
+ (sha256
+ (base32
+ "1rs0qjahssikayn91n790ms8dj3m3v327hp03c9ivlzn8vg6kalf"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-gdal python-lxml))
+ (arguments '(#:tests? #f)) ; Tests not included in release tarball
+ (home-page
+ "https://github.com/roelderickx/ogr2osm")
+ (synopsis
+ "Convert ogr-readable files like shapefiles into Openstreetmap(osm) format")
+ (description
+ "A tool for converting ogr-readable files into Openstreetmap(osm) format. Ogr2osm supports reading from ogr files like shapefiles or Postgres database. Ogr2osm converts data into osm or osm.pbf formats. A translation file can be used to manipulate the data during conversion.")
+ (license license:expat))
+
(define-public python-osmnx
(package
(name "python-osmnx")

base-commit: 3ae6f30767f962da74d18d824b521462e149b89a
-- 2.38.1
Attachment: file
N
N
Nicolas Goaziou wrote on 23 Apr 16:47 +0200
(name . Patrick Noll)(address . patrick@patricknoll.com)(address . 59938@debbugs.gnu.org)
878reisliq.fsf@nicolasgoaziou.fr
Hello,

Patrick Noll <patrick@patricknoll.com> writes:

Toggle quote (2 lines)
> +(define-public python-ogr2osm

Thank you.

Please note your commit message is not properly formatted. It should
look like:

gnu: Add python-ogr2osm.

* gnu/packages/geo.scm (python-ogr2osm): New variable.

Also, indentation is a bit off. You may want to use "guix style" command
to format the packge.

Toggle quote (3 lines)
> + (propagated-inputs
> + (list python-gdal python-lxml))

AFAIK, python-gdal is not provided in Guix, so you would need to package
it as well. Also, the package itself probably requires gdal as an input.

Toggle quote (2 lines)
> + (arguments '(#:tests? #f)) ; Tests not included in release tarball

Maybe it is better to get it from upsteram them. WDYT?

Toggle quote (11 lines)
> + (home-page
> + "https://github.com/roelderickx/ogr2osm")
> + (synopsis
> + "Convert ogr-readable files like shapefiles into Openstreetmap(osm) format")
> + (description
> + "A tool for converting ogr-readable files into Openstreetmap(osm)
> format. Ogr2osm supports reading from ogr files like shapefiles or
> Postgres database. Ogr2osm converts data into osm or osm.pbf formats.
> A translation file can be used to manipulate the data during
> conversion.")

The description should consist of complete sentences. Also, sentences
need to be separated with two spaces.

Would you want to send an updated patch?

Regards,
--
Nicolas Goaziou
?