[PATCH] add python-ogr2osm package

  • Done
  • quality assurance status badge
Details
3 participants
  • Nicolas Goaziou
  • Patrick Noll
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Patrick Noll
Severity
normal
P
P
Patrick Noll wrote on 10 Dec 2022 05:37
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
HbqTcyLwnJjyy9QxUa6NnAxIoGt17jb-kDNzcf54Hw8n2-w02xfhJgX4bqpIK76APq07PlFpGC5iasvvVbrChU4ATli3OPfVKgkhTlkCijM=@patricknoll.com
gnu/packages/geo.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index b3a5c0df3f..cbe88bf9bc 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -770,6 +770,29 @@ (define-public python-geopandas
require a spatial database such as PostGIS.")
(license license:bsd-3)))

+(define-public python-ogr2osm
+ (package
+ (name "python-ogr2osm")
+ (version "1.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ogr2osm" version))
+ (sha256
+ (base32
+ "1rs0qjahssikayn91n790ms8dj3m3v327hp03c9ivlzn8vg6kalf"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-gdal python-lxml))
+ (arguments '(#:tests? #f)) ; Tests not included in release tarball
+ (home-page
+ "https://github.com/roelderickx/ogr2osm")
+ (synopsis
+ "Convert ogr-readable files like shapefiles into Openstreetmap(osm) format")
+ (description
+ "A tool for converting ogr-readable files into Openstreetmap(osm) format. Ogr2osm supports reading from ogr files like shapefiles or Postgres database. Ogr2osm converts data into osm or osm.pbf formats. A translation file can be used to manipulate the data during conversion.")
+ (license license:expat))
+
(define-public python-osmnx
(package
(name "python-osmnx")

base-commit: 3ae6f30767f962da74d18d824b521462e149b89a
-- 2.38.1
Attachment: file
N
N
Nicolas Goaziou wrote on 23 Apr 2023 16:47
(name . Patrick Noll)(address . patrick@patricknoll.com)(address . 59938@debbugs.gnu.org)
878reisliq.fsf@nicolasgoaziou.fr
Hello,

Patrick Noll <patrick@patricknoll.com> writes:

Toggle quote (2 lines)
> +(define-public python-ogr2osm

Thank you.

Please note your commit message is not properly formatted. It should
look like:

gnu: Add python-ogr2osm.

* gnu/packages/geo.scm (python-ogr2osm): New variable.

Also, indentation is a bit off. You may want to use "guix style" command
to format the packge.

Toggle quote (3 lines)
> + (propagated-inputs
> + (list python-gdal python-lxml))

AFAIK, python-gdal is not provided in Guix, so you would need to package
it as well. Also, the package itself probably requires gdal as an input.

Toggle quote (2 lines)
> + (arguments '(#:tests? #f)) ; Tests not included in release tarball

Maybe it is better to get it from upsteram them. WDYT?

Toggle quote (11 lines)
> + (home-page
> + "https://github.com/roelderickx/ogr2osm")
> + (synopsis
> + "Convert ogr-readable files like shapefiles into Openstreetmap(osm) format")
> + (description
> + "A tool for converting ogr-readable files into Openstreetmap(osm)
> format. Ogr2osm supports reading from ogr files like shapefiles or
> Postgres database. Ogr2osm converts data into osm or osm.pbf formats.
> A translation file can be used to manipulate the data during
> conversion.")

The description should consist of complete sentences. Also, sentences
need to be separated with two spaces.

Would you want to send an updated patch?

Regards,
--
Nicolas Goaziou
S
S
Sharlatan Hellseher wrote on 26 Jan 02:26 +0100
[PATCH] add python-ogr2osm package
(address . 59938@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
cover.1706232187.git.sharlatanus@gmail.com
Hi Nicolas and Patrick,

I've applied all suggestions mentioned re-style the package, enable simple
tests, update to the latest upstream version and tested if after build.

Please let me know if it's good now.

Thanks,
Oleg

Patrick Noll (1):
gnu: Add python-ogr2osm.

gnu/packages/geo.scm | 59 +++++++++++++++++++++++++++++++++++++++++++-
1 file changed, 58 insertions(+), 1 deletion(-)


base-commit: fdffaa2256775a48585dbc563d646fdccb96f284
--
2.41.0
S
S
Sharlatan Hellseher wrote on 26 Jan 02:26 +0100
[PATCH 1/1] gnu: Add python-ogr2osm.
(address . 59938@debbugs.gnu.org)
9a6a717bbf93c1da003a4886ccd7103f4abd7433.1706232187.git.sharlatanus@gmail.com
From: Patrick Noll <patrick@patricknoll.com>

* gnu/packages/geo.scm (python-ogr2osm): New variable.

Co-authored-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Change-Id: Id083d89dd05a9e1cdeca500daff5fab872fa15b4
---
gnu/packages/geo.scm | 59 +++++++++++++++++++++++++++++++++++++++++++-
1 file changed, 58 insertions(+), 1 deletion(-)

Toggle diff (89 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 119a9802d0..5ec1f6ce77 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -14,10 +14,11 @@
;;; Copyright © 2020, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2020, 2021, 2022, 2023 Felix Gruber <felgru@posteo.net>
-;;; Copyright © 2021, 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2021, 2023, 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021, 2023, 2024 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2021, 2022 Nikolay Korotkiy <sikmir@disroot.org>
+;;; Copyright © 2022 Patrick Noll <patrick@patricknoll.com>
;;; Copyright © 2022 Roman Scherer <roman.scherer@burningswell.com>
;;; Copyright © 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
@@ -61,6 +62,7 @@ (define-module (gnu packages geo)
#:use-module (gnu packages audio)
#:use-module (gnu packages autotools)
#:use-module (gnu packages backup)
+ #:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
@@ -974,6 +976,61 @@ (define-public python-geopandas
require a spatial database such as PostGIS.")
(license license:bsd-3)))
+(define-public python-ogr2osm
+ (package
+ (name "python-ogr2osm")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch) ; no tests data in PyPi package
+ (uri
+ (git-reference
+ (url "https://github.com/roelderickx/ogr2osm/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0hwqnx3cdqxmniydpj1v31kglq1xjsx41d8p10c9j4hg8kb43j80"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; There are tests in git checkout but non of the examples taken from
+ ;; GitHub Actions worked for me. Disabling them to be checked later
+ ;; <https://github.com/roelderickx/ogr2osm/blob/main/.github/workflows/test.yml>.
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; TODO: Fix provided tests.
+ ;; (invoke "cram" "test/basic_usage.t")
+ ;; (invoke "cram" "test/osm_output.t")
+ ;; (invoke "cram" "test/pbf_output.t")
+
+ ;; Run simple tests to ensure that the command is working.
+ (invoke "ogr2osm" "--help")
+ (invoke
+ "ogr2osm" "-f" "test/shapefiles/basic_geometries.kml")))))))
+ (inputs
+ (list gdal))
+ (native-inputs
+ (list coreutils
+ diffutils
+ libxml2
+ python-cram
+ which))
+ (propagated-inputs
+ (list python-lxml
+ python-protobuf))
+ (home-page "https://github.com/roelderickx/ogr2osm")
+ (synopsis "Convert ogr-readable files like shapefiles into OSM or PDF formats")
+ (description
+ "@code{ogr2osm} is a tool for converting ogr-readable files into
+@acronym{OSM, OpenStreetMap} format. It supports reading from OGR files like
+shapefiles or PostgresSQL database and converts data into @code{osm} or
+@code{osm.pbf} formats. A translation file can be used to manipulate the data
+during conversion.")
+ (license license:expat)))
+
(define-public python-osmnx
(package
(name "python-osmnx")
--
2.41.0
S
S
Sharlatan Hellseher wrote on 28 Jan 23:33 +0100
[PATCH] add python-ogr2osm package
(address . 59938-done@debbugs.gnu.org)
87y1c9hyv4.fsf@gmail.com
Pushed as 7bf6a6f9db23980d2e2508842dcb303a9910b839 to master.

Thanks,
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmW21j8ACgkQdtcnv/Ys
0rXc4Q/8CoAIvowsXJUEexsz4EifSvJm8UuPEEhtbs1AcXaWOYxkk68DtwGpNWRH
FHZiakpC0nisZMfVaeuJVMmAtVxkfM4XMGROVuXUPt3a/zsTqwSJsUe7nZ811ItK
shN3DQuh0ShyCvi7K9+Avh/1FWSGt14AvbT8sVHCIUQjFJDVLw60NCLWWjMOdi/r
bOliLrhGFfP8PAz7uDEFv7z98sq3+9kwWqnNW+X8s8++zbUycfiND4AUWdszWpan
gC6rs3bIv5j5K8/S2syHpSucsTOfv1y7Kj8wfcmp3sa4L0Jpa0UkGNxMbjCWuLas
H322CnP0dfrFl29ZTYYm/u1aki1Wmv8RX5/MTvRLHnu3scYvZ8eo3/q/yRelHmUD
UW9YvoCbESwv3/6/M1pocuz0L041MWmFSQTAyqnb9K31fRz37n52qvSkL2QlrZua
qxZKAtWyIQ2NHoijscZiW/i7AQB5LAYLPDpTw6ekIngmLRlxyBltxO8RIjgRzONF
LTCUEdecbsNiJzFNc1mPdZT9dCMFurncTO8kDX+N2hLcjL7d9FV81MUP3lM3cl1m
dLKOHD05H/wUh/Ayn2lFxxz5mu4DZ9SmzcTEAakxwaWckQxyrhtY8zhA06jSRvhq
751VKwnPQj3Clc8nYDUrKyJsnI1dJPSNtVVKb/wEtf1pp9bNU6I=
=ZidS
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59938@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59938
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch