gnu: Add go-git-sr-ht-adnano-go-gemini

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Howard
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Christopher Howard
Severity
normal

Debbugs page

Christopher Howard wrote 2 years ago
(address . guix-patches@gnu.org)
Y5Oto1m6qlJR4Z1n@theoden
This patch adds go-git-sr-ht-adnano-go-gemini to golang.scm.

The importer gave "go-git-sr-ht--adnano-go-gemini", but a single dash seems to be the convention for similar definitions in golang.scm.

--
馃摏 Christopher Howard
馃殌 gemini://gem.librehacker.com

讘专讗砖讬转 讘专讗 讗诇讛讬诐 讗转 讛砖诪讬诐 讜讗转 讛讗专抓
From 40a775b7c04d4ea69717be0f064d18f17eb51885 Mon Sep 17 00:00:00 2001
From: Christopher Howard <christopher@librehacker.com>
Date: Tue, 6 Dec 2022 12:42:24 -0900
Subject: [PATCH] gnu: Add go-git-sr-ht-adnano-go-gemini.

* gnu/packages/golang.scm (go-git-sr-ht-adnano-go-gemini):
New variable
---
gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 70ddef52f1..3013e158d6 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -38,6 +38,7 @@
;;; Copyright � 2022 Dhruvin Gandhi <contact@dhruvin.dev>
;;; Copyright � 2022 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright � 2022 ( <paren@disroot.org>
+;;; Copyright � 2022 Christopher Howard <christopher@librehacker.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9599,6 +9600,30 @@ (define-public go-github-com-pborman-getopt
programs that use traditional command lines.")
(license license:bsd-3)))
+(define-public go-git-sr-ht-adnano-go-gemini
+ (package
+ (name "go-git-sr-ht-adnano-go-gemini")
+ (version "0.2.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~adnano/go-gemini")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0mv4x4cfwyhh77wfb3r221bhr84x4nmjpgysnvvjgmbnnafsgfns"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "git.sr.ht/~adnano/go-gemini"))
+ (propagated-inputs `(("go-golang-org-x-net" ,go-golang-org-x-net)
+ ("go-golang-org-x-text" ,go-golang-org-x-text)))
+ (home-page "https://git.sr.ht/~adnano/go-gemini")
+ (synopsis "go-gemini")
+ (description
+ "Package gemini provides Gemini client and server implementations.")
+ (license license:expat)))
+
(define-public go-git-sr-ht-sircmpwn-getopt
(package
(name "go-git-sr-ht-sircmpwn-getopt")
--
2.38.1
Nicolas Goaziou wrote 2 years ago
(name . Christopher Howard)(address . christopher@librehacker.com)(address . 59933-done@debbugs.gnu.org)
87ttx6r5w6.fsf@nicolasgoaziou.fr
Hello,

Christopher Howard <christopher@librehacker.com> writes:

Toggle quote (2 lines)
> This patch adds go-git-sr-ht-adnano-go-gemini to golang.scm.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59933@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59933
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help