Add r-shinywidgets, r-wpm

  • Open
  • quality assurance status badge
Details
4 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • M?d?lin Ionel Patra?cu
  • Ricardo Wurmus
  • Vagrant Cascadian
Owner
unassigned
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal
M
M
MadalinIonel.Patrascu@mdc-berlin.de wrote on 8 Dec 2022 22:10
[PATCH] gnu: Add r-logging, r-shinycustomloader, r-anytime, r-shinywidgets, r-attempt, r-golem and r-wpm.
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
e9fd42d3e9f740e7b33e854751b5e4fb@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-wpm): New variable.
* gnu/packages/cran.scm (r-logging, r-shinycustomloader, r-anytime, r-shinywidgets,
r-attempt, r-golem): New variables.
All the best!
M?d?lin Ionel Patra?cu
System Administrator
The Berlin Institute for Medical Systems Biology (BIMSB)
Max Delbrück Center (MDC)
Hannoversche Straße 28
House 101, room 1.89
10115 Berlin, Germany
Attachment: file
M
M
M?d?lin Ionel Patra?cu wrote on 8 Dec 2022 22:13
[PATCH 1/7] gnu: Add r-logging.
(address . 59911@debbugs.gnu.org)
20221208211322.28459-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-logging): New variable.
---
gnu/packages/cran.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5c5258d6e0..553c53887c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -16814,6 +16814,26 @@ (define-public r-locfdr
discovery rates.")
(license license:gpl2)))
+(define-public r-logging
+ (package
+ (name "r-logging")
+ (version "0.10-108")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "logging" version))
+ (sha256
+ (base32
+ "13gd40ygx586vs6xcp6clg69a92aj8zxlk1rn3xzkx8klfjimjc5"))))
+ (properties `((upstream-name . "logging")))
+ (build-system r-build-system)
+ (home-page "https://github.com/WLOGSolutions/r-logging")
+ (synopsis "R logging implementation of log4j")
+ (description
+ "This package implements the R version of the @code{log4j} package. It offers
+hierarchic loggers, multiple handlers per logger, level based filtering, space
+handling in messages and custom formatting.")
+ (license license:gpl3)))
+
(define-public r-longitudinal
(package
(name "r-longitudinal")

base-commit: 81191e3410cc00c6438f532599dd0b96d521982f
--
2.38.1
M
M
M?d?lin Ionel Patra?cu wrote on 8 Dec 2022 22:13
[PATCH 2/7] gnu: Add r-shinycustomloader.
(address . 59911@debbugs.gnu.org)
20221208211322.28459-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-shinycustomloader): New variable.
---
gnu/packages/cran.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 553c53887c..1a5bef3cdb 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17465,6 +17465,29 @@ (define-public r-upsetr
several common set, element and attribute related tasks.")
(license license:expat)))
+(define-public r-shinycustomloader
+ (package
+ (name "r-shinycustomloader")
+ (version "0.9.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "shinycustomloader" version))
+ (sha256
+ (base32
+ "1klx71vr26g0gjf6hbiia1qidqii5d467i1sdjvlrg1hxdcggqff"))))
+ (properties `((upstream-name . "shinycustomloader")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-glue
+ r-shiny))
+ (home-page "https://cran.r-project.org/package=shinycustomloader")
+ (synopsis "Custom loader for Shiny outputs")
+ (description
+ "This package provides a custom @code{CSS/HTML} or @code{GIF/image} file
+for the loading screen in R @code{Shiny}. It also can use the marquee to have
+a custom text loading screen.")
+ (license license:gpl3)))
+
;; This package includes a JavaScript file, which is not minified. When
;; upgrading please check that there are no new minified JavaScript files.
(define-public r-shinybs
--
2.38.1
M
M
M?d?lin Ionel Patra?cu wrote on 8 Dec 2022 22:13
[PATCH 4/7] gnu: Add r-shinywidgets.
(address . 59911@debbugs.gnu.org)
20221208211322.28459-4-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-shinywidgets): New variable.
---
gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b9d5757795..9cfca2f4ca 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -25810,6 +25810,33 @@ (define-public r-shinycssloaders
automatically show a loader when the output is (re)calculating.")
(license license:gpl3)))
+(define-public r-shinywidgets
+ (package
+ (name "r-shinywidgets")
+ (version "0.7.5")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "shinyWidgets" version))
+ (sha256
+ (base32
+ "1ls28r6dbvi4pml1mxakn327dzl0l71pkaw5rm9n80jd5npq9vmz"))))
+ (properties `((upstream-name . "shinyWidgets")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-anytime
+ r-bslib
+ r-htmltools
+ r-jsonlite
+ r-rlang
+ r-sass
+ r-shiny))
+ (home-page "https://github.com/dreamRs/shinyWidgets")
+ (synopsis "Custom input widgets for Shiny")
+ (description
+ "The package offers a collection of custom input controls and user interface
+components for Shiny applications.")
+ (license license:gpl3)))
+
(define-public r-rsvg
(package
(name "r-rsvg")
--
2.38.1
M
M
M?d?lin Ionel Patra?cu wrote on 8 Dec 2022 22:13
[PATCH 5/7] gnu: Add r-attempt.
(address . 59911@debbugs.gnu.org)
20221208211322.28459-5-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-attempt): New variable.
---
gnu/packages/cran.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9cfca2f4ca..cb67edd338 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -7235,6 +7235,31 @@ (define-public r-aricode
variation information} (NVI) and entropy.")
(license license:gpl3+)))
+(define-public r-attempt
+ (package
+ (name "r-attempt")
+ (version "0.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "attempt" version))
+ (sha256
+ (base32
+ "1ylgg7jcp8wqmxgf1mydnvh26k0mr8jyjla4hw06730r40yrs58m"))))
+ (properties `((upstream-name . "attempt")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-rlang))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/ColinFay/attempt")
+ (synopsis "Tools for defensive programming")
+ (description
+ "This package provides tools for defensive programming. It is inspired by
+@code{purrr} mappers and based on @code{rlang}. @code{Attempt} extends and
+facilitates defensive programming by providing a consistent grammar, and a set
+of functions for common tests and conditions. @code{Attempt} only depends on
+@code{rlang}, and focuses on speed, so it can be integrated with other functions
+and used in the data analysis.")
+ (license license:expat)))
+
(define-public r-debugme
(package
(name "r-debugme")
--
2.38.1
M
M
M?d?lin Ionel Patra?cu wrote on 8 Dec 2022 22:13
[PATCH 3/7] gnu: Add r-anytime.
(address . 59911@debbugs.gnu.org)
20221208211322.28459-3-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-anytime): New variable.
---
gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1a5bef3cdb..b9d5757795 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -25484,6 +25484,30 @@ (define-public r-anthropometry
statistical shape analysis and archetypal analysis.")
(license license:gpl2+)))
+(define-public r-anytime
+ (package
+ (name "r-anytime")
+ (version "0.3.9")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "anytime" version))
+ (sha256
+ (base32
+ "0jjpqynai5nd7mfy1smb44356f3d5bmpxhs1i9x9jw5c959c35hh"))))
+ (properties `((upstream-name . "anytime")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-bh
+ r-rcpp))
+ (home-page "http://dirk.eddelbuettel.com/code/anytime.html")
+ (synopsis "Converter of input to POSIXct or Date")
+ (description
+ "The package converts the input in any one of character, integer, numeric,
+factor, or an ordered type into @code{POSIXct} (or @code{Date}) objects, using
+one of a number of predefined formats, and relying on Boost facilities for date
+and time parsing.")
+ (license license:gpl2+)))
+
(define-public r-anndata
(package
(name "r-anndata")
--
2.38.1
M
M
M?d?lin Ionel Patra?cu wrote on 8 Dec 2022 22:13
[PATCH 6/7] gnu: Add r-golem.
(address . 59911@debbugs.gnu.org)
20221208211322.28459-6-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-golem): New variable.
---
gnu/packages/cran.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index cb67edd338..95c3672b78 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -11126,6 +11126,43 @@ (define-public r-biasedurn
distribution).")
(license license:gpl3)))
+(define-public r-golem
+ (package
+ (name "r-golem")
+ (version "0.3.5")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "golem" version))
+ (sha256
+ (base32
+ "0rjkl1r83h0hcn30zssx64qm07sdx3g4v5rdxn56gbzfghw7ddcl"))))
+ (properties `((upstream-name . "golem")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-attempt
+ r-cli
+ r-config
+ r-crayon
+ r-desc
+ r-fs
+ r-here
+ r-htmltools
+ r-pkgload
+ r-roxygen2
+ r-rstudioapi
+ r-shiny
+ r-usethis
+ r-yaml))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/ThinkR-open/golem")
+ (synopsis "Framework for robust shiny applications")
+ (description
+ "This package implements an opinionated framework for building a production-
+ready @code{Shiny} application. @code{Golem} contains a series of tools like
+dependency management, version management, easy installation and deployment or
+documentation management.")
+ (license license:expat)))
+
(define-public r-goplot
(package
(name "r-goplot")
--
2.38.1
M
M
M?d?lin Ionel Patra?cu wrote on 8 Dec 2022 22:13
[PATCH 7/7] gnu: Add r-wpm.
(address . 59911@debbugs.gnu.org)
20221208211322.28459-7-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-wpm): New variable.
---
gnu/packages/bioconductor.scm | 42 +++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c62c5970b8..21b69cab01 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -12244,6 +12244,48 @@ (define-public r-wppi
scores and a path search algorithm.")
(license license:expat)))
+(define-public r-wpm
+ (package
+ (name "r-wpm")
+ (version "1.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "wpm" version))
+ (sha256
+ (base32
+ "05zpj0i4741xn1g0yhkq3mg9zjppfryrfc47pxnys9bjfij0az52"))))
+ (properties `((upstream-name . "wpm")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biobase
+ r-cli
+ r-config
+ r-dplyr
+ r-dt
+ r-ggplot2
+ r-golem
+ r-logging
+ r-rcolorbrewer
+ r-rlang
+ r-shiny
+ r-shinycustomloader
+ r-shinydashboard
+ r-shinywidgets
+ r-stringr
+ r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/HelBor/wpm")
+ (synopsis "Generating well plate maker")
+ (description
+ "The @acronym{WPM, Well-Plate Maker} is a Shiny application deployed as an
+R package. Functions for a command-line/script use are available. The WPM allows
+users to generate well plate maps to carry out their experiments while improving
+the handling of batch effects. In particular, it helps controlling the \"plate
+effect\" thanks to its ability to randomize samples over multiple well plates.
+The algorithm for placing the samples is inspired by the backtracking algorithm:
+the samples are placed at random while respecting specific spatial constraints.")
+ (license license:artistic2.0)))
+
(define-public r-wrench
(package
(name "r-wrench")
--
2.38.1
R
R
Ricardo Wurmus wrote on 12 Dec 2022 18:49
Re: [bug#59911] [PATCH 4/7] gnu: Add r-shinywidgets.
(name . M?d?lin Ionel Patra?cu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 59911@debbugs.gnu.org)
87edt41pfb.fsf@elephly.net
M?d?lin Ionel Patra?cu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/cran.scm (r-shinywidgets): New variable.

This cannot be added as is. We have had this package in the Guix
Science channel for a while now because it contains massive amounts of
minified JavaScript, sometimes without an obvious source.

Have you perhaps taken a look at some of these JavaScript files yet?

--
Ricardo
R
R
Ricardo Wurmus wrote on 12 Dec 2022 19:03
Re: [bug#59911] [PATCH 1/7] gnu: Add r-logging.
(name . M?d?lin Ionel Patra?cu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 59911@debbugs.gnu.org)
87a63s1opr.fsf@elephly.net
I applied five of these seven patches. As I wrote earlier
r-shinywidgets contains minified JavaScript that would need to be
compiled from source instead. Consequently, r-wpm cannot be accepted
because it depends on r-shinywidgets.

Could you please look into compiling the JavaScript from shinywidgets
from source? We have a couple of other R packages that come with
minified JavaScript, and we modify them to remove the minified
JavaScript in a snippet, add the sources as native inputs, and then use
a build phase to compile them with esbuild.

--
Ricardo
R
R
Ricardo Wurmus wrote on 29 Dec 2022 23:49
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
87lemp7rkw.fsf@elephly.net
tags 59911 moreinfo
thanks

--
Ricardo
V
V
Vagrant Cascadian wrote on 2 Sep 2023 06:41
8734zxp4p4.fsf@wireframe
retitle 59911 Add r-shinywidgets, r-wpm
thanks

On 2022-12-12, Ricardo Wurmus wrote:
Toggle quote (5 lines)
> I applied five of these seven patches. As I wrote earlier
> r-shinywidgets contains minified JavaScript that would need to be
> compiled from source instead. Consequently, r-wpm cannot be accepted
> because it depends on r-shinywidgets.

Updating bug title appropriately.

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZPK89wAKCRDcUY/If5cW
qgKLAP9LMXG4MrsmXB5n5BKWlRjXyxgpKIcGw/m7T9SzQLrixgD+Nr1jMH0IYdFP
74XASFxWiNI0I0ON7vJXKTyIpnetUQQ=
=n+Md
-----END PGP SIGNATURE-----

?