[PATCH] gnu: Add r-rcppde, r-ptw, r-pepsnmr and r-asics.

  • Done
  • quality assurance status badge
Details
3 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • M?d?lin Ionel Patra?cu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal
M
M
MadalinIonel.Patrascu@mdc-berlin.de wrote on 8 Dec 2022 19:41
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
2916bd5df8054870a70ba29c5fde484c@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-pepsnmr, r-asics): New variables.
* gnu/packages/cran.scm (r-rcppde, r-ptw): New variables.
Attachment: file
M
M
M?d?lin Ionel Patra?cu wrote on 8 Dec 2022 20:22
[PATCH 2/4] gnu: Add r-ptw.
(address . 59908@debbugs.gnu.org)
20221208192232.16413-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-ptw): New variable.
---
gnu/packages/cran.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 016eeb4821..4561d50e02 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4858,6 +4858,32 @@ (define-public r-powerlaw
;; Any of these GPL versions.
(license (list license:gpl2 license:gpl3))))
+(define-public r-ptw
+ (package
+ (name "r-ptw")
+ (version "1.9-16")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "ptw" version))
+ (sha256
+ (base32
+ "0rma3h9ksc5qigdvk5vappb4ipd4rpk64wckzcxvxspakr5w71vy"))))
+ (properties `((upstream-name . "ptw")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-rcppde))
+ (home-page "https://github.com/rwehrens/ptw")
+ (synopsis "Parametric time warping")
+ (description
+ "Parametric time warping aligns patterns. It aims to put corresponding
+features at the same locations. The algorithm searches for an optimal polynomial
+describing the warping. It is possible to align one sample to a reference, several
+samples to the same reference, or several samples to several references. One can
+choose between calculating individual warpings, or one global warping for a set
+of samples and one reference. Two optimization criteria are implemented: @acronym{
+RMS, Root Mean Square} error and @acronym{WCC, Weighted Cross Correlation}. Both
+warping of peak profiles and of peak lists are supported.")
+ (license license:gpl2+)))
+
(define-public r-compare
(package
(name "r-compare")
--
2.38.1
M
M
M?d?lin Ionel Patra?cu wrote on 8 Dec 2022 20:22
[PATCH 1/4] gnu: Add r-rcppde.
(address . 59908@debbugs.gnu.org)
20221208192232.16413-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-rcppde): New variable.
---
gnu/packages/cran.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5c5258d6e0..016eeb4821 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4569,6 +4569,32 @@ (define-public r-rcpp
@code{citation(\"Rcpp\")} for details on these last two.")
(license license:gpl2+)))
+(define-public r-rcppde
+ (package
+ (name "r-rcppde")
+ (version "0.1.6")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "RcppDE" version))
+ (sha256
+ (base32
+ "1i9jj595nqpb16y22z2b8fcf0gq1fg0pbiisbd837p1cyw4nff69"))))
+ (properties `((upstream-name . "RcppDE")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-rcpp
+ r-rcpparmadillo))
+ (home-page "https://cran.r-project.org/package=RcppDE")
+ (synopsis "Global optimization by differential evolution in C++")
+ (description
+ "This package provides an iteration of the @code{DEoptim} function. It
+performs global optimization by differential evolution. The implementation
+employs the @code{Rcpp} package. The last one provides tools for integration
+of R objects at the C++ level—and vice versa. @code{R-rcppde} uses the @code{
+RcppArmadillo} package. This one provides an interface from R to the Armadillo
+linear algebra package written in C++.")
+ (license license:gpl2+)))
+
(define-public r-rcppml
(package
(name "r-rcppml")

base-commit: 81191e3410cc00c6438f532599dd0b96d521982f
--
2.38.1
M
M
M?d?lin Ionel Patra?cu wrote on 8 Dec 2022 20:22
[PATCH 3/4] gnu: Add r-pepsnmr.
(address . 59908@debbugs.gnu.org)
20221208192232.16413-3-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-pepsnmr): New variable.
---
gnu/packages/bioconductor.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c62c5970b8..740ec4b84b 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -8323,6 +8323,35 @@ (define-public r-perfmeas
a given recall, F-score for single and multiple classes are available.")
(license license:gpl2+)))
+(define-public r-pepsnmr
+ (package
+ (name "r-pepsnmr")
+ (version "1.16.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "PepsNMR" version))
+ (sha256
+ (base32
+ "02i29jinawssqlb33wvj0h9w6cfcvamlyfxdynd38jmwx23l15l5"))))
+ (properties `((upstream-name . "PepsNMR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-ggplot2
+ r-gridextra
+ r-matrix
+ r-matrixstats
+ r-ptw
+ r-reshape2))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/ManonMartin/PepsNMR")
+ (synopsis "Pre-process 1H-NMR FID signals")
+ (description
+ "This package provides R functions for common pre-processing steps that are
+applied on @acronym{1H-NMR, proton nuclear magnetic resonance} data. It also
+provides a function to read the @acronym{FID, free induction decay} signals
+directly in the Bruker format.")
+ (license license:gpl2)))
+
;; This is a CRAN package, but it depends on a Bioconductor package.
(define-public r-codedepends
(package
--
2.38.1
M
M
M?d?lin Ionel Patra?cu wrote on 8 Dec 2022 20:22
[PATCH 4/4] gnu: Add r-asics.
(address . 59908@debbugs.gnu.org)
20221208192232.16413-4-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-asics): New variable.
---
gnu/packages/bioconductor.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 740ec4b84b..64dbea97d0 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2720,6 +2720,40 @@ (define-public r-asgsca
model as latent variables.")
(license license:gpl3)))
+(define-public r-asics
+ (package
+ (name "r-asics")
+ (version "2.14.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ASICS" version))
+ (sha256
+ (base32
+ "0c2b3gdza58vqhharhw8967p2w2knnrm5s2svvnnjbf67qbg45b7"))))
+ (properties `((upstream-name . "ASICS")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocparallel
+ r-ggplot2
+ r-glmnet
+ r-gridextra
+ r-matrix
+ r-mvtnorm
+ r-pepsnmr
+ r-plyr
+ r-quadprog
+ r-ropls
+ r-summarizedexperiment
+ r-zoo))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/ASICS")
+ (synopsis "Automatic statistical identification in complex spectra")
+ (description
+ "@code{ASICS} quantifies concentration of metabolites in a complex spectrum.
+The identification of metabolites is performed by fitting a mixture model to the
+spectra of the library with a sparse penalty.")
+ (license license:gpl2+)))
+
(define-public r-aspli
(package
(name "r-aspli")
--
2.38.1
R
R
Ricardo Wurmus wrote on 12 Dec 2022 18:44
Re: [bug#59908] [PATCH 1/4] gnu: Add r-rcppde.
(name . M?d?lin Ionel Patra?cu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 59908-done@debbugs.gnu.org)
87ilig1ppg.fsf@elephly.net
Thanks for the patches. I applied them with negligible formatting
changes.

--
Ricardo
Closed
?