[PATCH] gnu: Add python-poppy.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 8 Dec 2022 01:02
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221208000259.18624-1-sharlatanus@gmail.com
* gnu/packages/astronomy.scm (python-poppy): New variable.
---
gnu/packages/astronomy.scm | 45 ++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index c59f4d02a4..fb00a90129 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -66,6 +66,7 @@ (define-module (gnu packages astronomy)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages sphinx)
#:use-module (gnu packages textutils)
#:use-module (gnu packages time)
#:use-module (gnu packages version-control)
@@ -1336,6 +1337,50 @@ (define-public python-photutils
of astronomical sources.")
(license license:bsd-3)))
+(define-public python-poppy
+ (package
+ (name "python-poppy")
+ (version "1.0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "poppy" version))
+ (sha256
+ (base32
+ "050cn6aabd1dxbi7zihbqnkl79hz6q6d5n6g25zmrpvc4sii171m"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs
+ ;; XXX: With python-synphot (marked as optional) package added to the list
+ ;; it tries to download from remote host during tests and fails. Overall
+ ;; tests take up to 5-8min to pass.
+ (list python-astropy
+ python-matplotlib
+ python-numpy
+ python-scipy))
+ (native-inputs
+ (list python-docutils
+ python-h5py
+ python-pandas
+ python-pytest
+ python-pytest-astropy
+ python-sphinx
+ python-setuptools-scm))
+ (home-page "https://poppy-optics.readthedocs.io/")
+ (synopsis "Physical Optics Propagation in Python")
+ (description
+ "@acronym{POPPY, Physical Optics Propagation in Python} is a Python package that
+simulates physical optical propagation including diffraction. It implements a
+flexible framework for modeling Fraunhofer and Fresnel diffraction and point
+spread function formation, particularly in the context of astronomical
+telescopes.
+
+POPPY was developed as part of a simulation package for the James Webb Space
+Telescope, but is more broadly applicable to many kinds of imaging simulations.
+It is not, however, a substitute for high fidelity optical design software such
+as Zemax or Code V, but rather is intended as a lightweight alternative for
+cases for which diffractive rather than geometric optics is the topic of
+interest, and which require portability between platforms or ease of scripting.")
+ (license license:bsd-3)))
+
(define-public python-pyvo
(package
(name "python-pyvo")
--
2.38.1
S
S
Sharlatan Hellseher wrote on 13 Jan 2023 22:55
(address . 59892@debbugs.gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
CAO+9K5pxEQ=pK4Sr60A_quG3DAdkMQ0V1BPDaYS12PC=6F_Pjw@mail.gmail.com
Hi Ludo,
Thanks for merging updates for Astropy and related packages in #59978.
I see that the Science group where Astronomy is listed in scope has no
members that's why I mention you on this issue :)
QA is green it's just one more Astro packages to Guix collection, let
me know if I need to update anything on the patch.
Regards,
Oleg
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
M
M
Maxim Cournoyer wrote on 16 Jan 2023 18:14
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 59892-done@debbugs.gnu.org)
87pmbe5rlp.fsf@gmail.com
Hi,

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/astronomy.scm (python-poppy): New variable.

LGTM! Applied, thanks for your contribution.

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59892@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59892
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch