[PATCH] gnu: rawtherapee: Update to 5.9.

  • Done
  • quality assurance status badge
Details
3 participants
  • 宋文武
  • (
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 2 years ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221207223757.900-1-sharlatanus@gmail.com
* gnu/packages/photo.scm (rawtherapee): Update to 5.9.
[arguments]: Use gexp.
[inputs]: Remove labels.
---
gnu/packages/photo.scm | 67 +++++++++++++++++++++---------------------
1 file changed, 34 insertions(+), 33 deletions(-)

Toggle diff (91 lines)
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index d86d4e7294..d8b0df22d1 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -755,50 +755,51 @@ (define-public hugin
(define-public rawtherapee
(package
(name "rawtherapee")
- (version "5.8")
+ (version "5.9")
(source (origin
(method url-fetch)
(uri (string-append "https://rawtherapee.com/shared/source/"
"rawtherapee-" version ".tar.xz"))
(sha256
(base32
- "0lq8qi7g0a28h3rab7bk5bbbd4gvfma42bvlz1dfn8p9mah2h19n"))))
+ "08s81mxnrj183bss2rb0hac1qyn7bmcnk3x2ymg1cp0q5322ibwf"))))
(build-system cmake-build-system)
(arguments
- '(#:tests? #f ; no test suite
- #:build-type "release"
- #:configure-flags
- (list (string-append "-DLENSFUNDBDIR="
- (assoc-ref %build-inputs "lensfun")
- "/share/lensfun")
- ;; Don't optimize the build for the host machine. See the file
- ;; 'ProcessorTargets.cmake' in the source distribution for more
- ;; information.
- "-DPROC_TARGET_NUMBER=1"
- ;; These flags are recommended by upstream for distributed packages.
- ;; See the file 'RELEASE_NOTES.txt' in the source distribution.
- "-DCMAKE_CXX_FLAGS=-O3 -fPIC"
- "-DCMAKE_C_FLAGS=-O3 -fPIC"
- "-DCACHE_NAME_SUFFIX=\"\"")))
+ (list
+ #:tests? #f ; no test suite
+ #:build-type "release"
+ #:configure-flags
+ #~(list (string-append "-DLENSFUNDBDIR="
+ (assoc-ref %build-inputs "lensfun")
+ "/share/lensfun")
+ ;; Don't optimize the build for the host machine. See the file
+ ;; 'ProcessorTargets.cmake' in the source distribution for more
+ ;; information.
+ "-DPROC_TARGET_NUMBER=1"
+ ;; These flags are recommended by upstream for distributed packages.
+ ;; See the file 'RELEASE_NOTES.txt' in the source distribution.
+ "-DCMAKE_CXX_FLAGS=-O3 -fPIC"
+ "-DCMAKE_C_FLAGS=-O3 -fPIC"
+ "-DCACHE_NAME_SUFFIX=\"\"")))
(native-inputs
(list pkg-config))
(inputs
- `(("expat" ,expat)
- ("fftw" ,fftwf)
- ("glib" ,glib)
- ("glibmm" ,glibmm)
- ("gtk+" ,gtk+)
- ("gtkmm" ,gtkmm-3)
- ("lcms" ,lcms)
- ("lensfun" ,lensfun)
- ("libcanberra" ,libcanberra)
- ("libiptcdata" ,libiptcdata)
- ("libjpeg" ,libjpeg-turbo)
- ("libpng" ,libpng)
- ("librsvg" ,librsvg)
- ("libsigc++" ,libsigc++)
- ("libtiff" ,libtiff)
- ("zlib" ,zlib)))
+ (list expat
+ fftwf
+ glib
+ glibmm
+ gtk+
+ gtkmm-3
+ lcms
+ lensfun
+ libcanberra
+ libiptcdata
+ libjpeg-turbo
+ libpng
+ librsvg
+ libsigc++
+ libtiff
+ zlib))
(home-page "https://rawtherapee.com")
(synopsis "Raw image developing and processing")
(description "RawTherapee is a raw image processing suite. It comprises a
--
2.38.1
( wrote 2 years ago
COVY4PZYFWCJ.BF3NO94J887K@guix-framework
Heya,

On Wed Dec 7, 2022 at 10:37 PM GMT, Sharlatan Hellseher wrote:
Toggle quote (11 lines)
> * gnu/packages/photo.scm (rawtherapee): Update to 5.9.
> [arguments]: Use gexp.
> [inputs]: Remove labels.

> --- a/gnu/packages/photo.scm
> +++ b/gnu/packages/photo.scm

> @@ -755,50 +755,51 @@ (define-public hugin

> + (assoc-ref %build-inputs "lensfun")

You should replace this with:

#$(this-package-input "lensfun")

-- (
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEE6Vh10NblKE5doNlW7ImHg/nqI20FAmORFp8ACgkQ7ImHg/nq
I20dpwv/Zm4fikeEcJLf33ZhkXuHFdp2jLlqvgkYwMK67vHti3XcDm0Jh+oWciiz
BPfqkjgLt3JHbFK2mWgrS9GiAErxfBwRz3NqgMAF39akUhE+2zHt5BoAa97sjhEW
T4uDxX4Rb1D1ovjaS6ARIvR8E253mqNGHGaKy5RlKheXmdV5oRkjRLxD7xNuz37r
VyCHa0UXUiCTLuigmF2iXTHVvYcJuMnThYImLqmNemG9PrjlrJaZBTIclXEqn0M5
VVwOFD9n0vAm82WLAELlXV5Abl6h9WTfKJKYRoxR4PmZ478Qxcx/7lQxYopJA2x+
r3eYTTXv3xZIPwGJ3vEWrXjiOQgKiZGkvhHwC6oKUxvVqJL0QAZ2WlZWwSU09rCE
wNRQzwYb8/YZMa1FnU+EikcrL2mxc3Mad9nMDTijlmpf/2Q4J4jz2ndnR2gz0GYS
LirPZ9mHSPRzQW0g0yuoBoBNikweDNfZbxdTcXEBLAmo4q2tvM7YuKJRtUhl65b8
8HxmGA4e
=XWRF
-----END PGP SIGNATURE-----


Sharlatan Hellseher wrote 2 years ago
[PATCH] gnu: rawtherapee: Update to 5.9.
(address . 59890@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221209002705.23294-1-sharlatanus@gmail.com
* gnu/packages/photo.scm (rawtherapee): Update to 5.9.
[arguments]: Use gexp.
[inputs]: Remove labels.
---
gnu/packages/photo.scm | 67 +++++++++++++++++++++---------------------
1 file changed, 34 insertions(+), 33 deletions(-)

Toggle diff (93 lines)
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index d86d4e7294..4d85611101 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -755,50 +755,51 @@ (define-public hugin
(define-public rawtherapee
(package
(name "rawtherapee")
- (version "5.8")
+ (version "5.9")
(source (origin
(method url-fetch)
(uri (string-append "https://rawtherapee.com/shared/source/"
"rawtherapee-" version ".tar.xz"))
(sha256
(base32
- "0lq8qi7g0a28h3rab7bk5bbbd4gvfma42bvlz1dfn8p9mah2h19n"))))
+ "08s81mxnrj183bss2rb0hac1qyn7bmcnk3x2ymg1cp0q5322ibwf"))))
(build-system cmake-build-system)
(arguments
- '(#:tests? #f ; no test suite
- #:build-type "release"
- #:configure-flags
- (list (string-append "-DLENSFUNDBDIR="
- (assoc-ref %build-inputs "lensfun")
- "/share/lensfun")
- ;; Don't optimize the build for the host machine. See the file
- ;; 'ProcessorTargets.cmake' in the source distribution for more
- ;; information.
- "-DPROC_TARGET_NUMBER=1"
- ;; These flags are recommended by upstream for distributed packages.
- ;; See the file 'RELEASE_NOTES.txt' in the source distribution.
- "-DCMAKE_CXX_FLAGS=-O3 -fPIC"
- "-DCMAKE_C_FLAGS=-O3 -fPIC"
- "-DCACHE_NAME_SUFFIX=\"\"")))
+ (list
+ #:tests? #f ; no test suite
+ #:build-type "release"
+ #:configure-flags
+ #~(list (string-append "-DLENSFUNDBDIR="
+ #$(this-package-input "lensfun")
+ "/share/lensfun")
+ ;; Don't optimize the build for the host machine. See the file
+ ;; 'ProcessorTargets.cmake' in the source distribution for more
+ ;; information.
+ "-DPROC_TARGET_NUMBER=1"
+ ;; These flags are recommended by upstream for distributed packages.
+ ;; See the file 'RELEASE_NOTES.txt' in the source distribution.
+ "-DCMAKE_CXX_FLAGS=-O3 -fPIC"
+ "-DCMAKE_C_FLAGS=-O3 -fPIC"
+ "-DCACHE_NAME_SUFFIX=\"\"")))
(native-inputs
(list pkg-config))
(inputs
- `(("expat" ,expat)
- ("fftw" ,fftwf)
- ("glib" ,glib)
- ("glibmm" ,glibmm)
- ("gtk+" ,gtk+)
- ("gtkmm" ,gtkmm-3)
- ("lcms" ,lcms)
- ("lensfun" ,lensfun)
- ("libcanberra" ,libcanberra)
- ("libiptcdata" ,libiptcdata)
- ("libjpeg" ,libjpeg-turbo)
- ("libpng" ,libpng)
- ("librsvg" ,librsvg)
- ("libsigc++" ,libsigc++)
- ("libtiff" ,libtiff)
- ("zlib" ,zlib)))
+ (list expat
+ fftwf
+ glib
+ glibmm
+ gtk+
+ gtkmm-3
+ lcms
+ lensfun
+ libcanberra
+ libiptcdata
+ libjpeg-turbo
+ libpng
+ librsvg
+ libsigc++
+ libtiff
+ zlib))
(home-page "https://rawtherapee.com")
(synopsis "Raw image developing and processing")
(description "RawTherapee is a raw image processing suite. It comprises a

base-commit: dfa0f34ee76e61e4343cc49ab2b302773cc04507
--
2.38.1
宋文武 wrote 2 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 59890-done@debbugs.gnu.org)
875yel9k10.fsf_-_@envs.net
Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (4 lines)
> * gnu/packages/photo.scm (rawtherapee): Update to 5.9.
> [arguments]: Use gexp.
> [inputs]: Remove labels.

Pushed, thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59890@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59890
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help