[PATCH] gnu: Add r-animalcules, r-plotroc, r-gridsvg, r-gunifrac, r-dirmult, r-modeest, r-fbasics, r-timeseries, r-gss, r-stable, r-rmutil, r-statip.

  • Done
  • quality assurance status badge
Details
3 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal

Debbugs page

MadalinIonel.Patrascu@mdc-berlin.de wrote 2 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
8e198ab0c3044a9fbf8488431475f0e7@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-animalcules): New variable.
* gnu/packages/cran.scm (r-plotroc, r-gridsvg, r-gunifrac, r-dirmult, r-modeest,
r-fbasics, r-timeseries, r-gss, r-stable, r-rmutil, r-statip): New variables.
Attachment: file
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 02/12] gnu: Add r-rmutil.
(address . 59870@debbugs.gnu.org)
20221207051837.10970-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-rmutil): New variable.
---
gnu/packages/cran.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d23265ad07..792fcf1a7d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -16231,6 +16231,28 @@ (define-public r-rmpfr
Precision Floating-Point Reliable} (MPFR) library.")
(license license:gpl2+)))
+(define-public r-rmutil
+ (package
+ (name "r-rmutil")
+ (version "1.1.10")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "rmutil" version))
+ (sha256
+ (base32
+ "1yd5gkg4jg3rvqrfl8c5r07lcr37n1p9h1a7b6s45iswd77dg7w1"))))
+ (properties `((upstream-name . "rmutil")))
+ (build-system r-build-system)
+ (native-inputs (list gfortran))
+ (home-page "https://www.commanster.eu/rcode.html")
+ (synopsis
+ "Utilities for nonlinear regression and repeated measurements models")
+ (description
+ "This package provides a toolkit of functions for nonlinear regression and
+repeated measurements. It was designated to be imported by other packages such
+as @code{gnlm}, @code{stable}, @code{growth}, @code{repeated}, and @code{event}.")
+ (license license:gpl2+)))
+
(define-public r-assertive-base
(package
(name "r-assertive-base")
--
2.38.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 03/12] gnu: Add r-stable.
(address . 59870@debbugs.gnu.org)
20221207051837.10970-3-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-stable): New variable.
---
gnu/packages/cran.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 792fcf1a7d..b773c6aeb9 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6452,6 +6452,28 @@ (define-public r-corrplot
;; Any version of the GPL
(license license:gpl2+)))
+(define-public r-stable
+ (package
+ (name "r-stable")
+ (version "1.1.6")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "stable" version))
+ (sha256
+ (base32
+ "194xsa291v5f0jya1c3aigbclg8cci427ffpb8brxamm6n57hf12"))))
+ (properties `((upstream-name . "stable")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-rmutil))
+ (home-page "https://www.commanster.eu/rcode.html")
+ (synopsis
+ "Probability functions and regression models for stable distributions")
+ (description
+ "This package provides density, distribution, quantile and hazard functions
+of a stable variate; generalized regression models for the parameters of a stable
+distribution.")
+ (license license:gpl2+)))
+
(define-public r-statip
(package
(name "r-statip")
--
2.38.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 07/12] gnu: Add r-modeest.
(address . 59870@debbugs.gnu.org)
20221207051837.10970-7-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-modeest): New variable.
---
gnu/packages/cran.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6239a53d85..4e35435e46 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -31049,6 +31049,31 @@ (define-public r-modeldata
model-related packages.")
(license license:expat)))
+(define-public r-modeest
+ (package
+ (name "r-modeest")
+ (version "2.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "modeest" version))
+ (sha256
+ (base32
+ "087dw0013y4m7fcl06mxylh9lnp6acysl80d80r9srv4pw4r950s"))))
+ (properties `((upstream-name . "modeest")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-fbasics
+ r-stable
+ r-stabledist
+ r-statip))
+ (home-page "https://github.com/paulponcet/modeest")
+ (synopsis "Mode estimations for univariate data or distributions")
+ (description
+ "The package provides estimators of the mode of univariate unimodal (and
+sometimes multimodal) data and values of the modes of usual probability
+distributions.")
+ (license license:gpl3)))
+
(define-public r-conflicted
(package
(name "r-conflicted")
--
2.38.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 04/12] gnu: Add r-gss.
(address . 59870@debbugs.gnu.org)
20221207051837.10970-4-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-gss): New variable.
---
gnu/packages/cran.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b773c6aeb9..bb163aa47a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -7228,6 +7228,26 @@ (define-public r-ggjoy
plots in @code{ggplot2}.")
(license license:gpl2)))
+(define-public r-gss
+ (package
+ (name "r-gss")
+ (version "2.2-3")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "gss" version))
+ (sha256
+ (base32
+ "0jr45lkpcndg5nynjsfnxn1wwkh4gkhsgv4hlvw6jn2frw0n8c14"))))
+ (properties `((upstream-name . "gss")))
+ (build-system r-build-system)
+ (native-inputs (list gfortran))
+ (home-page "https://cran.r-project.org/package=gss")
+ (synopsis "General smoothing splines")
+ (description
+ "This package provides a comprehensive collection for structural multivariate
+function estimation using smoothing splines.")
+ (license license:gpl2+)))
+
(define-public r-cli
(package
(name "r-cli")
--
2.38.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 01/12] gnu: Add r-statip.
(address . 59870@debbugs.gnu.org)
20221207051837.10970-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-statip): New variable.
---
gnu/packages/cran.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5c5258d6e0..d23265ad07 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6452,6 +6452,41 @@ (define-public r-corrplot
;; Any version of the GPL
(license license:gpl2+)))
+(define-public r-statip
+ (package
+ (name "r-statip")
+ (version "0.2.3")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "statip" version))
+ (sha256
+ (base32
+ "0kymc3ds1nx0h11ffmm3vmqr1w34gd0k788vf72x2v45h8c1ma2n"))))
+ (properties `((upstream-name . "statip")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-clue
+ r-rpart))
+ (home-page "https://github.com/paulponcet/statip")
+ (synopsis
+ "Statistical functions for probability distributions and regression")
+ (description
+ "This package provides a collection of miscellaneous statistical functions for:
+@itemize
+@item probability distributions: @code{dbern()}, @code{pbern()}, @code{qbern()},
+@code{rbern()} for the Bernoulli distribution, and @code{distr2name()}, @code{
+name2distr()} for distribution names;
+@item probability density estimation: @code{densityfun()};
+@item most frequent value estimation: @code{mfv()}, @code{mfv1()};
+@item other statistical measures of location: @code{cv()} (coefficient of
+variation), @code{midhinge()}, @code{midrange()}, @code{trimean()};
+@item construction of histograms: @code{histo()}, @code{find_breaks()};
+@item calculation of the Hellinger distance: @code{hellinger()};
+@item use of classical kernels: @code{kernelfun()}, @code{kernel_properties()};
+@item univariate piecewise-constant regression: @code{picor()}.
+@end itemize")
+ (license license:gpl3)))
+
(define-public r-stringdist
(package
(name "r-stringdist")

base-commit: b2a848d23d37f31496e1ff664f1dcf6abcdcc388
--
2.38.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 05/12] gnu: Add r-timeseries.
(address . 59870@debbugs.gnu.org)
20221207051837.10970-5-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-timeseries): New variable.
---
gnu/packages/cran.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index bb163aa47a..36c1d72a66 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -7357,6 +7357,28 @@ (define-public r-processx
timeout. It can also poll several processes at once.")
(license license:expat)))
+(define-public r-timeseries
+ (package
+ (name "r-timeseries")
+ (version "4021.105")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "timeSeries" version))
+ (sha256
+ (base32
+ "1k6vihbs20m7zjrxh13y9mmsvnia3844c7j13p0b7m5i9fb6rqxz"))))
+ (properties `((upstream-name . "timeSeries")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-timedate))
+ (home-page
+ "https://r-forge.r-project.org/scm/viewvc.php/pkg/timeSeries/?root=rmetrics")
+ (synopsis "Metrics for financial time series objects")
+ (description
+ "This package implements S4 classes and various tools for financial time series.
+Basic functions such as scaling and sorting, subsetting, mathematical operations
+and statistical functions are provided.")
+ (license license:gpl2+)))
+
(define-public r-tsp
(package
(name "r-tsp")
--
2.38.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 06/12] gnu: Add r-fbasics.
(address . 59870@debbugs.gnu.org)
20221207051837.10970-6-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-fbasics): New variable.
---
gnu/packages/cran.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 36c1d72a66..6239a53d85 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8364,6 +8364,36 @@ (define-public r-extradistr
multivariate distributions.")
(license license:gpl2)))
+(define-public r-fbasics
+ (package
+ (name "r-fbasics")
+ (version "4021.93")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "fBasics" version))
+ (sha256
+ (base32
+ "1lmmdwzvqhggy6rr7yc9y5f8hxxgyzsgwm3ry0sz5ljbgfijl7g6"))))
+ (properties `((upstream-name . "fBasics")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-gss
+ r-mass
+ r-spatial
+ r-stabledist
+ r-timedate
+ r-timeseries))
+ (home-page
+ "https://r-forge.r-project.org/scm/viewvc.php/pkg/fBasics/?root=rmetrics")
+ (synopsis "Metrics for markets and basic statistics")
+ (description
+ "This package provides a collection of functions to explore and to investigate
+basic properties of financial returns and related quantities. The covered fields
+include techniques of explorative data analysis and the investigation of
+distributional properties, including parameter estimation and hypothesis testing.
+Even more, there are several utility functions for data handling and management.")
+ (license license:gpl2+)))
+
(define-public r-fractal
(package
(name "r-fractal")
--
2.38.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 08/12] gnu: Add r-dirmult.
(address . 59870@debbugs.gnu.org)
20221207051837.10970-8-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-dirmult): New variable.
---
gnu/packages/cran.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4e35435e46..415098aed3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -399,6 +399,25 @@ (define-public r-dirichletreg
(description "This package implements Dirichlet regression models.")
(license license:gpl2+)))
+(define-public r-dirmult
+ (package
+ (name "r-dirmult")
+ (version "0.1.3-5")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "dirmult" version))
+ (sha256
+ (base32
+ "05whzhl81nyag7321hw98xa63r440s9bgj1764346yvm9bvzjqi4"))))
+ (properties `((upstream-name . "dirmult")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/package=dirmult")
+ (synopsis "Estimation in Dirichlet-Multinomial distribution")
+ (description
+ "This package estimates the parameters in Dirichlet-Multinomial and computes
+log-likelihoods.")
+ (license license:gpl2+)))
+
(define-public r-dixontest
(package
(name "r-dixontest")
--
2.38.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 10/12] gnu: Add r-gridsvg.
(address . 59870@debbugs.gnu.org)
20221207051837.10970-10-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-gridsvg): New variable.
---
gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 646737ea31..b61ee1c2dc 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -16005,6 +16005,30 @@ (define-public r-tractor-base
handling.")
(license license:gpl2)))
+(define-public r-gridsvg
+ (package
+ (name "r-gridsvg")
+ (version "1.7-4")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "gridSVG" version))
+ (sha256
+ (base32
+ "1jspjn56yrkx98hhs98npzm0k0kwpv8x1hg40kphx5ikhvincxmr"))))
+ (properties `((upstream-name . "gridSVG")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-jsonlite
+ r-xml))
+ (home-page "https://cran.r-project.org/package=gridSVG")
+ (synopsis "Export grid gaphics as SVG")
+ (description
+ "This package provides functions to export graphics drawn with package grid
+to SVG format. Extra functions provide access to SVG features that are not
+available in standard R graphics, such as hyperlinks, animation, filters, masks,
+clipping paths, and gradient and pattern fills.")
+ (license (list license:gpl2 license:gpl3)))) ;;is specified only GPL
+
(define-public r-grimport
(package
(name "r-grimport")
--
2.38.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 09/12] gnu: Add r-gunifrac.
(address . 59870@debbugs.gnu.org)
20221207051837.10970-9-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-gunifrac): New variable.
---
gnu/packages/cran.scm | 44 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 415098aed3..646737ea31 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -667,6 +667,50 @@ (define-public r-guix-install
repositories, replacing the need for installation via @code{devtools}.")
(license license:gpl3+)))
+(define-public r-gunifrac
+ (package
+ (name "r-gunifrac")
+ (version "1.7")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "GUniFrac" version))
+ (sha256
+ (base32
+ "13qb5fw9km6p5x8li9x3liqbh833wf2v73npj8jl3msplzfk82vp"))))
+ (properties `((upstream-name . "GUniFrac")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-ape
+ r-dirmult
+ r-foreach
+ r-ggplot2
+ r-ggrepel
+ r-mass
+ r-matrix
+ r-matrixstats
+ r-modeest
+ r-rcpp
+ r-rmutil
+ r-statmod
+ r-vegan))
+ (native-inputs (list r-knitr))
+ (home-page "https://cran.r-project.org/package=GUniFrac")
+ (synopsis
+ "Generalized UniFrac distances and methods for microbiome data analysis")
+ (description
+ "This package provides a suite of methods for powerful and robust microbiome
+data analysis, including data normalization, data simulation, community-level
+association testing and differential abundance analysis. It implements generalized
+UniFrac distances, Geometric Mean of Pairwise Ratios (GMPR) normalization,
+semiparametric data simulator, distance-based statistical methods, and feature-
+based statistical methods. The distance-based statistical methods include three
+extensions of PERMANOVA: (1) PERMANOVA using the Freedman-Lane permutation scheme,
+(2) PERMANOVA omnibus test using multiple matrices, and (3) analytical approach
+to approximating PERMANOVA p-value. Feature-based statistical methods include
+linear model-based methods for differential abundance analysis of zero-inflated
+high-dimensional compositional data.")
+ (license license:gpl3)))
+
(define-public r-ids
(package
(name "r-ids")
--
2.38.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 11/12] gnu: Add r-plotroc.
(address . 59870@debbugs.gnu.org)
20221207051837.10970-11-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-plotroc): New variable.
---
gnu/packages/cran.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b61ee1c2dc..87c22810d5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -21844,6 +21844,36 @@ (define-public r-plot3d
includes data sets from oceanography.")
(license license:gpl3+)))
+(define-public r-plotroc
+ (package
+ (name "r-plotroc")
+ (version "2.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "plotROC" version))
+ (sha256
+ (base32
+ "0kaz9hrimi9gi7cf7flag9kc9yrg5fdyylqa5hn53x4dy8vhj37g"))))
+ (properties `((upstream-name . "plotROC")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-ggplot2
+ r-gridsvg
+ r-plyr
+ r-rlang
+ r-shiny))
+ (native-inputs (list r-knitr))
+ (home-page "https://sachsmc.github.io/plotROC/")
+ (synopsis "Generating useful receiver operating characteristic curve charts")
+ (description
+ "This package generates @acronym{ROC, receiver operating characteristic}
+plots. Most ROC curve plots obscure the cutoff values and inhibit interpretation
+and comparison of multiple curves. This attempts to address those shortcomings
+by providing plotting and interactive tools. Functions are provided to generate
+an interactive ROC curve plot for web use, and print versions. A Shiny application
+implementing the functions is also included.")
+ (license license:expat)))
+
(define-public r-ggfortify
(package
(name "r-ggfortify")
--
2.38.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 12/12] gnu: Add r-animalcules.
(address . 59870@debbugs.gnu.org)
20221207051837.10970-12-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-animalcules): New variable.
---
gnu/packages/bioconductor.scm | 59 +++++++++++++++++++++++++++++++++++
1 file changed, 59 insertions(+)

Toggle diff (72 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c62c5970b8..fa5b38be86 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2337,6 +2337,65 @@ (define-public r-ancombc
these biases and construct statistically consistent estimators.")
(license license:artistic2.0)))
+(define-public r-animalcules
+ (package
+ (name "r-animalcules")
+ (version "1.14.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "animalcules" version))
+ (sha256
+ (base32
+ "1alpsamrglgvzhcibkaf7m3gyiv61wbj1gvsq4lw6vjka100j9qr"))))
+ (properties `((upstream-name . "animalcules")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-ape
+ r-assertthat
+ r-biomformat
+ r-caret
+ r-covr
+ r-deseq2
+ r-dplyr
+ r-dt
+ r-forcats
+ r-ggplot2
+ r-glmnet
+ r-gunifrac
+ r-lattice
+ r-limma
+ r-magrittr
+ r-matrix
+ r-multiassayexperiment
+ r-plotly
+ r-plotroc
+ r-rentrez
+ r-reshape2
+ r-s4vectors
+ r-scales
+ r-shiny
+ r-shinyjs
+ r-summarizedexperiment
+ r-tibble
+ r-tsne
+ r-umap
+ r-vegan
+ r-xml))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/compbiomed/animalcules")
+ (synopsis "Interactive microbiome analysis toolkit")
+ (description
+ "@code{Animalcules} is an R package for utilizing up-to-date data analytics,
+visualization methods, and machine learning models to provide users an easy-to-use
+interactive microbiome analysis framework. It can be used as a standalone software
+package or users can explore their data with the accompanying interactive R Shiny
+application. Traditional microbiome analysis such as alpha/beta diversity and
+differential abundance analysis are enhanced, while new methods like biomarker
+identification are introduced by animalcules. Powerful interactive and dynamic
+figures generated by animalcules enable users to understand their data better and
+discover new insights.")
+ (license license:artistic2.0)))
+
(define-public r-aldex2
(package
(name "r-aldex2")
--
2.38.1
Ricardo Wurmus wrote 2 years ago
Re: [bug#59870] [PATCH 01/12] gnu: Add r-statip.
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 59870-done@debbugs.gnu.org)
874ju03716.fsf@elephly.net
I applied this patch series with mostly minor changes, except for
r-plotroc, which required more effort to replace the minified
JavaScript.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59870@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59870
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help