(address . guix-patches@gnu.org)
Hi
Working with it i realized today that mbedtls is somewhat outdated in
Guix, so i took the liberty of creating an update patch. Following the
comments in the package definition i realized that updating mbedtls
would break hiawatha, since that project upgraded to mbedtls 3 with
version 11. So i updatet that package as well.
I removed the snippets in both source blocks since they aren't needed
anymore.
Thanks for review and merge! Kind regards
gabriel
From 94ade2b4e1cf65b4859418ea2e7f7e12e35289bc Mon Sep 17 00:00:00 2001
From: Gabriel Wicki <wicg@zhaw.ch>
Date: Tue, 6 Dec 2022 16:36:11 +0100
Subject: [PATCH] gnu: mbedtls-apache: Update to version 3.2.1.
* gnu/packages/tls.scm (mbedtls-apache): Update to 3.2.1.
[source]: Remove snippet.
* gnu/packages/web.scm (hiawatha): Update to version 11.2
[source] Remove snippet.
---
gnu/packages/tls.scm | 15 +++------------
gnu/packages/web.scm | 10 ++--------
2 files changed, 5 insertions(+), 20 deletions(-)
Toggle diff (62 lines)
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index f1e844b608..ee81359a66 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -1002,7 +1002,7 @@ (define-public mbedtls-apache
(name "mbedtls-apache")
;; XXX Check whether ‘-Wformat-signedness’ still breaks mbedtls-for-hiawatha
;; when updating.
- (version "2.26.0")
+ (version "3.2.1")
(source
(origin
(method git-fetch)
@@ -1010,17 +1010,8 @@ (define-public mbedtls-apache
(url "https://github.com/ARMmbed/mbedtls")
(commit (string-append "mbedtls-" version))))
(sha256
- (base32 "0scwpmrgvg6q7rvqkc352d2fqlsx0aylcbyibcp1f1rsn8iiif2m"))
- (file-name (git-file-name name version))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Can be removed with the next version.
- ;; Reduce level of format truncation warnings due to false positives.
- ;; https://github.com/ARMmbed/mbedtls/commit/2065a8d8af27c6cb1e40c9462b5933336dca7434
- (substitute* "CMakeLists.txt"
- (("Wformat-truncation=2") "Wformat-truncation"))
- #t))))
+ (base32 "1dvj1m2i5lkaf8bcmslap8d82z2pi7ypgr8n7lv0rqjyy4vgmkgq"))
+ (file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index a313b0c7a4..f046ddd025 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -6095,20 +6095,14 @@ (define-public tidy-html
(define-public hiawatha
(package
(name "hiawatha")
- (version "10.11")
+ (version "11.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.hiawatha-webserver.org/files/"
"hiawatha-" version ".tar.gz"))
- (modules '((guix build utils)))
- (snippet '(begin
- ;; We use packaged libraries, so delete the bundled copies.
- (for-each delete-file-recursively
- (list "extra/nghttp2.tgz" "mbedtls"))
- #t))
(sha256
- (base32 "09wpgilbv13zal71v9lbsqr8c3fignygadykpd1p1pb8blb5vn3r"))))
+ (base32 "1i8vrxbvpcj6yxmshbg19gm9g8vrxds6pdra0sgld4vzj9v4zilr"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; no tests included
--
2.38.0