[PATCH 1/2] gnu: gpaste: Fix missing @gschemasCompiled@ substitute.

  • Done
  • quality assurance status badge
Details
3 participants
  • Attila Lendvai
  • Ludovic Courtès
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Attila Lendvai
Severity
normal
A
A
Attila Lendvai wrote on 6 Dec 2022 18:44
(address . guix-patches@gnu.org)(name . Attila Lendvai)(address . attila@lendvai.name)
20221206174445.20241-1-attila@lendvai.name
---
gnu/packages/gnome-xyz.scm | 3 +++
1 file changed, 3 insertions(+)

Toggle diff (16 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 0368ccc223..48b126ce15 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -913,6 +913,9 @@ (define-public gpaste
#~(modify-phases %standard-phases
(add-after 'unpack 'fix-introspection-install-dir
(lambda _
+ (substitute* "src/libgpaste/gpaste/gpaste-settings.c"
+ (("@gschemasCompiled@")
+ (string-append #$output "/share/glib-2.0/schemas/")))
(substitute* '("src/gnome-shell/extension.js"
"src/gnome-shell/prefs.js")
(("@typelibPath@")
--
2.35.1
A
A
Attila Lendvai wrote on 6 Dec 2022 18:46
[PATCH 2/2] gnu: gpaste: Update to 42.2.
(address . 59863@debbugs.gnu.org)(name . Attila Lendvai)(address . attila@lendvai.name)
20221206174640.21647-2-attila@lendvai.name
---
gnu/packages/gnome-xyz.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 48b126ce15..8be9c55000 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -873,7 +873,7 @@ (define-public gnome-shell-extension-paperwm
(define-public gpaste
(package
(name "gpaste")
- (version "42.1")
+ (version "42.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -882,12 +882,13 @@ (define-public gpaste
(file-name (git-file-name name version))
(sha256
(base32
- "1dlqa69zvzzdxyh21qfrx2nhpfy0fbihxpgkxqmramcgv3h5k4q3"))
+ "0qq2p19p3r3lz8yfynpnf36cipv54bzdbmq1x5zgwhyl4yl41g28"))
(patches
(search-patches "gpaste-fix-paths.patch"))))
(build-system meson-build-system)
(native-inputs
- (list gettext-minimal
+ (list gcr
+ gettext-minimal
gobject-introspection
(list glib "bin") ; for glib-compile-resources
pkg-config
--
2.35.1
A
A
Attila Lendvai wrote on 6 Dec 2022 18:52
(No Subject)
(name . 59863@debbugs.gnu.org)(address . 59863@debbugs.gnu.org)
-Q_JZlMRJgnHSzWVlzTZEbxinMoKZcvRA27xbzn0h3qGG8nHps3mi0dpHbSAEwkPjq0q3AqKZupD9boD7JuccHrvOyr09_nu0U9jXv3hcvU=@lendvai.name

--
• attila lendvai
• PGP: 963F 5D5F 45C7 DFCD 0A39
--
“The cost of sanity in this society, is a certain level of alienation.”
— Terence McKenna (1946–2000), 'The world and its double' (11 September 1993)
M
M
Maxim Cournoyer wrote on 7 Dec 2022 16:11
Re: bug#59863: [PATCH 1/2] gnu: gpaste: Fix missing @gschemasCompiled@ substitute.
(name . Attila Lendvai)(address . attila@lendvai.name)(name . 59863-done@debbugs.gnu.org)(address . 59863@debbugs.gnu.org)
87k0338d09.fsf_-_@gmail.com
Hi,

Attila Lendvai <attila@lendvai.name> writes:

Toggle quote (2 lines)
I adjusted the commit messages and pushed!

--
Thanks,
Maxim
L
L
Ludovic Courtès wrote on 26 Dec 2022 00:39
control message for bug #59863
(address . control@debbugs.gnu.org)
874jtjvyr4.fsf@gnu.org
close 59863
quit
?