LXI protocol

  • Done
  • quality assurance status badge
Details
3 participants
  • Nicolas Goaziou
  • Bruno Victal
  • phodina
Owner
unassigned
Submitted by
phodina
Severity
normal
P
P
phodina wrote on 6 Dec 2022 04:19
(name . Guix Patches)(address . guix-patches@gnu.org)
JOa0JrizoCuQsmT0nIIGlUfjAZAJEKJhtey80c1wUl3Xdr6ioOBeCaJVQQXbVpFrSnf4_6NGWT6NOCUkgxOBhkFlRT3b-2W_l_Xygp6Wpkc=@protonmail.com
Hello,

these patches add tools to control laboratory equipment remotely (e.g. osciloscope, power supply, etc.).

----
Petr
Attachment: file
From 42eb2875c900090f5a54f33a1766bae80c0f2988 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Sat, 3 Dec 2022 10:21:12 +0100
Subject: [PATCH 1/2] gnu: Add liblxi.

* gnu/packages/hardware.scm (liblxi): New variable.

Toggle diff (53 lines)
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index 65558ffe08..64e45dffb8 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -42,6 +42,7 @@ (define-module (gnu packages hardware)
#:use-module (gnu packages cdrom)
#:use-module (gnu packages compression)
#:use-module (gnu packages check)
+ #:use-module (gnu packages cmake)
#:use-module (gnu packages cpp)
#:use-module (gnu packages crypto)
#:use-module (gnu packages cups)
@@ -67,6 +68,7 @@ (define-module (gnu packages hardware)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages networking)
#:use-module (gnu packages openldap)
+ #:use-module (gnu packages onc-rpc)
#:use-module (gnu packages pciutils)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -1338,3 +1340,30 @@ (define-public libcpuid
string, code name and other information from x86 CPU. This library is not to be
confused with the @code{cpuid} command line utility from package @code{cpuid}.")
(license license:bsd-2))))
+
+(define-public liblxi
+ (package
+ (name "liblxi")
+ (version "1.16")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lxi-tools/liblxi")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0dfhqslfx78qx5md4va5fpjmxwbxhb6mbx8bzlf31i6nhsj2rzcx"))))
+ (build-system meson-build-system)
+ (native-inputs (list cmake pkg-config))
+ (inputs (list avahi libtirpc libxml2))
+ (home-page
+ "https://lxi-tools.github.io/")
+ (synopsis
+ "LAN eXtensions for Instrumentation library")
+ (description
+ "This package provides library for LAN eXtensions for Instrumentation
+based on the LXI Consortium standard which defines the communication
+protocols for modern instrumentation and data acquision systems using
+Ethernet.")
+ (license license:bsd-3)))
--
2.38.1
From cc294ff8c4db2bc6a3f01402c45948bff10d1373 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Sat, 3 Dec 2022 10:21:45 +0100
Subject: [PATCH 2/2] gnu: Add lxi-tools.

* gnu/packages/hardware.scm (lxi-tools): New variable.

Toggle diff (53 lines)
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index 64e45dffb8..bbd0fa4d31 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -62,6 +62,7 @@ (define-module (gnu packages hardware)
#:use-module (gnu packages high-availability)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages lua)
#:use-module (gnu packages lxqt)
#:use-module (gnu packages mtools)
#:use-module (gnu packages package-management)
@@ -81,6 +82,7 @@ (define-module (gnu packages hardware)
#:use-module (gnu packages qt)
#:use-module (gnu packages scanner)
#:use-module (gnu packages security-token)
+ #:use-module (gnu packages readline)
#:use-module (gnu packages tls)
#:use-module (gnu packages video)
#:use-module (gnu packages virtualization)
@@ -1367,3 +1369,30 @@ (define-public liblxi
protocols for modern instrumentation and data acquision systems using
Ethernet.")
(license license:bsd-3)))
+
+(define-public lxi-tools
+ (package
+ (name "lxi-tools")
+ (version "2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lxi-tools/lxi-tools")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "17l70b8whwp0a7j23vsrav1abjzhw78k7rg77q78q07rdqn9fwnd"))))
+ (build-system meson-build-system)
+ (native-inputs (list cmake pkg-config readline))
+ (inputs (list liblxi lua))
+ (home-page
+ "https://lxi-tools.github.io/")
+ (synopsis
+ "LAN eXtensions for Instrumentation tools")
+ (description
+ "This package provides tools for LAN eXtensions for Instrumentation
+based on the LXI Consortium standard which defines the communication
+protocols for modern instrumentation and data acquision systems using
+Ethernet.")
+ (license license:bsd-3)))
--
2.38.1
B
B
Bruno Victal wrote on 31 Mar 2023 01:00
control-msg
(name . control)(address . control@debbugs.gnu.org)
74912071-f536-c8bc-4711-db295b4da0e6@makinata.eu
# done with 5c131aff691fa1cb0fafe71b5f2795902ae056a7
close 55819

# control fail?
close 45449

# no longer relevant
close 33078

# tags
tags 62551 patch
tags 62503 patch
tags 62461 patch
tags 62443 patch
tags 62428 patch
tags 61226 patch
tags 59893 patch
tags 59852 patch
tags 49451 patch
tags 49207 patch
tags 44258 patch


quit
N
N
Nicolas Goaziou wrote on 23 Apr 2023 19:03
Re: [bug#59852] LXI protocol
(name . phodina via Guix-patches via)(address . guix-patches@gnu.org)
87pm7ur0ns.fsf@nicolasgoaziou.fr
Hello,

phodina via Guix-patches via <guix-patches@gnu.org> writes:


Toggle quote (3 lines)
> these patches add tools to control laboratory equipment remotely (e.g.
> osciloscope, power supply, etc.).

I updated both packages to their latest release, reformatted them, fixed
build for lxi-tools and pushed everything.

Thank you.

Regards,
--
Nicolas Goaziou
?