[PATCH] gnu: Add r-clustercrit, .r-waffle and r-amplican.

  • Done
  • quality assurance status badge
Details
3 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • M?d?lin Ionel Patra?cu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal
M
M
MadalinIonel.Patrascu@mdc-berlin.de wrote on 5 Dec 2022 18:25
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
47083f7d4810490c98e4e43cf814cbbd@mdc-berlin.de
* gnu/packages/cran.scm (r-clustercrit, r-waffle): New variables.

* gnu/packages/bioconductor.scm (r-amplican): New variable.
Attachment: file
M
M
M?d?lin Ionel Patra?cu wrote on 5 Dec 2022 18:27
[PATCH 1/3] gnu: Add r-clustercrit.
(address . 59840@debbugs.gnu.org)
20221205172726.24426-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-clustercrit): New variable.
---
gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5c5258d6e0..6c2b8c834b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14094,6 +14094,30 @@ (define-public r-npsurv
exact and interval-censored observations.")
(license license:gpl2+)))
+(define-public r-clustercrit
+ (package
+ (name "r-clustercrit")
+ (version "1.2.8")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "clusterCrit" version))
+ (sha256
+ (base32
+ "10pz1bikdbkm2ky3xnagp0qv60whalavp6j39b4p7d75jj5xcxgk"))))
+ (properties `((upstream-name . "clusterCrit")))
+ (build-system r-build-system)
+ (native-inputs (list gfortran))
+ (home-page "https://www.r-project.org/")
+ (synopsis "Computing clustering validation indices")
+ (description
+ "The @code{clusterCrit} package provides an implementation of the following
+indices: Czekanowski-Dice, Folkes-Mallows, Hubert Γ, Jaccard, McNemar, Kulczynski,
+Phi, Rand, Rogers-Tanimoto, Russel-Rao or Sokal-Sneath. ClusterCrit defines
+several functions which compute internal quality indices or external comparison
+indices. The partitions are specified as an integer vector giving the index of
+the cluster each observation belongs to.")
+ (license license:gpl2+)))
+
(define-public r-clusteval
(package
(name "r-clusteval")

base-commit: b2a848d23d37f31496e1ff664f1dcf6abcdcc388
--
2.38.1
M
M
M?d?lin Ionel Patra?cu wrote on 5 Dec 2022 18:27
[PATCH 3/3] gnu: Add r-amplican.
(address . 59840@debbugs.gnu.org)
20221205172726.24426-3-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-amplican): New variable.
---
gnu/packages/bioconductor.scm | 46 +++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c62c5970b8..7e92186505 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2178,6 +2178,52 @@ (define-public r-airpart
datasets.")
(license license:gpl2)))
+(define-public r-amplican
+ (package
+ (name "r-amplican")
+ (version "1.20.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "amplican" version))
+ (sha256
+ (base32
+ "1c990i6gxbarcpbdpkz017x94spwzap95l95synlizbkyif4z8ij"))))
+ (properties `((upstream-name . "amplican")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocgenerics
+ r-biocparallel
+ r-biostrings
+ r-clustercrit
+ r-data-table
+ r-dplyr
+ r-genomeinfodb
+ r-genomicranges
+ r-ggplot2
+ r-ggthemes
+ r-gridextra
+ r-gtable
+ r-iranges
+ r-knitr
+ r-matrix
+ r-matrixstats
+ r-rcpp
+ r-rmarkdown
+ r-s4vectors
+ r-shortread
+ r-stringr
+ r-waffle))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/valenlab/amplican")
+ (synopsis "Automated analysis of CRISPR experiments")
+ (description
+ "The package performs alignment of the amplicon reads, normalizes gathered
+data, calculates multiple statistics (e.g. cut rates, frameshifts) and presents
+the results in the form of aggregated reports. Data and statistics can be broken
+down by experiments, barcodes, user defined groups, guides and amplicons allowing
+for quick identification of potential problems.")
+ (license license:gpl3)))
+
(define-public r-amountain
(package
(name "r-amountain")
--
2.38.1
M
M
M?d?lin Ionel Patra?cu wrote on 5 Dec 2022 18:27
[PATCH 2/3] gnu: Add r-waffle.
(address . 59840@debbugs.gnu.org)
20221205172726.24426-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-waffle): New variable.
---
gnu/packages/cran.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6c2b8c834b..33c2a59d25 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -15146,6 +15146,35 @@ (define-public r-tm
"This package provides a framework for text mining applications within R.")
(license license:gpl3)))
+(define-public r-waffle
+ (package
+ (name "r-waffle")
+ (version "0.7.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "waffle" version))
+ (sha256
+ (base32
+ "1qjmai33p96cyavi9lgi6k30h6fj7db5sr569v9jf4kwx92c61df"))))
+ (properties `((upstream-name . "waffle")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-extrafont
+ r-ggplot2
+ r-gridextra
+ r-gtable
+ r-rcolorbrewer))
+ (home-page "https://github.com/hrbrmstr/waffle/tree/cran")
+ (synopsis "Creating waffle chart visualizations in R")
+ (description
+ "This package creates square pie charts also known as waffle charts. These
+can be used to communicate parts of a whole for categorical quantities. To emulate
+the percentage view of a pie chart, a 10x10 grid should be used. In this way each
+square is representing 1% of the total. @code{Waffle} provides tools to create
+charts as well as stitch them together. Isotype pictograms can be made by using
+glyphs.")
+ (license license:gpl2+)))
+
(define-public r-waveslim
(package
(name "r-waveslim")
--
2.38.1
R
R
Ricardo Wurmus wrote on 12 Dec 2022 15:52
Re: [bug#59840] [PATCH 1/3] gnu: Add r-clustercrit.
(name . M?d?lin Ionel Patra?cu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 59840-done@debbugs.gnu.org)
878rjc3c91.fsf@elephly.net
Thanks, I applied this series with minor changes.

--
Ricardo
Closed
?