[PATCH] shell: Make --help show --target and --list-targets

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Yarl Baudig
Owner
unassigned
Submitted by
Yarl Baudig
Severity
normal
Y
Y
Yarl Baudig wrote on 5 Dec 2022 18:16
(address . guix-patches@gnu.org)(name . Yarl Baudig)(address . yarl-baudig@mailoo.org)
20221205171622.3854-1-yarl-baudig@mailoo.org
These options are callable and documented in the manual but not
shown by --help.

* guix/scripts/shell.scm: Make --help show --target and
--list-targets.
---
guix/scripts/shell.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (17 lines)
diff --git a/guix/scripts/shell.scm b/guix/scripts/shell.scm
index 2fc1dc942a..bca5ddf4eb 100644
--- a/guix/scripts/shell.scm
+++ b/guix/scripts/shell.scm
@@ -76,6 +76,8 @@ (define (show-help)
(newline)
(show-build-options-help)
(newline)
+ (show-native-build-options-help)
+ (newline)
(show-transformation-options-help)
(newline)
(display (G_ "

base-commit: c3713d53e0bdf1186e08880b9e0ae6dd85f55fc4
--
2.38.1
Y
Y
Yarl Baudig wrote on 5 Dec 2022 18:39
[PATCH v2] shell: Make --help show --target and --list-targets
(address . 59839@debbugs.gnu.org)(name . Yarl Baudig)(address . yarl-baudig@mailoo.org)
20221205173921.4885-1-yarl-baudig@mailoo.org
Sorry about that, forgot to import show-native-build-options-help in v1.

These options are callable and documented in the manual but not
shown by --help.

* guix/scripts/shell.scm: Make --help show --target and
--list-targets.
---
guix/scripts/shell.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (27 lines)
diff --git a/guix/scripts/shell.scm b/guix/scripts/shell.scm
index 2fc1dc942a..3c18e0edbc 100644
--- a/guix/scripts/shell.scm
+++ b/guix/scripts/shell.scm
@@ -20,7 +20,8 @@ (define-module (guix scripts shell)
#:use-module (guix ui)
#:use-module ((guix diagnostics) #:select (location))
#:use-module (guix scripts environment)
- #:autoload (guix scripts build) (show-build-options-help)
+ #:autoload (guix scripts build) (show-build-options-help
+ show-native-build-options-help)
#:autoload (guix transformations) (options->transformation
transformation-option-key?
show-transformation-options-help)
@@ -76,6 +77,8 @@ (define (show-help)
(newline)
(show-build-options-help)
(newline)
+ (show-native-build-options-help)
+ (newline)
(show-transformation-options-help)
(newline)
(display (G_ "

base-commit: c3713d53e0bdf1186e08880b9e0ae6dd85f55fc4
--
2.38.1
Y
Y
Yarl Baudig wrote on 5 Dec 2022 21:41
[PATCH v3] shell: Make --help show --system and --list-systems
(address . 59839@debbugs.gnu.org)(name . Yarl Baudig)(address . yarl-baudig@mailoo.org)
20221205204101.23553-1-yarl-baudig@mailoo.org
These options are callable and documented in the manual but not
shown by --help.

* guix/scripts/shell.scm: Make --help show --system and
--list-systems.
---
guix/scripts/shell.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (27 lines)
diff --git a/guix/scripts/shell.scm b/guix/scripts/shell.scm
index 2fc1dc942a..3c18e0edbc 100644
--- a/guix/scripts/shell.scm
+++ b/guix/scripts/shell.scm
@@ -20,7 +20,8 @@ (define-module (guix scripts shell)
#:use-module (guix ui)
#:use-module ((guix diagnostics) #:select (location))
#:use-module (guix scripts environment)
- #:autoload (guix scripts build) (show-build-options-help)
+ #:autoload (guix scripts build) (show-build-options-help
+ show-native-build-options-help)
#:autoload (guix transformations) (options->transformation
transformation-option-key?
show-transformation-options-help)
@@ -76,6 +77,8 @@ (define (show-help)
(newline)
(show-build-options-help)
(newline)
+ (show-native-build-options-help)
+ (newline)
(show-transformation-options-help)
(newline)
(display (G_ "

base-commit: c3713d53e0bdf1186e08880b9e0ae6dd85f55fc4
--
2.38.1
L
L
Ludovic Courtès wrote on 26 Dec 2022 00:31
Re: bug#59839: [PATCH] shell: Make --help show --target and --list-targets
(name . Yarl Baudig)(address . yarl-baudig@mailoo.org)(address . 59839-done@debbugs.gnu.org)
877cyfvz5u.fsf_-_@gnu.org
Hi,

Yarl Baudig <yarl-baudig@mailoo.org> skribis:

Toggle quote (6 lines)
> These options are callable and documented in the manual but not
> shown by --help.
>
> * guix/scripts/shell.scm: Make --help show --system and
> --list-systems.

Applied, thanks!

Nitpick: Make sure to use spaces, not tabs.

Ludo’.
Closed
?