[PATCH 0/1] Fix julia-documenter and so many Julia packages

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 5 Dec 2022 16:37
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20221205153710.10684-1-zimon.toutoune@gmail.com
Hi,

Commit 83ede5a02e1fc531d912eb92eb0a22a4b897997c updating Git from 2.38.0 to
2.38.1 fixes several securtity issues. But it changes the default behaviour
of "git submodule", hence breaking the test suite of julia-documenter.

This patch backports the fix from upstream. This fix has not been released
yet. An update to lastest Julia Documenter implies other updates. I am
working on it but it is ~160 patches (from new packages to updates) and it is
not ready yet.

Therefore, this patch allows to have again all the Julia packages instead of
the current: 77.4% substitutes available (243 out of 314).


Cheers,
simon


zimoun (1):
gnu: julia-documenter: Fix test suite regression.

gnu/packages/julia-xyz.scm | 9 +++++++++
1 file changed, 9 insertions(+)


base-commit: 48329575c87bbee7166eedf10b1699599e67c49d
--
2.38.1
Z
Z
zimoun wrote on 5 Dec 2022 16:38
[PATCH 1/1] gnu: julia-documenter: Fix test suite regression.
(address . 59836@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20221205153851.11268-1-zimon.toutoune@gmail.com
* gnu/packages/julia-xyz.scm (julia-documenter)[arguments]<#:phases>:
Substitute a work around to fix the change of 'git submodule' default
behaviour introduced by Git v2.38.1.
---
gnu/packages/julia-xyz.scm | 9 +++++++++
1 file changed, 9 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 28c759a5c0..ac6584825b 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1472,6 +1472,15 @@ (define-public julia-documenter
(("pip install")
(string-append (search-input-file inputs "bin/pip")
" install")))))
+ (add-after 'link-depot 'fix-test-git-submodule
+ ;; Git v2.38.1 fixes security issues and changes the default
+ ;; behaviour of `git submodule`. This substitution is a backport
+ ;; of the upstream patch, not yet released, fixing the test suite.
+ ;; https://github.com/JuliaDocs/Documenter.jl/commit/b5a5c65d02d136743e7c18ffebf8baba900484fc
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "test/utilities.jl"
+ (("submodule add")
+ "-c protocol.file.allow=always submodule add"))))
(add-after 'link-depot 'remove-javascript-downloads
(lambda _
(substitute* "src/Writers/HTMLWriter.jl"
--
2.38.1
L
L
Ludovic Courtès wrote on 5 Dec 2022 16:58
Re: bug#59836: [PATCH 0/1] Fix julia-documenter and so many Julia packages
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 59836-done@debbugs.gnu.org)
87ilipq1us.fsf_-_@gnu.org
Hi,

zimoun <zimon.toutoune@gmail.com> skribis:

Toggle quote (4 lines)
> * gnu/packages/julia-xyz.scm (julia-documenter)[arguments]<#:phases>:
> Substitute a work around to fix the change of 'git submodule' default
> behaviour introduced by Git v2.38.1.

Well done; applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59836@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59836
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch