[PATCH] gnu: Add r-makecdfenv, r-altcdfenvs and r-harshlight.

  • Done
  • quality assurance status badge
Details
3 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal

Debbugs page

MadalinIonel.Patrascu@mdc-berlin.de wrote 2 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
7734e3c0299847c9a5c367e2bcf77a6a@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-makecdfenv, r-altcdfenvs and r-harshlight): New variables.
Attachment: file
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 2/3] gnu: Add r-altcdfenvs.
(address . 59835@debbugs.gnu.org)
20221205152153.18545-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-altcdfenvs): New variable.
---
gnu/packages/bioconductor.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 7cace3317c..37b84983c4 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2492,6 +2492,37 @@ (define-public r-alpine
data.")
(license license:gpl2+)))
+(define-public r-altcdfenvs
+ (package
+ (name "r-altcdfenvs")
+ (version "2.60.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "altcdfenvs" version))
+ (sha256
+ (base32
+ "0fm4l93j6nm1w1w57zzryc1hkzapp8l16pkwjzdzllvwvsnsg8r0"))))
+ (properties `((upstream-name . "altcdfenvs")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-affy
+ r-biobase
+ r-biocgenerics
+ r-biostrings
+ r-hypergraph
+ r-makecdfenv
+ r-s4vectors))
+ (home-page "https://bioconductor.org/packages/altcdfenvs")
+ (synopsis
+ "Convenience data structures and functions to handle CDF environments")
+ (description
+ "The package is usable with @code{Affymetrix GeneChip} short oligonucleotide
+arrays, and it can be adapted or extended to other platforms. It is able to
+modify or replace the grouping of probes in the probe sets. Also, the package
+contains simple functions to read @code{R} connections in the @code{FASTA} format
+and it can create an alternative mapping from sequences.")
+ (license license:gpl2+)))
+
(define-public r-aneufinder
(package
(name "r-aneufinder")
--
2.38.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 1/3] gnu: Add r-makecdfenv.
(address . 59835@debbugs.gnu.org)
20221205152153.18545-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-makecdfenv): New variable.
---
gnu/packages/bioconductor.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c62c5970b8..7cace3317c 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6010,6 +6010,33 @@ (define-public r-made4
datasets (coinertia analysis).")
(license license:artistic2.0)))
+(define-public r-makecdfenv
+ (package
+ (name "r-makecdfenv")
+ (version "1.74.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "makecdfenv" version))
+ (sha256
+ (base32
+ "0bvj5dg6yfjnhga1z8788zmb98d8shyz8pzz0ggnml87c1p2gy25"))))
+ (properties `((upstream-name . "makecdfenv")))
+ (build-system r-build-system)
+ (inputs (list zlib))
+ (propagated-inputs
+ (list r-affy
+ r-affyio
+ r-biobase
+ r-zlibbioc))
+ (home-page "https://bioconductor.org/packages/makecdfenv")
+ (synopsis "Chip description file environment maker")
+ (description
+ "This package implements two functions. One of them reads an @code{Affymetrix}
+@acronym{CDF, chip description file} and creates a hash table environment containing
+the location/probe set membership mapping. The other one creates a package that
+automatically loads that environment.")
+ (license license:gpl2+)))
+
(define-public r-metaneighbor
(package
(name "r-metaneighbor")

base-commit: b2a848d23d37f31496e1ff664f1dcf6abcdcc388
--
2.38.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 3/3] gnu: Add r-harshlight.
(address . 59835@debbugs.gnu.org)
20221205152153.18545-3-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-harshlight): New variable.
---
gnu/packages/bioconductor.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 37b84983c4..346fccfd3a 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -5854,6 +5854,33 @@ (define-public r-gseabase
Enrichment Analysis} (GSEA).")
(license license:artistic2.0)))
+(define-public r-harshlight
+ (package
+ (name "r-harshlight")
+ (version "1.70.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "Harshlight" version))
+ (sha256
+ (base32
+ "0asjgcnwawg8x7ql0srhb2011rvb4kr2cpsa1cy28nfmjfvdf0qm"))))
+ (properties `((upstream-name . "Harshlight")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-affy
+ r-altcdfenvs
+ r-biobase))
+ (home-page "http://asterion.rockefeller.edu/Harshlight/")
+ (synopsis "Corrective make-up program for microarray chips")
+ (description
+ "The package detects extended diffuse and compact blemishes on microarray
+chips. @code{Harshlight} marks the areas in a collection of chips (affybatch
+objects). A corrected @code{AffyBatch} object will result. The package replaces
+the defected areas with N/As or the median of the values of the same probe. The
+new version handles the substitute value as a whole matrix to solve the memory
+problem.")
+ (license license:gpl2+)))
+
(define-public r-hpar
(package
(name "r-hpar")
--
2.38.1
Ricardo Wurmus wrote 2 years ago
Re: [bug#59835] [PATCH 1/3] gnu: Add r-makecdfenv.
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 59835-done@debbugs.gnu.org)
87cz8o3czj.fsf@elephly.net
I applied this series with minor changes, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59835@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59835
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help