[PATCH] gnu: Add zls

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Mája Tomášek
Owner
unassigned
Submitted by
Mája Tomášek
Severity
normal
M
M
Mája Tomášek wrote on 29 Nov 2022 20:08
(address . guix-patches@gnu.org)
87k03da8a6.fsf@disroot.org
Hi,

this is a patch that adds the zls - zig language server. It is not currently
the most recent version, as the project follows versions of zig itself, which
is in guix one version behind. (as zig became self hosted)

Kind regards,
Maya
---
gnu/packages/zig-xyz.scm | 70 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 70 insertions(+)
create mode 100644 gnu/packages/zig-xyz.scm

Toggle diff (78 lines)
diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
new file mode 100644
index 0000000000..ff778003cb
--- /dev/null
+++ b/gnu/packages/zig-xyz.scm
@@ -0,0 +1,70 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Maya Tomasek <maya.tomasek@disroot.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages zig-xyz)
+ #:use-module (guix packages)
+ #:use-module (guix git-download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix gexp)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages zig)
+ #:use-module (gnu packages python))
+
+(define-public zig-zls
+ (package
+ (name "zig-zls")
+ (version "0.9.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zigtools/zls")
+ (commit version)
+ (recursive? #t)))
+ (sha256
+ (base32 "1hhs7dz9rpshfd1a7x5swmix2rmh53vsqskh3mzqlrj2lgb3cnii"))))
+ (build-system gnu-build-system)
+ (inputs (list zig python))
+ (arguments
+ (list
+ #:modules '((guix build gnu-build-system)
+ (guix build utils))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (zig (string-append #$zig "/bin/zig")))
+ ;; zig defaults it's cache dir to subdir of $HOME, which is not defined in the build environment
+ (setenv "ZIG_GLOBAL_CACHE_DIR"
+ (string-append (getcwd) "/zig-cache"))
+ ;; invoke the install target of the build command
+ (invoke zig "build" "install" "-Drelease-safe" "--prefix" out))))
+ (delete 'install)
+ (replace 'check
+ (lambda _
+ (let ((zig (string-append #$zig "/bin/zig")))
+ ;; run the test target
+ (invoke zig "build" "test")))))))
+ (synopsis "Zig language server")
+ (description "Zig Language Server is a language server for the @code{zig} programming language.")
+ (home-page "https://github.com/zigtools/zls")
+ (license license:expat)))
+
+zig-zls
--
2.38.1
L
L
Ludovic Courtès wrote on 14 Dec 2022 12:08
(name . Mája Tomášek)(address . maya.tomasek@disroot.org)(address . 59688@debbugs.gnu.org)
878rjatf83.fsf@gnu.org
Hi Mája,

Mája Tomášek <maya.tomasek@disroot.org> skribis:

Toggle quote (4 lines)
> this is a patch that adds the zls - zig language server. It is not currently
> the most recent version, as the project follows versions of zig itself, which
> is in guix one version behind. (as zig became self hosted)

Could you resend the patch to 59688@debbugs.gnu.org using ‘git
send-email’ so that https://qa.guix.gnu.orgcan pick it up?

Toggle quote (3 lines)
> ---
> gnu/packages/zig-xyz.scm | 70 ++++++++++++++++++++++++++++++++++++++++

Please add the new file to gnu/local.mk.

Toggle quote (3 lines)
> + (synopsis "Zig language server")
> + (description "Zig Language Server is a language server for the @code{zig} programming language.")

Could you expound the description a bit? For instance, by mentioning
“Language Server Protocol (LSP)” so that there’s no ambiguity as to the
kind of “language server” we’re talking about?

Toggle quote (2 lines)
> +zig-zls

You can remove this line.

Thanks in advance!

Ludo’.
M
M
Maya Tomasek wrote on 17 Dec 2022 12:41
[PATCH] gnu: Add zls
(address . 59688@debbugs.gnu.org)(name . Maya Tomasek)(address . maya.omase@protonmail.com)
20221217114148.21781-1-maya.tomasek@disroot.org
From: Maya Tomasek <maya.omase@protonmail.com>

---
gnu/local.mk | 1 +
gnu/packages/zig-xyz.scm | 68 ++++++++++++++++++++++++++++++++++++++++
2 files changed, 69 insertions(+)
create mode 100644 gnu/packages/zig-xyz.scm

Toggle diff (88 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 9120d7a263..ad47fcd216 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -641,6 +641,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/xorg.scm \
%D%/packages/xfce.scm \
%D%/packages/zig.scm \
+ %D%/packages/zig-xyz.scm \
%D%/packages/zile.scm \
%D%/packages/zwave.scm \
\
diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
new file mode 100644
index 0000000000..131d200ec7
--- /dev/null
+++ b/gnu/packages/zig-xyz.scm
@@ -0,0 +1,68 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Maya Tomasek <maya.tomasek@disroot.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages zig-xyz)
+ #:use-module (guix packages)
+ #:use-module (guix git-download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix gexp)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages zig)
+ #:use-module (gnu packages python))
+
+(define-public zig-zls
+ (package
+ (name "zig-zls")
+ (version "0.9.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zigtools/zls")
+ (commit version)
+ (recursive? #t)))
+ (sha256
+ (base32 "1hhs7dz9rpshfd1a7x5swmix2rmh53vsqskh3mzqlrj2lgb3cnii"))))
+ (build-system gnu-build-system)
+ (inputs (list zig python))
+ (arguments
+ (list
+ #:modules '((guix build gnu-build-system)
+ (guix build utils))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (zig (string-append #$zig "/bin/zig")))
+ ;; zig defaults it's cache dir to subdir of $HOME, which is not defined in the build environment
+ (setenv "ZIG_GLOBAL_CACHE_DIR"
+ (string-append (getcwd) "/zig-cache"))
+ ;; invoke the install target of the build command
+ (invoke zig "build" "install" "-Drelease-safe" "--prefix" out))))
+ (delete 'install)
+ (replace 'check
+ (lambda _
+ (let ((zig (string-append #$zig "/bin/zig")))
+ ;; run the test target
+ (invoke zig "build" "test")))))))
+ (synopsis "Zig language server")
+ (description "Zig Language Server is a language server implementing the Language Server Protocol (LSP) for the @code{zig} programming language.")
+ (home-page "https://github.com/zigtools/zls")
+ (license license:expat)))
--
2.38.1
L
L
Ludovic Courtès wrote on 5 Jan 2023 22:37
(name . Maya Tomasek)(address . maya.tomasek@disroot.org)
87a62w3bop.fsf_-_@gnu.org
Hi,

Maya Tomasek <maya.tomasek@disroot.org> skribis:

Toggle quote (6 lines)
> From: Maya Tomasek <maya.omase@protonmail.com>
>
> ---
> gnu/local.mk | 1 +
> gnu/packages/zig-xyz.scm | 68 ++++++++++++++++++++++++++++++++++++++++

Finally applied with a commit log as well as simplifications and
cosmetic changes to address the ‘guix lint’ warnings (see below).

Thanks!

Ludo’.
Toggle diff (58 lines)
diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index 131d200ec7..3812aa0125 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -36,33 +36,30 @@ (define-public zig-zls
(url "https://github.com/zigtools/zls")
(commit version)
(recursive? #t)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1hhs7dz9rpshfd1a7x5swmix2rmh53vsqskh3mzqlrj2lgb3cnii"))))
+ (base32
+ "1hhs7dz9rpshfd1a7x5swmix2rmh53vsqskh3mzqlrj2lgb3cnii"))))
(build-system gnu-build-system)
(inputs (list zig python))
(arguments
- (list
- #:modules '((guix build gnu-build-system)
- (guix build utils))
- #:phases
- #~(modify-phases %standard-phases
- (delete 'configure)
- (replace 'build
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (zig (string-append #$zig "/bin/zig")))
- ;; zig defaults it's cache dir to subdir of $HOME, which is not defined in the build environment
- (setenv "ZIG_GLOBAL_CACHE_DIR"
- (string-append (getcwd) "/zig-cache"))
- ;; invoke the install target of the build command
- (invoke zig "build" "install" "-Drelease-safe" "--prefix" out))))
- (delete 'install)
- (replace 'check
- (lambda _
- (let ((zig (string-append #$zig "/bin/zig")))
- ;; run the test target
- (invoke zig "build" "test")))))))
+ (list #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (setenv "ZIG_GLOBAL_CACHE_DIR"
+ (string-append (getcwd) "/zig-cache"))
+ (invoke "zig" "build" "install"
+ "-Drelease-safe" "--prefix" out))))
+ (delete 'install)
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "zig" "build" "test")))))))
(synopsis "Zig language server")
- (description "Zig Language Server is a language server implementing the Language Server Protocol (LSP) for the @code{zig} programming language.")
+ (description
+ "Zig Language Server is a language server implementing the @acronym{LSP,
+Language Server Protocol} for the Zig programming language.")
(home-page "https://github.com/zigtools/zls")
(license license:expat)))
Closed
?