[PATCH 0/2] gnu: python-sgp4: Update to 2.21.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 2 years ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221128232419.10274-1-sharlatanus@gmail.com
Hi Guix team!

This patch set includes python-sgp4 of the latest version tag which builds on
aarch64-linux (reported as failing build in https://issues.guix.gnu.org/59113).

I see that package was added 2 years ago to python-science.scm but It's more suitable
for and is only in use within astronomy.scm so I've moved it there.

Toggle quote (5 lines)
> ./pre-inst-env guix build --system=aarch64-linux --rounds=2 python-sgp4
> /gnu/store/qwcv08yygjk1fvpvcyyfdqhyz3dvjp05-python-sgp4-2.21
> ./pre-inst-env guix build --rounds=2 python-sgp4
> /gnu/store/i6400brvqr736vils8msq4v82a15qv8g-python-sgp4-2.21

Sharlatan Hellseher (2):
gnu: python-sgp4: Update to 2.21.
gnu: python-sgp4: Move to astronomy.

gnu/packages/astronomy.scm | 29 +++++++++++++++++++++++++++++
gnu/packages/python-science.scm | 20 --------------------
2 files changed, 29 insertions(+), 20 deletions(-)


base-commit: fddd62ff532972bd4ca9e1aeb8dd372a914e77a2--
2.38.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 1/2] gnu: python-sgp4: Update to 2.21.
(address . 59665@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221128232718.10428-1-sharlatanus@gmail.com
The latest version passes build on aarch64-linux system.

* gnu/packages/python-science.scm (python-sgp4): Update to 2.21.
---
gnu/packages/python-science.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 52fe1460bb..7af3f8202a 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -293,13 +293,13 @@ (define-public python-scikit-allel
(define-public python-sgp4
(package
(name "python-sgp4")
- (version "2.12")
+ (version "2.21")
(source
(origin
(method url-fetch)
(uri (pypi-uri "sgp4" version))
(sha256
- (base32 "0dncp9i5b6afkg7f8mj9j0qzsp008b8v73yc0qkmizhpns7mvwvx"))))
+ (base32 "1vzcrlrlzmhbycdz16m8v241l8zx49vsy81wcd0yjxs80isvhyb1"))))
(build-system python-build-system)
(propagated-inputs
(list python-numpy))
--
2.38.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 2/2] gnu: python-sgp4: Move to astronomy.
(address . 59665@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221128232718.10428-2-sharlatanus@gmail.com
* gnu/packages/astronomy.scm: (python-sgp4): Move here from python-science.scm.
[description]: Expand description, annotate acronyms, add link to CelesTrak.
---
gnu/packages/astronomy.scm | 29 +++++++++++++++++++++++++++++
gnu/packages/python-science.scm | 20 --------------------
2 files changed, 29 insertions(+), 20 deletions(-)

Toggle diff (73 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 439fdf72a8..0fb3efff0a 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1412,6 +1412,35 @@ (define-public python-reproject
changing the pixel resolution, orientation, coordinate system.")
(license license:bsd-3)))
+(define-public python-sgp4
+ (package
+ (name "python-sgp4")
+ (version "2.21")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sgp4" version))
+ (sha256
+ (base32 "1vzcrlrlzmhbycdz16m8v241l8zx49vsy81wcd0yjxs80isvhyb1"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-numpy))
+ (home-page "https://github.com/brandon-rhodes/python-sgp4")
+ (synopsis "Track earth satellite TLE orbits using SGP4")
+ (description
+ "This package provides a Python implementation for computations of the
+position and velocity of an earth-orbiting satellite, given the satellite’s
+@acronym{TLE, Two-line element set} orbital elements from a source like
+@url{CelesTrak, https://celestrak.org/}.
+
+It implements the most recent version of @acronym{SGP4, Simplified General
+Perturbation models}, and is regularly run against the SGP4 test suite to make
+sure that its satellite position predictions agree to within 0.1 mm with the
+predictions of the standard distribution of the algorithm. This error is far
+less than the 1–3 km/day by which satellites themselves deviate from the ideal
+orbits described in TLE files.")
+ (license license:expat)))
+
(define-public python-sunpy
(package
(name "python-sunpy")
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 7af3f8202a..4e9582191c 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -290,26 +290,6 @@ (define-public python-scikit-allel
genetic variation data.")
(license license:expat)))
-(define-public python-sgp4
- (package
- (name "python-sgp4")
- (version "2.21")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "sgp4" version))
- (sha256
- (base32 "1vzcrlrlzmhbycdz16m8v241l8zx49vsy81wcd0yjxs80isvhyb1"))))
- (build-system python-build-system)
- (propagated-inputs
- (list python-numpy))
- (home-page "https://github.com/brandon-rhodes/python-sgp4")
- (synopsis "Track earth satellite TLE orbits using SGP4")
- (description
- "This package provides a Python implementation of the most recent version
-of the SGP4 satellite tracking algorithm.")
- (license license:expat)))
-
(define-public python-trimesh
(package
(name "python-trimesh")
--
2.38.1
Ludovic Courtès wrote 2 years ago
Re: bug#59665: [PATCH 0/2] gnu: python-sgp4: Update to 2.21.
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 59665-done@debbugs.gnu.org)
87tu29ol9q.fsf@gnu.org
Hi,

Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (15 lines)
> This patch set includes python-sgp4 of the latest version tag which builds on
> aarch64-linux (reported as failing build in https://issues.guix.gnu.org/59113).
>
> I see that package was added 2 years ago to python-science.scm but It's more suitable
> for and is only in use within astronomy.scm so I've moved it there.
>
>> ./pre-inst-env guix build --system=aarch64-linux --rounds=2 python-sgp4
>> /gnu/store/qwcv08yygjk1fvpvcyyfdqhyz3dvjp05-python-sgp4-2.21
>> ./pre-inst-env guix build --rounds=2 python-sgp4
>> /gnu/store/i6400brvqr736vils8msq4v82a15qv8g-python-sgp4-2.21
>
> Sharlatan Hellseher (2):
> gnu: python-sgp4: Update to 2.21.
> gnu: python-sgp4: Move to astronomy.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59665@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59665
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help