[PATCH] gnu: Add tuxedo-keyboard.

  • Done
  • quality assurance status badge
Details
2 participants
  • Demis Balbach
  • Ludovic Courtès
Owner
unassigned
Submitted by
Demis Balbach
Severity
normal

Debbugs page

Demis Balbach wrote 2 years ago
(address . guix-patches@gnu.org)(name . Demis Balbach)(address . db@minikn.xyz)
20221128221758.6760-1-db@minikn.xyz
* gnu/packages/linux.scm (tuxedo-keyboard): New variable.
---
gnu/packages/linux.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 2e1da21800..6a6de13a15 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -67,6 +67,7 @@
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2022 Hunter Jozwiak <hunter.t.joz@gmail.com>
;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
+;;; Copyright © 2022 Demis Balbach <db@minikn.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1405,6 +1406,32 @@ (define-public librem-ec-acpi-linux-module
and the notification, WiFi, and Bluetooth LED.")
(license license:gpl2)))
+(define-public tuxedo-keyboard
+ (package
+ (name "tuxedo-keyboard")
+ (version "3.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tuxedocomputers/tuxedo-keyboard.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "17n14yh55yrxx4qbx4ph9drbzx2ll4kdsfmlngrdgizhyzk7z7zv"))))
+ (build-system linux-module-build-system)
+ (arguments
+ (list #:tests? #f)) ; no test suite
+ (home-page "https://github.com/tuxedocomputers/tuxedo-keyboard")
+ (synopsis "Linux kernel modules to control keyboard on most Tuxedo computers")
+ (description
+ "This packages provides the @code{tuxedo_keyboard}, @code{tuxedo_io}, @code{clevo_wmi}
+@acronym{WMI, Windows Management Engine} and the @code{clevo_acpi} @acronym{ACPI, Advanced
+Configuration and Power Interface} kernel modules to control the keyboard on most Tuxedo
+computers. Only white backlight only models are currently not supported. The @code{tuxedo_io}
+module is also needed for the @code{tuxedo-control-center} (short tcc) package.")
+ (license license:gpl3)))
+
(define-public ec
(package
(name "ec")
--
2.38.1
Ludovic Courtès wrote 2 years ago
(name . Demis Balbach)(address . db@minikn.xyz)(address . 59664-done@debbugs.gnu.org)
87y1rloldh.fsf@gnu.org
Demis Balbach <db@minikn.xyz> skribis:

Toggle quote (2 lines)
> * gnu/packages/linux.scm (tuxedo-keyboard): New variable.

[...]

Toggle quote (2 lines)
> + (license license:gpl3)))

Change it to ‘gpl3+’ because source file headers carry the “or any later
version” wording.

Thanks,
Ludo’.
Closed
Demis Balbach wrote 2 years ago
Re: bug#59664: closed (Re: bug#59664: [PATCH] gnu: Add tuxedo-keyboard.)
(address . 59664@debbugs.gnu.org)
87v8mphcn5.fsf@minikn.xyz
Toggle quote (8 lines)
>
> Change it to ‘gpl3+’ because source file headers carry the “or any later
> version” wording.
>
> Thanks,
> Ludo’.
>

Hello,

I'm not familiar with the procecure. Why exactly did you close this
issue? Do I need to open a new one with altered patch?

--
Best regards / Mit freundlichen Grüßen,
Demis Balbach
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEz9zHmXzCRksxyCGU8X3bmMw8QFwFAmOORr4ACgkQ8X3bmMw8
QFzwTBAAmnPwfhlonGOFzlU0cQN6D23ej1pwbIGsPgx8NHdkEJuvTLcr9/KW3N4P
Cx1YJloHjKHv0rN4mMd6UAv6RUSjaLN2dr2Nn8ChqaSEJOY2b1bcMnOiQ6WLlK/m
fBfI5A/e/x7DM5M/lL50tyUpMW//uxBWI2C4qr6EjjFH6F0OGBL3nLzJHvL9RnHv
DUBwblhr8dVNVifMJuRa4oOOrReTDP2p4pwAa6QpxAF7rJL7HofxWHDhKCdL9AlL
RLNH27U68vgIH4PVdzM3J8b3f6Z2igLQHyyxQyhvLleUGhCteOrbU95FLfqGFLr6
LRly0mnV/4jEBwgWhwBd8LCwuwwTasOHCh/x5Hzff08Mu7tEScBdKPAqt+xn2SoI
qHT0gOF6jOewyvXrC16rjnMNKX1UKP4gIYnN1NTvcJGoEW5LEM/srPDfS3YrwxKA
3gkWPgv2Z9x3C08tTfNcjMiBlyciXimMsFdxvHGWOPiKtBrm9MF/gkfETzmRHclz
FRIRJyeAx1edgVWYv7pO+qhENHjJuc3CQAqjX+MfMNI9bQDOOd1nvfH5XUQyIymk
RTbEDJJE03gLeaA9ZwPAvMkgp3Ft6Oc2CfnPF8fWPGpxojW6x862wHECLSzJw1wB
XSR9McLIO+x+gPeKAma26ZXcYXGCbmi7ASY7l9yMKoEWNCFlC7I=
=ULAS
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 59664@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59664
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help