[PATCH] gnu: Add emacs-ibrowse.

  • Done
  • quality assurance status badge
Details
3 participants
  • Andrew Tropin
  • Ludovic Courtès
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
N
N
Nicolas Graves wrote on 28 Nov 2022 09:07
(address . guix-patches@gnu.org)
20221128080733.28777-1-ngraves@ngraves.fr
* gnu/packages/emacs-xyz.scm (emacs-ibrowse): New variable.
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 35d6d87030..a680b29f27 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21515,6 +21515,30 @@ (define-public emacs-mbsync
within Emacs.")
(license license:gpl3+))))
+(define-public emacs-ibrowse
+ (let* ((commit "7e4a2987fc63861514b441f65db2008da5949ef2")
+ (revision "0"))
+ (package
+ (name "emacs-ibrowse")
+ (version (git-version "0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~ngraves/ibrowse.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "15661xgjxdxk1p0g87dsas9jd9v7g64y6n9irlbyzww09gjsjwwd"))))
+ (build-system emacs-build-system)
+ (inputs (list sqlite))
+ (propagated-inputs (list emacs-embark emacs-marginalia))
+ (home-page "https://git.sr.ht/~ngraves/ibrowse.el")
+ (synopsis "Interact with your browser from emacs")
+ (description "This package provides some commands to act on the browser
+tabs, history, or bookmarks from Emacs.")
+ (license license:gpl3+))))
+
(define-public emacs-ibuffer-projectile
(package
(name "emacs-ibuffer-projectile")
--
2.38.1
A
A
Andrew Tropin wrote on 28 Nov 2022 12:12
(address . ngraves@ngraves.fr)
87tu2jib82.fsf@trop.in
On 2022-11-28 09:07, Nicolas Graves wrote:

Toggle quote (41 lines)
> * gnu/packages/emacs-xyz.scm (emacs-ibrowse): New variable.
> ---
> gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
> 1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 35d6d87030..a680b29f27 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -21515,6 +21515,30 @@ (define-public emacs-mbsync
> within Emacs.")
> (license license:gpl3+))))
>
> +(define-public emacs-ibrowse
> + (let* ((commit "7e4a2987fc63861514b441f65db2008da5949ef2")
> + (revision "0"))
> + (package
> + (name "emacs-ibrowse")
> + (version (git-version "0.0" revision commit))
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://git.sr.ht/~ngraves/ibrowse.el")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "15661xgjxdxk1p0g87dsas9jd9v7g64y6n9irlbyzww09gjsjwwd"))))
> + (build-system emacs-build-system)
> + (inputs (list sqlite))
> + (propagated-inputs (list emacs-embark emacs-marginalia))
> + (home-page "https://git.sr.ht/~ngraves/ibrowse.el")
> + (synopsis "Interact with your browser from emacs")
> + (description "This package provides some commands to act on the browser
> +tabs, history, or bookmarks from Emacs.")
> + (license license:gpl3+))))
> +
> (define-public emacs-ibuffer-projectile
> (package
> (name "emacs-ibuffer-projectile")

Could you add a version tag and use it in package definition, please?

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmOEl60ACgkQIgjSCVjB
3rAMkg/8CxUUc/9Jp3xFkx4/AxeMW9FVByqKVNW2uOF8RbHGE+aTh2B+SzK1deTN
8rfJaLQhM8Xls6ysHg8MJZxl2d2OPQwtYYHwS6C6EUgJ0c237So3+IDvVGTbiyBl
yVAnOKbto6b2k5DFxOCDSPNn6WtAFbu0lMgHGG/T+z3Yq9FUZeYZ7Xk4E+dC1twA
7fWESuecVN6Vz251thTBaogELKXv6k8urSlJIvTQdHvQx+0ffovI61f8q6TOmdCU
CViKAPnD64tmK9gclTeA+uJxnUK2JMbdNTzg1WEwCTjhhbEKXw64C4Uspiygk1Tn
oARB1RLF/mFyMfwwS/PLozi7Onggpja2Qi/mlbfU4OJDap4WFwXwmgkmkMCGpPwx
MstZWulPbLW97KVkJwOYBOOemATIs//ErOzfP45/Q0GU6upFGjVPtmvrDL7axnRC
gCoIO4cPshgBsNC/BhbL5M27/sgdLJKok1vYvY+rEQKTuCi4pTNq6KfdVSXCbRpy
8TLAPJxX0ZldKx9Pgbe9zV0CS+4ddIgq0PA14OtRXhFzVLCfZdDnMOdMYmVyAQt+
En9EXwIVlvF1uDHynXoaCUUskY/6KPmgmXWpZVsts70lJ/n8PrmzccIcnm2kx2mS
Fqv8ubj2EpH10RfXLodJItZegHbtLK3JjyPzU6rcgIZ/h6Nfkuc=
=1LTC
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 5 Jan 2023 22:21
Re: bug#59649: [PATCH] gnu: Add emacs-ibrowse.
(name . Nicolas Graves)(address . ngraves@ngraves.fr)
87ilhk3cf9.fsf@gnu.org
Hi,

Nicolas Graves <ngraves@ngraves.fr> skribis:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-ibrowse): New variable.

Not sure what Andrew had in mind regarding a “version tag” (seems
alright to me, no?) so I went ahead and finally applied it.

Thanks!

Ludo’.
Closed
A
A
Andrew Tropin wrote on 6 Jan 2023 09:27
(address . 59649-done@debbugs.gnu.org)
87bkncqd8d.fsf@trop.in
On 2023-01-05 22:21, Ludovic Courtès wrote:

Toggle quote (9 lines)
> Hi,
>
> Nicolas Graves <ngraves@ngraves.fr> skribis:
>
>> * gnu/packages/emacs-xyz.scm (emacs-ibrowse): New variable.
>
> Not sure what Andrew had in mind regarding a “version tag” (seems
> alright to me, no?) so I went ahead and finally applied it.

Nicolas is an author of the ibrowse and has a write access to the repo,
so I asked to add a tag, so we can reference it in guix package
definition instead of commit =)

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmO324IACgkQIgjSCVjB
3rDypw/+J8cDj3kSHtU5CfkE7XizVapcDccJXHDle6MK8FsEVzJliSCPdno0B4Nc
6WkI95CO6Mi5prgKBUzE4zPbKG92bBRugFIq9RDvrfByRAdcOKFmhqpcYSxEo/J1
6sUwxdlL9mFXc3BD3Go99Hx0vFRiR7ajaD0YKmxEEaLCuBevbZ9E1am0tFFkEOEV
tLBbHS4aak5qIcyl79G6PUsPxIp7H8z0NAnGIOoy6iQZsQbE2H0csSrvMLHjV/U1
8m7Ly3P/Dqr15kxBhsV/4Ame3h9JGY9LAmyO8jKH5DXGxrI1KmYmjWj0ssi2amfs
8NO5Sa8JQvjzwlurjQsuKc1bFrR3wvyGJ/ax4A+Ps7UxgzEZdhxDvb6hyaq48Y4u
oHZNmQgwQzySvIDvCs30IP+KvgFG0PykdgKWF4GNc6zu1F974sFo3U60HEbEA/gR
JZqdFIuhV+IiMAO4ixf33JP5hXk0ID/K8DimB3DGnUlRVI+bULpIDzJq8sDrPTDk
c6w1twrS5hOGxc30Ll2WyInxtl2NsYlkx469H3jISe+L1ucpG5Vn2sgPmJ/ZZguZ
yzTOyWwzAQ7LYNMkDXNmVPMX6meKsxGnZJUEEpEIdxBroixjvExtddMWrFg76P58
boe/2haeK4RI3RZJXUjrErqAt/peoU29+XxmZsoUkUkKh2QuKCE=
=TjMr
-----END PGP SIGNATURE-----

Closed
L
L
Ludovic Courtès wrote on 7 Jan 2023 00:04
(name . Andrew Tropin)(address . andrew@trop.in)
87zgavw9gx.fsf@gnu.org
Andrew Tropin <andrew@trop.in> skribis:

Toggle quote (15 lines)
> On 2023-01-05 22:21, Ludovic Courtès wrote:
>
>> Hi,
>>
>> Nicolas Graves <ngraves@ngraves.fr> skribis:
>>
>>> * gnu/packages/emacs-xyz.scm (emacs-ibrowse): New variable.
>>
>> Not sure what Andrew had in mind regarding a “version tag” (seems
>> alright to me, no?) so I went ahead and finally applied it.
>
> Nicolas is an author of the ibrowse and has a write access to the repo,
> so I asked to add a tag, so we can reference it in guix package
> definition instead of commit =)

Ooh, I didn’t know that, sorry!

Ludo’.
Closed
?