[PATCH] gnu: icedove: Use native notifications when available

  • Done
  • quality assurance status badge
Details
5 participants
  • Jonathan Brielmaier
  • Ludovic Courtès
  • Christopher Baines
  • SeerLite
  • SeerLite
Owner
unassigned
Submitted by
SeerLite
Severity
normal
S
S
SeerLite wrote on 28 Nov 2022 05:54
(address . guix-patches@gnu.org)(name . SeerLite)(address . seerlite@nixnet.email)
7cc35b95103dd43472eb68b810971060e35aa42b.1669611249.git.seerlite@nixnet.email
* gnu/packages/gnuzilla.scm (icedove)[phases]{wrap-program}: Add libnotify
to LD_LIBRARY_PATH.
---
gnu/packages/gnuzilla.scm | 9 +++++++--
1 file changed, 7 insertions(+), 2 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index feb80d81a2..6a8ee41a1e 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1189,6 +1189,7 @@ (define (runpaths-of-input label)
"eudev"
"pulseaudio"
;; For the integration of native notifications
+ ;; (same reason as icedove)
"libnotify"))))
(wrap-program (car (find-files lib "^icecat$"))
`("XDG_DATA_DIRS" prefix (,gtk-share))
@@ -1496,10 +1497,13 @@ (define-public icedove
(pulseaudio #$(this-package-input "pulseaudio"))
(pulseaudio-lib (string-append pulseaudio "/lib"))
(eudev #$(this-package-input "eudev"))
- (eudev-lib (string-append eudev "/lib")))
+ (eudev-lib (string-append eudev "/lib"))
+ ;; For the integration of native notifications (same reason as icecat)
+ (libnotify #$(this-package-input "libnotify"))
+ (libnotify-lib (string-append libnotify "/lib")))
(wrap-program (car (find-files lib "^icedove$"))
`("XDG_DATA_DIRS" prefix (,gtk-share))
- `("LD_LIBRARY_PATH" prefix (,pulseaudio-lib ,eudev-lib)))))))))
+ `("LD_LIBRARY_PATH" prefix (,pulseaudio-lib ,eudev-lib ,libnotify-lib)))))))))
(inputs
(list alsa-lib
bzip2
@@ -1519,6 +1523,7 @@ (define-public icedove
libffi
libgnome
libjpeg-turbo
+ libnotify
libpng-apng
libvpx
libxcomposite
--
2.38.1
L
L
Ludovic Courtès wrote on 5 Dec 2022 17:17
(name . SeerLite)(address . seerlite@nixnet.email)
877cz5q0yz.fsf@gnu.org
Hi,

SeerLite <seerlite@nixnet.email> skribis:

Toggle quote (3 lines)
> * gnu/packages/gnuzilla.scm (icedove)[phases]{wrap-program}: Add libnotify
> to LD_LIBRARY_PATH.

Jonathan: this one’s for you. :-)

Ludo’.
J
J
Jonathan Brielmaier wrote on 8 Dec 2022 16:09
[PATCH] gnu: icedove: Use native notifications when available
(address . 59648@debbugs.gnu.org)
3d3b50d6-e258-8d39-f2fd-b06a9523a759@web.de
Hello SeerNet,

hm, when I enable notifications in Thunderbird I get notifications from
my sway desktop:
I just enabled it via Settings -> General -> Incoming Messages -> When
new messages arrive -> [x] Show an alert.

This is without your patch applied...

~Jonathan
C
C
Christopher Baines wrote on 13 Dec 2022 14:23
tag 59648 moreinfo
(address . control@debbugs.gnu.org)
87bko7tp2e.fsf@cbaines.net
tags 59648 + moreinfo
quit
S
S
SeerLite wrote on 19 Feb 2023 02:39
[PATCH] gnu: icedove: Use native notifications when available
3fe596c61765c15b1914bd2d2ddc26e5@disroot.org
Hi! Sorry, I didn't receive this response when it was sent, and it
wasn't in my inbox.

Toggle quote (2 lines)
> Hello SeerNet,

It's SeerLite :s

Toggle quote (7 lines)
> hm, when I enable notifications in Thunderbird I get notifications from
> my sway desktop:
> I just enabled it via Settings -> General -> Incoming Messages -> When
> new messages arrive -> [x] Show an alert.
>
> This is without your patch applied...

Yes, that's the same for me as well. The issue is not that there aren't
notifications, but that IceDove chooses to use its own fallback
implementation of them rather than using the program configured to send
them (in my case it's dunst). Without my patch I get large notifications
inconsistent with my setup. With my patch I get my custom configured
dunst notifications.

I'm pretty sure Icecat would use the same fallback notification
implementation if it didn't have libnotify. That's how I found out about
this issue back when I made the patch after all, but I can't remember
the details anymore. All I can say is Icedove uses the right
notifications on my machine with the patch applied.

I hope that explains the difference and maybe you're able to reproduce
the issue.

PS: I was actually actively waiting for a response since I sent the
patch (same as my other patch). Unfortunately I didn't check mumi
earlier. I've also changed my E-mail provider as the server I was
previously using was having a hard time getting to Debbugs.
J
J
Jonathan Brielmaier wrote on 12 Apr 2023 10:34
(address . 59648-done@debbugs.gnu.org)
677bc72b-04c8-bdf9-a16e-574767a3df8a@web.de
Hello SeerLite,

rebased and pushed as a3239ffd84e6ee9d9494085ddc3b875ebf43e225.

~Jonathan
Closed
?