[PATCH] gnu: Add emacs-frowny.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20221127205550.18581-1-jgart@dismail.de
* gnu/packages/emacs-xyz.scm (emacs-frowny): New variable.
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2c6f5d7306..be2c3be8f1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5089,6 +5089,28 @@ (define-public emacs-git-link
the URL for a commit. URLs are added to the kill ring.")
(license license:gpl3+)))
+(define-public emacs-frowny
+ (package
+ (name "emacs-frowny")
+ (version "0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/duckwork/frowny.el")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "01ss3js71as1jpqcf0x9hfvapiyyhj9ni4y1n6wvqsghv5dcaiy0"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/duckwork/frowny.el")
+ (synopsis "Insert frownies in Emacs :(")
+ (description "This package ships @code{frowny-mode}, which enables inserting a
+single @code{(} when after a @code{:} meaning it’ll insert a @code{:(}
+without closing the parentheses for modes like @code{electric-pair-mode},
+@code{paredit-mode}, and others.")
+ (license license:public-domain)))
+
(define-public emacs-apache-mode
(package
(name "emacs-apache-mode")
--
2.38.1
L
L
Liliana Marie Prikler wrote on 28 Nov 2022 06:35
Emacs frowny and spongebob
(name . jgart)(address . jgart@dismail.de)
a7caa81a5cdc7e73268b5c50c5f24b239b76df58.camel@gmail.com
Pushed
Toggle quote (1 lines)
> * gnu/packages/emacs-xyz.scm (emacs-frowny): New variable.
and
Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-spongebob): New variable.

Cheers
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59642@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59642
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch