[PATCH] gnu: Add tilix.

  • Done
  • quality assurance status badge
Details
4 participants
  • Efraim Flashner
  • jgart
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20221127185348.10186-1-jgart@dismail.de
* gnu/packages/terminals.scm (tilix): New variable.
---
gnu/packages/terminals.scm | 43 ++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (77 lines)
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index f6673388d2..69b982a727 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2022 Felipe Balbi <balbi@kernel.org>
;;; Copyright © 2022 ( <paren@disroot.org>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -72,6 +73,7 @@ (define-module (gnu packages terminals)
#:use-module (gnu packages crates-io)
#:use-module (gnu packages crates-graphics)
#:use-module (gnu packages crypto)
+ #:use-module (gnu packages dlang)
#:use-module (gnu packages docbook)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
@@ -86,6 +88,7 @@ (define-module (gnu packages terminals)
#:use-module (gnu packages image)
#:use-module (gnu packages libcanberra)
#:use-module (gnu packages libevent)
+ #:use-module (gnu packages libunwind)
#:use-module (gnu packages linux)
#:use-module (gnu packages man)
#:use-module (gnu packages ncurses)
@@ -1307,6 +1310,46 @@ (define-public eternalterminal
(define-public wterm
(deprecated-package "wterm" foot))
+(define-public tilix
+ (package
+ (name "tilix")
+ (version "1.9.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gnunn1/tilix")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0sb1hypg2276y8c2a5vivrkcxp70swddvhnd9h273if3kv6j879r"))))
+ (build-system meson-build-system)
+ (arguments
+ '(#:glib-or-gtk? #t
+ #:configure-flags '("-Dbuildtype=debugoptimized")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'check))))
+ (inputs
+ (list dbus
+ gettext-minimal
+ dconf
+ gsettings-desktop-schemas
+ libsecret
+ libunwind))
+ (native-inputs
+ (list desktop-file-utils
+ gtkd
+ ldc
+ pkg-config
+ python-wrapper
+ appstream))
+ (home-page "https://gnunn1.github.io/tilix-web/")
+ (synopsis "Tiling terminal emulator following the Gnome Human Interface Guidelines")
+ (description "Tilix is a tiling terminal emulator following the
+Gnome Human Interface Guidelines.")
+ (license license:mpl2.0)))
+
(define-public tio
(package
(name "tio")
--
2.38.1
J
Re: bug#59640: Acknowledgement ([PATCH] gnu: Add tilix.)
(address . 59640@debbugs.gnu.org)(name . ()(address . paren@disroot.org)
20221127131009.GB12861@dismail.de
On Sun, 27 Nov 2022 18:55:02 +0000 help-debbugs@gnu.org (GNU bug Tracking System) wrote:

Ignore v1. Waiting on gtkd getting patched because it is currently broken.

I just added this here to share my tilix WIP with others and to get feedback.
C
C
Christopher Baines wrote on 13 Dec 2022 14:24
Re: [bug#59640] [PATCH] gnu: Add tilix.
(name . jgart)(address . jgart@dismail.de)
87fsdjpha7.fsf@cbaines.net
jgart via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (5 lines)
> * gnu/packages/terminals.scm (tilix): New variable.
> ---
> gnu/packages/terminals.scm | 43 ++++++++++++++++++++++++++++++++++++++
> 1 file changed, 43 insertions(+)

Hey, thanks for the patch.

Toggle quote (10 lines)
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/gnunn1/tilix")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "0sb1hypg2276y8c2a5vivrkcxp70swddvhnd9h273if3kv6j879r"))))

This hash doesn't seem to match, you can sort of see this with the QA
testing. Has something changed upstream since you prepared the patch?

Toggle quote (18 lines)
> + (build-system meson-build-system)
> + (arguments
> + '(#:glib-or-gtk? #t
> + #:configure-flags '("-Dbuildtype=debugoptimized")
> + #:phases
> + (modify-phases %standard-phases
> + (delete 'check))))
> + (inputs
> + (list dbus
> + gettext-minimal
> + dconf
> + gsettings-desktop-schemas
> + libsecret
> + libunwind))
> + (native-inputs
> + (list desktop-file-utils
> + gtkd

Also, gtkd seems to fail to build for me, so I can't build tilix. Were
you able to build it locally?

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmOYfUBfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XctTQ//Q0tE+uG/aMMxHk4Dmf5AjWJd6049SbK4
zWjIVrX8HCPldGbN/1TSSj/rh8CwlQ9OzVS3WdMqiY6sBLkXeh0TlQYK3OD+HMnO
aDvGHCrFvhJeQqK4uD+C2mEbXO42W1iYVHKmbGT5Mh50FpQOG7rWOOgt82ngH2Cl
19kMACqj4lrm+i4fIuZte2lCc26BCCuBlx6eXsm0EYUvaVdKA89+kCueVC0f+zJ9
aIfNVPTkCka/uYW+GJz1jTJ3OhjwVFmgwWHBSfPjQdkIviJJ9U31meiySkYFIvIi
QBw0fDlwvxX14r7YPc0pYrbEtjC04mMZ5nTDrJ7OsAqOs5YDgZXcX4zyoKMRZ7rY
59DmD4J4xlFX5DBGctGphPYIJ7ECQG32b8WwlyVDWEeiXLJrQpSg96GPpCE6PkxP
z7APYAmp14DfwXpkFpTzZBt2QKwCePA9UgTvvYClhauagKLR/T/0uUaiVqfUewzY
dmZCUHIrLDmwurFv8GjlGR5akxnsfy2nmBW56QKXRLjWeTLbGYlVd53tx44aTNRw
9g2uLFJJJtJ9WsMobQ2hbHb5bjXtiilZkrkN38s9F8u0ULTlVI+qKiNvX/s39zcN
SgYY4PFOegzrUT+ul0kh1UaNlL0l/tnY1Qvs9j+Dna7HeykZKwAzAosqxdzddfeO
tAzjezE/82A=
=cmPL
-----END PGP SIGNATURE-----

J
(name . Christopher Baines)(address . mail@cbaines.net)
20221213102342.GB5135@dismail.de
On Tue, 13 Dec 2022 13:24:02 +0000 Christopher Baines <mail@cbaines.net> wrote:
Toggle quote (3 lines)
> Also, gtkd seems to fail to build for me, so I can't build tilix. Were
> you able to build it locally?

Hi Christopher,

Sorry to not update this patch. I haven't had time to work on gtkd but
I'll send an update to both gtkd and tilix once I fix the former.

Thanks for the reviews. They are greatly appreciated!

all best,

jgart
L
L
Ludovic Courtès wrote on 5 Jan 2023 22:18
control message for bug #59640
(address . control@debbugs.gnu.org)
87o7rc3cl1.fsf@gnu.org
tags 59640 + moreinfo
quit
E
E
Efraim Flashner wrote on 7 Jan 2023 22:10
[PATCH] gnu: Add tilix.
(address . 59640@debbugs.gnu.org)
3c98f0e06f5358f6b172f186e9bd6e5c01d71eaf.1673125726.git.efraim@flashner.co.il
From: jgart <jgart@dismail.de>

* gnu/packages/terminals.scm (tilix): New variable.

Co-authored-by: Efraim Flashner <efraim@flashner.co.il>
---
gnu/packages/terminals.scm | 53 +++++++++++++++++++++++++++++++++++++-
1 file changed, 52 insertions(+), 1 deletion(-)

Toggle diff (95 lines)
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 06b7b8b725..4832206fec 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015-2021, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Mckinley Olsen <mck.olsen@gmail.com>
;;; Copyright © 2016, 2017, 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016 David Craven <david@craven.ch>
@@ -32,6 +32,7 @@
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2022 Felipe Balbi <balbi@kernel.org>
;;; Copyright © 2022 ( <paren@disroot.org>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -73,6 +74,7 @@ (define-module (gnu packages terminals)
#:use-module (gnu packages crates-io)
#:use-module (gnu packages crates-graphics)
#:use-module (gnu packages crypto)
+ #:use-module (gnu packages dlang)
#:use-module (gnu packages docbook)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
@@ -87,6 +89,7 @@ (define-module (gnu packages terminals)
#:use-module (gnu packages image)
#:use-module (gnu packages libcanberra)
#:use-module (gnu packages libevent)
+ #:use-module (gnu packages libunwind)
#:use-module (gnu packages linux)
#:use-module (gnu packages man)
#:use-module (gnu packages ncurses)
@@ -1310,6 +1313,54 @@ (define-public eternalterminal
(define-public wterm
(deprecated-package "wterm" foot))
+(define-public tilix
+ (package
+ (name "tilix")
+ (version "1.9.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gnunn1/tilix")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ij3ix6yhi8hicxvglrxjyyv8bch9birrgsr8ml6jfh3hvk4pxdh"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-env-variables
+ (lambda _
+ (setenv "CC" ,(cc-for-target))))
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ (lambda _
+ (substitute* "meson_post_install.py"
+ (("gtk-update-icon-cache") (which "true"))))))))
+ (inputs
+ (list dbus
+ dconf
+ gsettings-desktop-schemas
+ gtk+
+ gtkd
+ libsecret
+ libunwind
+ vte))
+ (native-inputs
+ (list appstream
+ desktop-file-utils
+ gettext-minimal
+ (list glib "bin")
+ ldc
+ pkg-config
+ python-wrapper))
+ (home-page "https://gnunn1.github.io/tilix-web/")
+ (synopsis "Tiling terminal emulator following the Gnome Human Interface Guidelines")
+ (description "Tilix is a tiling terminal emulator following the
+Gnome Human Interface Guidelines.")
+ (license license:mpl2.0)))
+
(define-public tio
(package
(name "tio")

base-commit: d15972194aaef17fd1f7fd713d235c70794c9d4f
prerequisite-patch-id: 7e73a2ead7c6e84326cbb37aedbfed984cbe6ac3
--
2.38.1
J
J
jgart wrote on 7 Jan 2023 23:13
70f42edcd52e5271d1fecf7ff2dd7cb9@dismail.de
Hi Efraim,

Thank you very much for fixing up and working on this patch. It is greatly appreciated!

Here's a screenshot of me running tilix on GNOME 42.4 after building the patch that you sent:


I also ran the linter and just got

gnu/packages/terminals.scm:1351:5: tilix@1.9.5: label 'glib' does not match package name 'glib:bin'

But the above is a warning that can be ignored, correct?

all best,

jgart
E
E
Efraim Flashner wrote on 8 Jan 2023 12:08
(name . jgart)(address . jgart@dismail.de)(address . 59640-done@debbugs.gnu.org)
Y7qkSRl0LkPWG8lQ@3900XT
On Sat, Jan 07, 2023 at 10:13:56PM +0000, jgart wrote:
Toggle quote (14 lines)
> Hi Efraim,
>
> Thank you very much for fixing up and working on this patch. It is greatly appreciated!
>
> Here's a screenshot of me running tilix on GNOME 42.4 after building the patch that you sent:
>
> https://up.nixnet.services/wpex6t2q.png
>
> I also ran the linter and just got
>
> gnu/packages/terminals.scm:1351:5: tilix@1.9.5: label 'glib' does not match package name 'glib:bin'
>
> But the above is a warning that can be ignored, correct?

That's right.

I pushed the patch with a few more minor changes. I think this makes it
our first package actually using dlang.


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmO6pEgACgkQQarn3Mo9
g1Fv7g/+LUm/IAwMO70yOu3v6lWOOyALKlmg5WW6/mpYSMTrVgQeJqs2o+rTvB5Y
8M9F+hHzNL+btMBjhmRNi3eDgNzF/PLRuScH3Y3TWc/yLNoHZ48xVUjhZ2zMTaPW
lkNJqUEnt1R3VRa67qDt3mx3/asVmLe0feyQ91S9ihKr66+sJ55qMe9WBnQsg1WP
sXt8Kyta7pVTQVDtGd9WkXTb+4jR+RfvfaJUnKiMQ7b/6XDTLiVk36tMilXKklfw
aUYlEstaGUk0uujmzprnYxdVF/9F12sA5G1rAwraX/t02hgpRleUGCtJaq55uU7Q
K5zYDTuW0Ef1jLj+o+6r6uYuxFWZMtMwA/Tj1zuZaMyvrV7K1EPe40qgJ+fw3dzQ
FYlP4WZUrUgPcRz/9b+STWs3/jBXHj7ePd1ssfQaPFzN6ngeyW2Rs/fDDneEXUw8
CRGSG4SZJlelFH4/AQUtC2CG4CPq7VIEZPiJNYVbr5ykVDx/9fc9MR+qNRdUSaOq
Ej/CPYARSCqAuCAvU7A3F8z8Au6jgBXoHxB7qBtLMwnxUfFxDL6m+Q27tQGf259h
TAAPtcxRyp9yZouLZrISXuhC6slwGos4KSCTLsuBhrXPjOjy0k1LKWHn+RJ65DNf
AlxNccGYhoKK9Zlenud0ldo3X/q7v0x4z52tVrg2sttRHYW9W1s=
=uCOy
-----END PGP SIGNATURE-----


Closed
?