[PATCH] gnu: emacs-rec-mode: Patch executable paths.

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • (
Owner
unassigned
Submitted by
(
Severity
normal
(
(address . guix-patches@gnu.org)(name . ()(address . paren@disroot.org)
20221126100905.2835-1-paren@disroot.org
* gnu/packages/databases.scm (emacs-rec-mode)[source]: Add FILE-NAME.
[arguments]: Use G-expressions.
<#:phases>{'patch-program-paths}: New phase.
[inputs]: Add RECUTILS.
---
gnu/packages/databases.scm | 32 ++++++++++++++++++++------------
1 file changed, 20 insertions(+), 12 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index e4dde1b22b..d9930de8fd 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1625,24 +1625,32 @@ (define-public emacs-rec-mode
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/"
"rec-mode-" version ".tar"))
+ (file-name (string-append name "-" version ".tar"))
+ (snippet #~(delete-file "rec-mode.info"))
(sha256
(base32
- "1w1q6kh567fd8xismq9i6wr1y893lypd30l452yvydi1qjiq1n6x"))
- (snippet '(begin (delete-file "rec-mode.info")))))
+ "1w1q6kh567fd8xismq9i6wr1y893lypd30l452yvydi1qjiq1n6x"))))
(build-system emacs-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-before 'install 'make-info
- (lambda _
- (invoke "makeinfo" "--no-split"
- "-o" "rec-mode.info" "rec-mode.texi"))))))
- (native-inputs
- (list texinfo))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-program-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (emacs-substitute-variables "rec-mode.el"
+ ("rec-recfix" (search-input-file inputs "bin/recfix"))
+ ("rec-recinf" (search-input-file inputs "bin/recinf"))
+ ("rec-recsel" (search-input-file inputs "bin/recsel")))))
+ (add-before 'install 'make-info
+ (lambda _
+ (invoke "makeinfo" "--no-split"
+ "-o" "rec-mode.info" "rec-mode.texi"))))))
+ (inputs (list recutils))
+ (native-inputs (list texinfo))
(home-page "https://www.gnu.org/software/recutils/")
(synopsis "Emacs mode for working with recutils database files")
- (description "This package provides an Emacs major mode @code{rec-mode}
-for working with GNU Recutils text-based, human-editable databases. It
+ (description
+ "This package provides an Emacs major mode @code{rec-mode} for
+working with GNU Recutils text-based, human-editable databases. It
supports editing, navigation, and querying of recutils database files
including field and record folding.")
(license license:gpl3+)))

base-commit: 4a97591d0a13e88037b3073bd891bcdf35352f87
--
2.38.1
L
L
Liliana Marie Prikler wrote on 26 Nov 2022 13:28
d47f374654f43190753f17cc3af2aca73ed5cfb3.camel@gmail.com
Am Samstag, dem 26.11.2022 um 10:09 +0000 schrieb (:
Toggle quote (5 lines)
> * gnu/packages/databases.scm (emacs-rec-mode)[source]: Add FILE-NAME.
> [arguments]: Use G-expressions.
> <#:phases>{'patch-program-paths}: New phase.
> [inputs]: Add RECUTILS.
> ---
Split into two smaller commits, fixed up commit log and pushed.

Cheers
Closed
(
COM887H3IW95.L665XLS2PUNI@guix-framework
On Sat Nov 26, 2022 at 12:28 PM GMT, Liliana Marie Prikler wrote:
Toggle quote (2 lines)
> Split into two smaller commits, fixed up commit log and pushed.

Thanks for the speedy merge! :)

-- (
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59604@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59604
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch