(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
Greetings Guix patches!
Relevant thread: https://mail.gnu.org/archive/html/guix-devel/2022-11/msg00153.html
From 990cb50b8ba49c2bf1787abdffa54318d285624c Mon Sep 17 00:00:00 2001
From: Charles <charles.b.jackson@protonmail.com>
Date: Thu, 24 Nov 2022 11:44:12 -0600
Subject: [PATCH] guix: asdf-build-system: Keep some package-arguments for cl-*
packages.
Specifically asd-system and asd-test-systems. Before theses were striped
out. Now they stay there as meta data not used by the build-system.
* guix/build-system/asdf.scm (package-with-build-system):
Remove #:asd-systems #:asd-test-systems from striped arguments.
---
guix/build-system/asdf.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Toggle diff (15 lines)
diff --git a/guix/build-system/asdf.scm b/guix/build-system/asdf.scm
index 74a3e47da1..2985f7f786 100644
--- a/guix/build-system/asdf.scm
+++ b/guix/build-system/asdf.scm
@@ -203,7 +203,7 @@ (define (new-inputs inputs-getter)
(define base-arguments
(if target-is-source?
(strip-keyword-arguments
- '(#:tests? #:lisp #:asd-systems #:asd-test-systems #:asd-operation)
+ '(#:tests? #:lisp #:asd-operation)
(package-arguments pkg))
(package-arguments pkg)))
--
2.38.1