[PATCH] gnu: Resolve derivation lint warnings.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 2 years ago
(address . guix-patches@gnu.org)
20221125102622.20089-1-mail@cbaines.net
Computing derivations for these systems (i686-gnu and riscv32-linux) fails
with an error like the following:

could not find bootstrap binary 'tar' for system

* gnu/packages/mes.scm (mescc-tools)[supported-systems]: Remove riscv32-linux.
* guix/packages.scm (%hurd-system): Remove i686-gnu.
---
gnu/packages/mes.scm | 2 +-
guix/packages.scm | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/mes.scm b/gnu/packages/mes.scm
index d4e0e1203f..4487b1b6eb 100644
--- a/gnu/packages/mes.scm
+++ b/gnu/packages/mes.scm
@@ -234,7 +234,7 @@ (define-public mescc-tools
(build-system gnu-build-system)
(supported-systems '("i686-linux" "x86_64-linux"
"armhf-linux" "aarch64-linux"
- "riscv32-linux" "riscv64-linux"))
+ "riscv64-linux"))
(arguments
`(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
#:test-target "test"
diff --git a/guix/packages.scm b/guix/packages.scm
index 502df7fdd1..8f119d9fa7 100644
--- a/guix/packages.scm
+++ b/guix/packages.scm
@@ -423,7 +423,7 @@ (define %supported-systems
(define %hurd-systems
;; The GNU/Hurd systems for which support is being developed.
- '("i586-gnu" "i686-gnu"))
+ '("i586-gnu"))
(define %cuirass-supported-systems
;; This is the list of system types for which build machines are available.
--
2.38.1
Ludovic Courtès wrote 2 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 59568@debbugs.gnu.org)
87cz8ylumo.fsf@gnu.org
Hi Christopher,

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (8 lines)
> Computing derivations for these systems (i686-gnu and riscv32-linux) fails
> with an error like the following:
>
> could not find bootstrap binary 'tar' for system
>
> * gnu/packages/mes.scm (mescc-tools)[supported-systems]: Remove riscv32-linux.
> * guix/packages.scm (%hurd-system): Remove i686-gnu.

LGTM!

Ludo’.
Christopher Baines wrote 2 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 59568-done@debbugs.gnu.org)
87a640n52v.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (12 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
>> Computing derivations for these systems (i686-gnu and riscv32-linux) fails
>> with an error like the following:
>>
>> could not find bootstrap binary 'tar' for system
>>
>> * gnu/packages/mes.scm (mescc-tools)[supported-systems]: Remove riscv32-linux.
>> * guix/packages.scm (%hurd-system): Remove i686-gnu.
>
> LGTM!

Awesome, I've pushed this to master as
981f01d0cc0581f4ae60f4039be266abad3deab7.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmOPJ4hfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xf3pQ/9GLvYXR0XzNUnrWKxZx+60eSyifeN/HOT
0F/9Q9+mLTpF/euN3w4MFo2azyKUmzBRQyGYDT+s8sZKz+0n8SAZbbVkJQb5gG6C
TExd0htykGSGbAcPU2NriNvOEvaUQ9m5Z1hQmrMlBLffjfl9Op3fas0m3n8nUNrP
35lxrV/yJGlxxU0fNg4C/ZZ7UalPjfncTgNPmlMXtvNzGshKK++12olxmuuxJkAV
XcPcIQyOAvK+JNODUj1EB5QbQUwuRvZRpMx91qFywlXNqiLPa8q9rjkgzJQ64x+G
XIOq/e2Og0Tz1l4QJ4S+hJOh2Fp8n9dwmboViajP1hkeFVY0QP9jIs5mVQqlPyeo
pSIxNWv43knv6rj/R++9Ys4KgZuJ2IVIC+1nUjNDCUh/jZ8BcD6iiya+MnM8MSEc
T+LBKDHOzVqPSVrKaPwwAbwJUefqF/MTcURGJatROA17UrsKJRRFWjNUFJB9WPBL
eOrS+wpPffsbTi/MFPCLCOA5KtCLfF3+engcWorAZuMo6kR0wOk/0Z01+W8wVVRu
td/tbbynh5tZnZMNhIuIkD8r1UV49owucVnL2gxN9ZROLdEkSO00yxBF64NFak9s
dZ50JR8CHFq+pbdnbwpFR36hFmDukFaH7dMUQ7cvxcIrDzczd9BpBGMAjtqDlYK/
P8QStarxnrI=
=/Q+2
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59568@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59568
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help