Christopher Baines wrote 2 years ago
(address . guix-patches@gnu.org)
Computing derivations for these systems (i686-gnu and riscv32-linux) fails
with an error like the following:
could not find bootstrap binary 'tar' for system
* gnu/packages/mes.scm (mescc-tools)[supported-systems]: Remove riscv32-linux.
* guix/packages.scm (%hurd-system): Remove i686-gnu.
---
gnu/packages/mes.scm | 2 +-
guix/packages.scm | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
Toggle diff (28 lines)
diff --git a/gnu/packages/mes.scm b/gnu/packages/mes.scm
index d4e0e1203f..4487b1b6eb 100644
--- a/gnu/packages/mes.scm
+++ b/gnu/packages/mes.scm
@@ -234,7 +234,7 @@ (define-public mescc-tools
(build-system gnu-build-system)
(supported-systems '("i686-linux" "x86_64-linux"
"armhf-linux" "aarch64-linux"
- "riscv32-linux" "riscv64-linux"))
+ "riscv64-linux"))
(arguments
`(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
#:test-target "test"
diff --git a/guix/packages.scm b/guix/packages.scm
index 502df7fdd1..8f119d9fa7 100644
--- a/guix/packages.scm
+++ b/guix/packages.scm
@@ -423,7 +423,7 @@ (define %supported-systems
(define %hurd-systems
;; The GNU/Hurd systems for which support is being developed.
- '("i586-gnu" "i686-gnu"))
+ '("i586-gnu"))
(define %cuirass-supported-systems
;; This is the list of system types for which build machines are available.
--
2.38.1