[PATCH] Added a new package, which is called r-btools. The package is a suite of R function for all types of microbial diversity analyses.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)
20221125100305.25836-1-navid.afkhami@mdc-berlin.de
---
gnu/packages/bioinformatics.scm | 36 +++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6d7097c42c..448d0689a4 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2021 Hong Li <hli@mdc-berlin.de>
;;; Copyright © 2021, 2022 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2022 Navid Afkhami <navid.afkhami@mdc-berlin.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -535,6 +536,41 @@ (define-public pbcopper
and utilities for PacBio C++ applications.")
(license license:bsd-3))))
+(define-public r-btools
+ (let ((commit "fa21d4ca01d37ea4d98b45582453f3bf95cbc2b5")
+ (revision "1"))
+ (package
+ (name "r-btools")
+ (version (git-version "0.0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/twbattaglia/btools")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0bca593dnxz6xdywpdi0ipli0paln2b3bfxxj0csnmj55ryrz428"))))
+ (properties `((upstream-name . "btools")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-biomformat
+ r-coin
+ r-deseq2
+ r-dplyr
+ r-genefilter
+ r-phyloseq
+ r-picante
+ r-plotly
+ r-reshape2
+ r-stringr
+ r-vegan))
+ (home-page "https://github.com/twbattaglia/btools")
+ (synopsis "R functiones for microbial diversity analyses")
+ (description
+ "An assortment of R functions that ist suitable
+for all types of microbial diversity analyses")
+ (license license:expat))))
+
(define-public pbbam
(package
(name "pbbam")
--
2.34.1
Ricardo Wurmus wrote 2 years ago
[PATCH] Add r-btools
(address . 59567-done@debbugs.gnu.org)
87a64fmj2f.fsf@elephly.net
Thanks for the patch! I applied it with a few minor changes. See
commit b095dac8e0aeb9a61ecffd53bfa6f60f49b31f54 for details.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59567@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59567
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help