[PATCH] Added r-rfacts, whoch is a none free package to cran.scm

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)
20221124151211.59764-1-navid.afkhami@mdc-berlin.de
---
guix-science-nonfree/packages/cran.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/guix-science-nonfree/packages/cran.scm b/guix-science-nonfree/packages/cran.scm
index c320a55..fdb1e63 100644
--- a/guix-science-nonfree/packages/cran.scm
+++ b/guix-science-nonfree/packages/cran.scm
@@ -53,3 +53,29 @@ interpolator on regular grids.")
(license
(nonfree "https://cran.r-project.org/web/packages/akima/LICENSE"
"Non-commercial, ACM"))))
+
++(define-public r-rfacts
+ (package
+ (name "r-rfacts")
+ (version "0.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "rfacts" version))
+ (sha256
+ (base32
+ "0h2ryyl5zc3pxi85y0qwadfz7sdzz0m6ilwzabw317sb0z5lms5b"))))
+ (properties `((upstream-name . "rfacts")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-digest r-fs r-tibble r-xml2))
+ (native-inputs (list r-knitr))
+ (home-page "https://elilillyco.github.io/rfacts/")
+ (synopsis "Tool for invoking FACTS to run clinical trial simulations")
+ (description
+ "The rfacts package is an R interface to the Fixed and Adaptive
+Clinical Trial Simulator @code{FACTS}. It programmatically
+invokes @code{FACTS} to run clinical trial simulations.It
+aggregates simulation output data into tidy data frames. These
+capabilities provide end-to-end automation for large-scale simulation
+pipelines, and they enhance computational reproducibility.")
+
+ (license license:expat)))
--
2.34.1
Ricardo Wurmus wrote 2 years ago
(address . 59543-done@debbugs.gnu.org)
874juonw2b.fsf@elephly.net
Hi,

thanks for the patch.

Since this is a patch for the “guix-science-nonfree” channel, the
contribution is handled as a pull request against that channel’s
repository.

Closing here and continuing there!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59543@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59543
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help