[PATCH] Added r-rfacts package

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)
20221124110956.37518-1-navid.afkhami@mdc-berlin.de
---
gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3e5d654c5a..1487af41e6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -472,6 +472,33 @@ (define-public r-emdist
Distance (EMD).")
(license license:expat)))
+(define-public r-rfacts
+ (package
+ (name "r-rfacts")
+ (version "0.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "rfacts" version))
+ (sha256
+ (base32
+ "0h2ryyl5zc3pxi85y0qwadfz7sdzz0m6ilwzabw317sb0z5lms5b"))))
+ (properties `((upstream-name . "rfacts")))
+ (build-system r-build-system)
+ (inputs (list))
+ (propagated-inputs (list r-digest r-fs r-tibble r-xml2))
+ (native-inputs (list r-knitr))
+ (home-page "https://elilillyco.github.io/rfacts/")
+ (synopsis "Tool for invoking FACTS to run clinical trial simulations")
+ (description
+ "The rfacts package is an R interface to the Fixed and Adaptive Clinical Trial
+Simulator @code{FACTS} on Unix-like systems.
+It programmatically invokes @code{FACTS} to run clinical trial simulations.
+It aggregates simulation output data into tidy data frames.
+These capabilities provide end-to-end automation for
+large-scale simulation pipelines, and they enhance computational
+reproducibility.")
+ (license license:expat)))
+
(define-public r-ggalt
(package
(name "r-ggalt")
--
2.34.1
Ricardo Wurmus wrote 2 years ago
(address . 59541-done@debbugs.gnu.org)
87zgcgmhek.fsf@elephly.net
Hi,

looks like FACTS is nonfree software, and since r-rfacts doesn’t make
any sense to use without FACTS we cannot add this package to the
official Guix channel — even though rfacts itself is free software.

(For the record: this has been added to guix-science-nonfree instead.)

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59541@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59541
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help