[PATCH] gnu: Add kvantum.

  • Done
  • quality assurance status badge
Details
3 participants
  • ???
  • Christopher Baines
  • Yash Tiwari
Owner
unassigned
Submitted by
Yash Tiwari
Severity
normal
Y
Y
Yash Tiwari wrote on 24 Nov 2022 07:17
(address . guix-patches@gnu.org)(name . Yash Tiwari)(address . yasht@mailbox.org)
2a24602de5005d98057016dcf28ca07f676952f7.1669270666.git.yasht@mailbox.org
* gnu/packages/qt.scm (kvantum): New variable.
---
gnu/packages/qt.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (62 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 30bf429897..bc380c68ba 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -26,6 +26,7 @@
;;; Copyright © 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2022 Yash Tiwari <yasht@mailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -185,6 +186,45 @@ (define-public qt5ct
(home-page "https://qt5ct.sourceforge.io/")
(license license:bsd-2)))
+(define-public kvantum
+ (package
+ (name "kvantum")
+ (version "1.0.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/tsujan/Kvantum/releases/download/V"
+ version "/Kvantum-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1vmnb6hxy6nwjjm2asrq9av7rbrrs2rllzq7iwmsm9nidy7i7qxg"))))
+ (build-system qt-build-system)
+ (arguments
+ (list #:tests? #f
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "Kvantum") #t))
+ (add-after 'chdir 'patch-style-dir
+ (lambda _
+ (substitute* "style/CMakeLists.txt"
+ (("\\$\\{KVANTUM_STYLE_DIR\\}")
+ (string-append #$output
+ "/lib/qt5/plugins/styles"))))))))
+ (native-inputs (list qttools-5))
+ (inputs (list libx11
+ libxext
+ qtbase-5
+ qtsvg-5
+ qtx11extras
+ kwindowsystem))
+ (synopsis "SVG-based theme engine for Qt")
+ (description
+ "Kvantum is an SVG-based theme engine for Qt,
+tuned to KDE and LXQt, with an emphasis on elegance, usability and practicality.")
+ (home-page "https://github.com/tsujan/Kvantum")
+ (license license:gpl3)))
+
(define-public materialdecoration
(let ((commit "6a5de23f2e5162fbee39d16f938473ff970a2ec0")
(revision "9"))

base-commit: 22d44f87763f86a05e9679d9ad2c99e17f4c79be
--
2.38.1
C
C
Christopher Baines wrote on 25 Nov 2022 11:39
(name . Yash Tiwari)(address . yasht@mailbox.org)
87k03jz59m.fsf@cbaines.net
Yash Tiwari via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (3 lines)
> + (arguments
> + (list #:tests? #f

How come the tests are disabled?

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmOAm5VfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdPcxAArDbS8dybKLGUJGdaDxeZCoWdn15cCRZ3
kgOQJqz6eryheZH2K4g5VO+FJltklJm6b5QGEhvc7uoIhStzwr9wGtzY4Xoxe06m
bNku6e75oJYbMarXBnIM7Vnw/rDaUIv7ZNREJJl81/e4zA/3s+69WqtISYCnZJjb
pM68dvpZ7epESKoFiwr2F5XHbtspyqNDFHfZ+p1i7cwXEBd/hFySYNHGWvpCaTaP
A68o6ENYvrCPqqjRtPBjqE4gSmBCPd88Pvi6pExLTdq+wx3S2FNQ+Qvy0SrSBK1o
UVikwT8ZGJLDgNGV+YyYqvtHn/5jybe5WHybJRAEA4lBQzzv9Ww90xQD7xqJFwMf
mk9FPFFGbLuLglVos8740cWTfzRvjfcRhuYFulipIWkFaYO3rISrPuPMgze2VdQU
/zwkKGbG9xsPIwm+OxrDMLzpHXb4Eagk0LUcF1NYpbn6fXACesAAjeJ3QSxRIF9s
jRh1nyOOya1oKSsb7qd0Y1J3hAnR2gz699n+MgSCquB2QRno0NO61XuZWsK1Jsht
B5yR6gc8UZSPlvNsBIdDXRkNhWO7BSYKLf+opym0ItH83PBaHxBUmxMI91Qq9tRC
ZbpKl90ERyJ5qsWS23Ukynfx7XPG9NxgEvzb7I5yupmwlsS4av1e1+gm22mQeXtP
x2Z8w9A4qG4=
=dQGQ
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 25 Nov 2022 11:40
tag 59536 moreinfo
(address . control@debbugs.gnu.org)
875yf3z59b.fsf@cbaines.net
tags 59536 + moreinfo
quit
Y
Y
Yash Tiwari wrote on 25 Nov 2022 14:48
Re: [bug#59536] [PATCH] gnu: Add kvantum.
(name . Christopher Baines)(address . mail@cbaines.net)
DC61F9A8-4E31-44ED-AC67-8D046F478C7C@mailbox.org
With tests enabled, the build generates the same error as qt5ct i.e. "make: *** No rule to make target 'test'. Stop." From what I understand, there are no tests in the kvantum src.


On November 25, 2022 4:09:37 PM GMT+05:30, Christopher Baines <mail@cbaines.net> wrote:
Toggle quote (11 lines)
>
>Yash Tiwari via Guix-patches via <guix-patches@gnu.org> writes:
>
>> + (arguments
>> + (list #:tests? #f
>
>How come the tests are disabled?
>
>Thanks,
>
>Chris
?
Re: bug#59536: [PATCH] gnu: Add kvantum.
(name . Yash Tiwari)(address . yasht@mailbox.org)(address . 59536-done@debbugs.gnu.org)
87o7qg904q.fsf@envs.net
Yash Tiwari <yasht@mailbox.org> writes:

Toggle quote (2 lines)
> * gnu/packages/qt.scm (kvantum): New variable.

Hello, I have applied this patch with version update to 1.0.7, and
license to GPL3+ since the sources have "any later version" in it.

Close now, thank you!
Closed
?