[PATCH] gnu: Add portfolio.

  • Done
  • quality assurance status badge
Details
2 participants
  • conses
  • Ludovic Courtès
Owner
unassigned
Submitted by
conses
Severity
normal
C
C
conses wrote on 23 Nov 2022 21:33
(address . guix-patches@gnu.org)
8635a9bed2.fsf@conses.eu
* gnu/packages/gnome-xyz.scm (portfolio): New variable.
---
gnu/packages/gnome-xyz.scm | 54 ++++++++++++++++++++++++++++++++++++++
1 file changed, 54 insertions(+)

Toggle diff (70 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index b7e10100fb..e244b2d302 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1536,3 +1536,57 @@ (define-public tiramisu
notifications to STDOUT in order to allow the user to process notifications any
way they prefer.")
(license license:expat)))
+
+(define-public portfolio
+ (package
+ (name "portfolio")
+ (version "0.9.14")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tchx84/Portfolio")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0h09v8lhz3kv6qmwjhx3gr7rp6ccfhrzm54gjnaixl4dcg9zddls"))))
+ (arguments
+ (list
+ #:glib-or-gtk? #t
+ #:imported-modules `(,@%meson-build-system-modules
+ (guix build python-build-system))
+ #:modules '((guix build meson-build-system)
+ ((guix build python-build-system) #:prefix python:)
+ (guix build utils))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'rename-executable
+ (lambda _
+ (with-directory-excursion (string-append #$output "/bin")
+ (rename-file "dev.tchx84.Portfolio" "portfolio"))))
+ (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-program (search-input-file outputs "bin/portfolio")
+ `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")
+ ,(python:site-packages inputs outputs)))
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))))))
+ (build-system meson-build-system)
+ (inputs
+ (list
+ bash-minimal
+ python-pygobject
+ gtk+
+ libhandy))
+ (native-inputs
+ (list
+ (list glib "bin")
+ desktop-file-utils
+ gettext-minimal
+ python
+ (list gtk+ "bin")))
+ (home-page "https://github.com/tchx84/Portfolio")
+ (synopsis "A minimalist file manager for those who want to use Linux mobile devices.")
+ (description "Portfolio is a minimalist file manager for those who want to use Linux
+mobile devices. Tap to activate and long press to select, to browse, open, copy, move,
+delete, or edit your files.")
+ (license license:gpl3)))
--
2.38.1



--
Best regards,
conses
L
L
Ludovic Courtès wrote on 8 Dec 2022 22:32
control message for bug #59524
(address . control@debbugs.gnu.org)
87359pd1ji.fsf@gnu.org
close 59524
quit
?