[PATCH] gnu: cura: Make it work on wayland.

  • Open
  • quality assurance status badge
Details
3 participants
  • Morgan Smith
  • Demis Balbach
  • Christopher Baines
Owner
unassigned
Submitted by
Demis Balbach
Severity
normal
D
D
Demis Balbach wrote on 21 Nov 2022 18:14
(address . guix-patches@gnu.org)(name . Demis Balbach)(address . db@minikn.xyz)
20221121171403.30222-1-db@minikn.xyz
* gnu/packages/engineering.scm (cura): Make it work on wayland.
---
gnu/packages/engineering.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 43e23e30a8..42537364e6 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -3780,6 +3780,7 @@ (define-public cura
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(wrap-program (string-append out "/bin/cura")
+ '("QT_QPA_PLATFORM" = ("xcb"))
(list "GUIX_PYTHONPATH"
'prefix (list (string-append out
"/lib/python"
--
2.38.1
C
C
Christopher Baines wrote on 23 Nov 2022 10:20
(name . Demis Balbach)(address . db@minikn.xyz)
874juqrpoo.fsf@cbaines.net
Demis Balbach <db@minikn.xyz> writes:

Toggle quote (18 lines)
> * gnu/packages/engineering.scm (cura): Make it work on wayland.
> ---
> gnu/packages/engineering.scm | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
> index 43e23e30a8..42537364e6 100644
> --- a/gnu/packages/engineering.scm
> +++ b/gnu/packages/engineering.scm
> @@ -3780,6 +3780,7 @@ (define-public cura
> (lambda* (#:key outputs #:allow-other-keys)
> (let ((out (assoc-ref outputs "out")))
> (wrap-program (string-append out "/bin/cura")
> + '("QT_QPA_PLATFORM" = ("xcb"))
> (list "GUIX_PYTHONPATH"
> 'prefix (list (string-append out
> "/lib/python"

Setting this environment variable here seems quite unusual. What's it
doing, and would anyone want to set a different value?

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmN95jdfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcHbxAAmtL1SKHi0v1hrAw8uw+P6+hjAfPN3BJO
GPyteRZIjvT/HpL7hQWSBCnxUtJHlkVvJe7LjV/6Sp6pbx+V7csrhMEa0mELgYL5
PWifOmPhaUAUj/6ucnmdiK6bnztemE5SwvW/P/dsvw/M5KlZ2Mjmjzb0bsS4Rm2L
WTq03YjOqBQAOkMv7aP9ZVhviGiQ/dOKWko6VqZDqbmj2ui49uTP/lU76vW2C9Ez
esnI3/MgcQOdTmExCYCaao0YH3wji0tH7Cwd1fxtkcrEfPDbAvKchgDAKNmyvrv0
q68T/9u3OX9oUwMdKCYK1zWpSniCk/yWBltn9fbnkgqE/AZ/5p/xWl14auRQ58gQ
OgpWs0UvDQlsPPL+sMlt41mkUkYxMmhv0hm8L7W2/SHW5Jib0XKAdFUBembOnw16
J0zStlcqy+bxAJ6kNG4YjmozXJNP9Lh9TR+EfooB/vL9QAmbMxWRIr82uRogPF9f
BiQbdsK4KoEOSRzBSpFDa16dFv3s1kpuW387Jd4oKzU0vj7Ct73UsEN771uPrr2Y
nlL4Y3sAapGfLXf79gQLWyOg9lE/rRazhzgBSMKc7bombyltrwD39Akt+JzZIYHM
y1E0M3Yo0c4ZbwgVT4DWUAxJJUTzv6sXfIAEUfi3mlDMxN/UnHfJGp9ErmnfPjdZ
VscYLUC1NqM=
=d3Tu
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 23 Nov 2022 10:22
tag 59451 moreinfo
(address . control@debbugs.gnu.org)
87cz9euit8.fsf@cbaines.net
tags 59451 + moreinfo
quit
D
D
Demis Balbach wrote on 28 Nov 2022 23:34
Re: [bug#59451] [PATCH] gnu: cura: Make it work on wayland.
(name . Christopher Baines)(address . mail@cbaines.net)
87fse23dyn.fsf@minikn.xyz
On 2022-11-23 09:20, Christopher Baines wrote:

Toggle quote (7 lines)
> Setting this environment variable here seems quite unusual. What's it
> doing, and would anyone want to set a different value?
>
> Thanks,
>
> Chris

Hello Chris,

unfortunately I can't help much with this. Cura is currently not running
under Wayland (XWayland). After doing a bit of research, I found
`QT_QPA_PLATFORM` to `xcb` was the suggested workaround until wayland is
officially supported.

My QT knowledge is very limited, but the QT_QPA_PLATFORM env var seems
to allow for defining platform-specific features for the application

Setting it to `xcb` enables the XCB plugin
default X11 plugin.

Setting the env var to `wayland` doesn't work unfortunately. As an
alternative, I could create a package derivation `cura-wayland` and only
apply the patch there? Would that be more suitable?

--
Best regards / Mit freundlichen Grüßen,
Demis Balbach
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEz9zHmXzCRksxyCGU8X3bmMw8QFwFAmOFN5AACgkQ8X3bmMw8
QFySdxAAtJzBWube0WsPxGKD2WFdsR7UOPhecimo8td2pj2AlX9vIh26QGpdSacx
NuzZQDUGOrhboyz0l9mHDmI63tuEFa1p/huYJN8nBDoNsbqKVJLoDeeTgWkxFSDz
HYpOwV7qzIy0hk42PGgf4HkS2dIWkG8+wKQytcZkNaIF7OtnxJOpwt3tTjYOv5em
+pLfV33jxIl7mDapO8cpfxbSLTOP/da9Y8O1cTWm5Vb1mxFg8X7Jq5biqyLrFK8s
SFkbZHHzpYDwXzw2CFxGXVWg3ys6DcRODnkmtsu/bcg2yCbKLUaiEmM4Yp8/ODJp
bQIlw1ylIKGbhj4fW3BxiYcQzwsPFSxN9rt6DGK5YzmTJzMEDDldylkitMR1CeFI
s58cFX+zk79WFbACmsfZmcgR6yaxa+wXb3zb04MT6rRC5t+IPBLaeIiqFKwMBtZS
085QGa/OgN1Hm63Fs/jz5sekcXMB+zfe6YF8K9XnmfuCT+wwcZ39VMNtqinxv75/
RK0sLhCrZmxzj7uX3/W6ri2QeDteodzOAPB4xB/IHiptm1z4/AaVVYajLqS1MF/E
7mVfrXAOLiud07d/6bwmvLO2uNzitKwr5aVijF+JyC/kTsndxEco1070fsVSpJQw
dZfEidI4JRFjPu6JXLB+h04C1/THOqc4aS2ibtYA2Jvt7jqVZZs=
=Cq0J
-----END PGP SIGNATURE-----

M
M
Morgan Smith wrote on 4 Dec 2022 18:56
Re: bug#59451: [PATCH] gnu: cura: Make it work on wayland.
(name . Demis Balbach)(address . db@minikn.xyz)
DM5PR03MB3163F518F1F49817002DDD19C5199@DM5PR03MB3163.namprd03.prod.outlook.com
I'm not certain but this might be related to bug 57742. Basically cura
is a QT application that cannot access the qtwayland plugin. We could
add this plugin to the inputs or we could fix bug 57742 and have users
install it themselves. If I'm correct that is. I haven't tested this
theory
?