(address . bug-guix@gnu.org)
Hello,
I'm trying to offload an aarch64-linux build on Berlin and it fails this
way:
Toggle snippet (32 lines)
process 75612 acquired build slot '/var/guix/offload/10.0.0.9:22/3'
Backtrace:
In ice-9/boot-9.scm:
1752:10 12 (with-exception-handler _ _ #:unwind? _ # _)
In unknown file:
11 (apply-smob/0 #<thunk 7f6bbc3072e0>)
In ice-9/boot-9.scm:
724:2 10 (call-with-prompt _ _ #<procedure default-prompt-handle…>)
In ice-9/eval.scm:
619:8 9 (_ #(#(#<directory (guile-user) 7f6bbc30cc80>)))
In guix/ui.scm:
2263:7 8 (run-guix . _)
2226:10 7 (run-guix-command _ . _)
In guix/scripts/offload.scm:
814:22 6 (guix-offload . _)
In ice-9/boot-9.scm:
1752:10 5 (with-exception-handler _ _ #:unwind? _ # _)
In guix/scripts/offload.scm:
595:21 4 (process-request _ _ "/gnu/store/vqmlpayiwfagh6s86jwns…" …)
514:36 3 (choose-build-machine _)
In guix/inferior.scm:
345:2 2 (port->inferior _ _)
327:2 1 (read-repl-response _ _)
In ice-9/boot-9.scm:
1685:16 0 (raise-exception _ #:continuable? _)
ice-9/boot-9.scm:1685:16: In procedure raise-exception:
Throw to key `match-error' with args `("match" "no matching pattern" #<eof>)'.
guix build: error: unexpected EOF reading a line
make: *** [Makefile:7087: release] Error 1
It can be reproduced 100% by running a `make release` or using this
command:
Toggle snippet (3 lines)
guix deploy -L maintenance/hydra/modules maintenance/hydra/deploy-overdrive1.scm
Thanks,
Mathieu