Offload fails with: Throw to key `match-error'

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Mathieu Othacehe
Severity
normal
M
M
Mathieu Othacehe wrote on 21 Nov 2022 15:23
(address . bug-guix@gnu.org)
87r0xwz8ra.fsf@gnu.org
Hello,

I'm trying to offload an aarch64-linux build on Berlin and it fails this
way:

Toggle snippet (32 lines)
process 75612 acquired build slot '/var/guix/offload/10.0.0.9:22/3'
Backtrace:
In ice-9/boot-9.scm:
1752:10 12 (with-exception-handler _ _ #:unwind? _ # _)
In unknown file:
11 (apply-smob/0 #<thunk 7f6bbc3072e0>)
In ice-9/boot-9.scm:
724:2 10 (call-with-prompt _ _ #<procedure default-prompt-handle…>)
In ice-9/eval.scm:
619:8 9 (_ #(#(#<directory (guile-user) 7f6bbc30cc80>)))
In guix/ui.scm:
2263:7 8 (run-guix . _)
2226:10 7 (run-guix-command _ . _)
In guix/scripts/offload.scm:
814:22 6 (guix-offload . _)
In ice-9/boot-9.scm:
1752:10 5 (with-exception-handler _ _ #:unwind? _ # _)
In guix/scripts/offload.scm:
595:21 4 (process-request _ _ "/gnu/store/vqmlpayiwfagh6s86jwns…" …)
514:36 3 (choose-build-machine _)
In guix/inferior.scm:
345:2 2 (port->inferior _ _)
327:2 1 (read-repl-response _ _)
In ice-9/boot-9.scm:
1685:16 0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1685:16: In procedure raise-exception:
Throw to key `match-error' with args `("match" "no matching pattern" #<eof>)'.
guix build: error: unexpected EOF reading a line
make: *** [Makefile:7087: release] Error 1

It can be reproduced 100% by running a `make release` or using this
command:

Toggle snippet (3 lines)
guix deploy -L maintenance/hydra/modules maintenance/hydra/deploy-overdrive1.scm

Thanks,

Mathieu
L
L
Ludovic Courtès wrote on 22 Nov 2022 09:50
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 59447@debbugs.gnu.org)
8735abid9k.fsf@gnu.org
Hello,

Mathieu Othacehe <othacehe@gnu.org> skribis:

Toggle quote (3 lines)
> I'm trying to offload an aarch64-linux build on Berlin and it fails this
> way:

[...]

Toggle quote (12 lines)
> 514:36 3 (choose-build-machine _)
> In guix/inferior.scm:
> 345:2 2 (port->inferior _ _)
> 327:2 1 (read-repl-response _ _)
> In ice-9/boot-9.scm:
> 1685:16 0 (raise-exception _ #:continuable? _)
>
> ice-9/boot-9.scm:1685:16: In procedure raise-exception:
> Throw to key `match-error' with args `("match" "no matching pattern" #<eof>)'.
> guix build: error: unexpected EOF reading a line
> make: *** [Makefile:7087: release] Error 1

Fixed in b2b9571935f9188086b2e7b434840eeda6c42805.

We’ll have to update the ‘guix’ package to deploy it, though.

(In the meantime I commented out offending machines from
‘machines-for-berlin.scm’ and deployed it on berlin.)

Thanks,
Ludo’.
M
M
Mathieu Othacehe wrote on 22 Nov 2022 17:29
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 59447-done@debbugs.gnu.org)
87pmdfvtob.fsf@gnu.org
Toggle quote (4 lines)
> Fixed in b2b9571935f9188086b2e7b434840eeda6c42805.
>
> We’ll have to update the ‘guix’ package to deploy it, though.

Thanks for fixing that one, closing!

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59447@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59447
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch