(address . guix-patches@gnu.org)
From a8f78a0b951cce3ab4c03b3f1e61b1b95d93c723 Mon Sep 17 00:00:00 2001
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Mon, 21 Nov 2022 13:29:16 +0800
Subject: [PATCH] gnu: Add hyprland.
* gnu/packages/wm.scm (hyprland): New variable.
---
gnu/packages/wm.scm | 44 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)
Toggle diff (64 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index c87a616ed9..c2b567bd62 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -107,6 +107,7 @@ (define-module (gnu packages wm)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages fribidi)
#:use-module (gnu packages gawk)
+ #:use-module (gnu packages gcc)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gperf)
@@ -2723,6 +2724,49 @@ (define-public hikari
capabilities. It is heavily inspired by the Calm Window manager(cwm).")
(license license:bsd-2)))
+(define-public hyprland
+ (package
+ (name "hyprland")
+ (version "0.18.0beta")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hyprwm/Hyprland")
+ (commit (string-append "v"version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1sbf12mqvgqpjfw4bni4p2gk2djnh49fwzki4dnsyq4ykcp7x6hb"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ ;; Unbundle dependencies and add it to the dependency list
+ (delete-file-recursively "subprojects")
+ (substitute* "CMakeLists.txt"
+ ((".*subprojects/wlroots/.*") "")
+ (("libinput)") "libinput wlroots)"))))))
+ (build-system cmake-build-system)
+ (native-inputs
+ (list pkg-config gcc-12))
+ (inputs
+ (list wayland
+ wayland-protocols
+ cairo
+ pango
+ libdrm
+ egl-wayland
+ libxkbcommon
+ libinput
+ wlroots))
+ (home-page "https://www.hyprland.org/")
+ (synopsis "Dynamic tiling Wayland compositor based on wlroots")
+ (description
+ "Hyprland is a dynamic tiling Wayland compositor based on wlroots
+that doesn't sacrifice on its looks. It supports multiple layouts,
+fancy effects, has a very flexible IPC model allowing for a lot of
+customization, and more. ")
+ (license license:bsd-3)))
+
(define-public devour
(package
(name "devour")
--
2.38.1