[PATCH 0/5] Use qt6 instead of qt5 for rncbc's audio projects.

  • Done
  • quality assurance status badge
Details
2 participants
  • kiasoc5
  • Christopher Baines
Owner
unassigned
Submitted by
kiasoc5
Severity
normal

Debbugs page

kiasoc5 wrote 2 years ago
[PATCH 0/5] Use qt6 instead of qt5 for rncbc's audio projects.
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20221121043651.19213-1-kiasoc5@disroot.org
The build systems use qt6 by default so let's do that.

kiasoc5 (5):
gnu: synthv1: Use qt6 instead of qt5.
gnu: drumkv1: Use qt6 instead of qt5.
gnu: samplv1: Use qt6 instead of qt5.
gnu: padthv1: Use qt6 instead of qt5.
gnu: qtractor: Use qt6 instead of qt5.

gnu/packages/music.scm | 31 +++++++++++++++----------------
1 file changed, 15 insertions(+), 16 deletions(-)


base-commit: ac09fcb955e9358c330d728693759ca1a2e20542
--
2.38.1
kiasoc5 wrote 2 years ago
[PATCH 1/5] gnu: synthv1: Use qt6 instead of qt5.
(address . 59428@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20221121044235.21227-1-kiasoc5@disroot.org
* gnu/packages/music.scm (synthv1)[inputs]: Remove qtbase-5 and qtsvg-5; add qtbase and qtsvg.
[native-inputs]: Remove qttools-5; add qttools.
---
gnu/packages/music.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (20 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 2c87152449..2d74c76f49 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2300,10 +2300,10 @@ (define-public synthv1
alsa-lib
new-session-manager
liblo
- qtbase-5
- qtsvg-5))
+ qtbase
+ qtsvg))
(native-inputs
- (list pkg-config qttools-5))
+ (list pkg-config qttools))
(home-page "https://synthv1.sourceforge.io")
(synopsis "Polyphonic subtractive synthesizer")
(description
--
2.38.1
kiasoc5 wrote 2 years ago
[PATCH 2/5] gnu: drumkv1: Use qt6 instead of qt5.
(address . 59428@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20221121044235.21227-2-kiasoc5@disroot.org
* gnu/packages/music.scm (drumkv1): Update to 0.9.27.
[inputs]: Remove qtbase-5 and qtsvg-5; add qtbase and qtsvg.
[native-inputs]: Remove qttools-5; add qttools.
---
gnu/packages/music.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (20 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 2d74c76f49..2507faecc6 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2333,10 +2333,10 @@ (define-public drumkv1
alsa-lib
new-session-manager
liblo
- qtbase-5
- qtsvg-5))
+ qtbase
+ qtsvg))
(native-inputs
- (list pkg-config qttools-5))
+ (list pkg-config qttools))
(home-page "https://drumkv1.sourceforge.io")
(synopsis "Drum-kit sampler synthesizer with stereo effects")
(description
--
2.38.1
kiasoc5 wrote 2 years ago
[PATCH 3/5] gnu: samplv1: Use qt6 instead of qt5.
(address . 59428@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20221121044235.21227-3-kiasoc5@disroot.org
* gnu/packages/music.scm (samplv1): Update to 0.9.27.
[inputs]: Remove qtbase-5 and qtsvg-5; add qtbase and qtsvg.
[native-inputs]: Remove qttools-5; add qttools.
---
gnu/packages/music.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (20 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 2507faecc6..6bd558bbdb 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2366,10 +2366,10 @@ (define-public samplv1
alsa-lib
new-session-manager
liblo
- qtbase-5
- qtsvg-5))
+ qtbase
+ qtsvg))
(native-inputs
- (list pkg-config qttools-5))
+ (list pkg-config qttools))
(home-page "https://samplv1.sourceforge.io")
(synopsis "Polyphonic sampler synthesizer with stereo effects")
(description
--
2.38.1
kiasoc5 wrote 2 years ago
[PATCH 4/5] gnu: padthv1: Use qt6 instead of qt5.
(address . 59428@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20221121044235.21227-4-kiasoc5@disroot.org
* gnu/packages/music.scm (padthv1): Update to 0.9.27.
[inputs]: Remove qtbase-5 and qtsvg-5; add qtbase and qtsvg.
[native-inputs]: Remove qttools-5; add qttools.
---
gnu/packages/music.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (20 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 6bd558bbdb..3cd1d85bc7 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2399,10 +2399,10 @@ (define-public padthv1
new-session-manager
liblo
fftwf
- qtbase-5
- qtsvg-5))
+ qtbase
+ qtsvg))
(native-inputs
- (list pkg-config qttools-5))
+ (list pkg-config qttools))
(home-page "https://padthv1.sourceforge.io")
(synopsis "Polyphonic additive synthesizer")
(description
--
2.38.1
kiasoc5 wrote 2 years ago
[PATCH 5/5] gnu: qtractor: Use qt6 instead of qt5.
(address . 59428@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20221121044235.21227-5-kiasoc5@disroot.org
* gnu/packages/music.scm (qtractor): Update to 0.9.29.
[inputs]: Remove qtbase-5, qtsvg-5, and qtx11extras; add qtbase and qtsvg.
[native-inputs]: Remove qttools-5; add qttools.
---
gnu/packages/music.scm | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 3cd1d85bc7..4e83101d35 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3313,14 +3313,13 @@ (define-public qtractor
libvorbis
lilv
lv2
- qtbase-5
- qtsvg-5
- qtx11extras
+ qtbase
+ qtsvg
rubberband
suil
zlib))
(native-inputs
- (list pkg-config qttools-5))
+ (list pkg-config qttools))
(home-page "https://qtractor.org/")
(synopsis "Audio/MIDI multi-track sequencer")
(description
--
2.38.1
Christopher Baines wrote 2 years ago
Re: [bug#59428] [PATCH 0/5] Use qt6 instead of qt5 for rncbc's audio projects.
(name . kiasoc5)(address . kiasoc5@disroot.org)
87k03otlb6.fsf@cbaines.net
kiasoc5 via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (15 lines)
> The build systems use qt6 by default so let's do that.
>
> kiasoc5 (5):
> gnu: synthv1: Use qt6 instead of qt5.
> gnu: drumkv1: Use qt6 instead of qt5.
> gnu: samplv1: Use qt6 instead of qt5.
> gnu: padthv1: Use qt6 instead of qt5.
> gnu: qtractor: Use qt6 instead of qt5.
>
> gnu/packages/music.scm | 31 +++++++++++++++----------------
> 1 file changed, 15 insertions(+), 16 deletions(-)
>
>
> base-commit: ac09fcb955e9358c330d728693759ca1a2e20542

Thanks for the patches! I've pushed these to master as
88e2c715d647e42c77652d2f21a94f3970566f59 now.

I tweaked a few of the commit messages, I'm not sure why a number of
them said "Update to 0.9.27.", since none of the versions changed.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmN7j91fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdCcBAAtJpZsd71KE9cTSd0rFn4gXAUmaXk8+mX
m0tgkZplVbfV3jF4RX/Wr/ifz7V4+VmuFkm+ahpjKefqyJhfLlV3MmTGcJIBprlK
jTgXBl9t1nswysaDwDOocR+cqHj05EmX0yrmK/fOjrRhH2h4Zr7YLw9STrSbi5QL
drsIiZDRDQ4jb/kFzfsD9P7fOEEXRSWW6QbDmUOb4SCZ0G13fNvTgoO4YqaG7ccS
QqFhQgIDoqxxdbNZeYsEVFWrlV5wnwi4GzIkx7APBFModN8XiWbVJsCsGf4Zq2qU
HInMKexxizmHM+u2Dt0PSouwlHRuVJN1slv+RivH8DbrEiEAHH83EFYB62nsiR1w
G3ap5oYstovX0tkvOnyiE5T4itqNgE2FPkYwB5UDQwQAbog9gRIxvjNWOVShm0te
LErSm+k0p9BhCHF7F7ZllqLpIfoVLR6CjhNBbWzRf/r/NzB+LPwVa0BGUspMJ/76
TOb4U7i4lcFyCaJvxfVxJeycCwmFAeUGCag7JKyR2F5TH6/NNUzWDZg6sDbtUBwA
1ecb1UBOrDt9J2gIkPiS/w5sybmEUDygDY4c6VGnrdGAP8oSLEmGK6Y4psK2Qjcb
Kz27cn82E/j25jazJ9tbMe2Pw+BwL9IF1nZX9QwF+cNMXhYD2fpYcz090RcGLHd2
GXn43FxR760=
=wokA
-----END PGP SIGNATURE-----

kiasoc5 wrote 2 years ago
(name . Christopher Baines)(address . mail@cbaines.net)
f1febb04-d103-93be-9386-88cfcdafe713@disroot.org
On 11/21/22 09:48, Christopher Baines wrote:
Toggle quote (4 lines)
>
> I tweaked a few of the commit messages, I'm not sure why a number of
> them said "Update to 0.9.27.", since none of the versions changed.

Ah, that was the result of using ./etc/committer. I thought I had
changed the commit messages after but I guess I forgot to send the new
patches. Thanks!
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59428@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59428
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help