[PATCH] gnu: Add cl-adopt

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 2 years ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221120212857.28358-1-sharlatanus@gmail.com
* gnu/packages/lisp-xyz.scm (cl-adopt, ecl-adopt, sbcl-adopt): New variables.
---
gnu/packages/lisp-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 27312cb369..406d5268ad 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -708,6 +708,36 @@ (define-public ecl-command-line-arguments
(define-public cl-command-line-arguments
(sbcl-package->cl-source-package sbcl-command-line-arguments))
+(define-public sbcl-adopt
+ (package
+ (name "sbcl-adopt")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sjl/adopt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "adopt" version))
+ (sha256
+ (base32 "16kzkai96qk7vmclp8wxc9aghhnisw8gg9s7hra68300bgj86wzr"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs (list sbcl-1am))
+ (inputs (list sbcl-bobbin sbcl-split-sequence))
+ (home-page "https://hg.stevelosh.com/adopt")
+ (synopsis "Common Lisp option parsing library")
+ (description
+ "@acronym{ADOPT, A Damn OPTion} is a simple UNIX-style option parser in
+Common Lisp, heavily influenced by Python's @code{optparse} and
+@code{argparse}.")
+ (license license:expat)))
+
+(define-public ecl-adopt
+ (sbcl-package->ecl-package sbcl-adopt))
+
+(define-public cl-adopt
+ (sbcl-package->cl-source-package sbcl-adopt))
+
(define-public sbcl-cl-irc
(let ((commit "963823537c7bfcda2edd4c44d172192da6722175")
(revision "0"))
--
2.38.0
Guillaume Le Vaillant wrote 2 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 59419-done@debbugs.gnu.org)
87edtwfz5e.fsf@kitej
Patch pushed as c0037bd5080460c88aa80000e8fa5d8f3493c335.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCY3tBTQ8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/Q9wEAlAGANkUF8B7ujAukD9iEw97xiFuqRf6hsWQU
PdrO4KIBAIou7RpRzsqbLQK7GfeJi/MAYE9G4yalRpcwILeAAkf+
=SfN6
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59419@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59419
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help