[PATCH staging 0/1] gnu: ppsspp: Drop OGLCompiler andOSDependent from glslang libs.

  • Open
  • quality assurance status badge
Details
3 participants
  • dan
  • Liliana Marie Prikler
  • Maxim Cournoyer
Owner
unassigned
Submitted by
dan
Severity
normal
D
(address . guix-patches@gnu.org)
20221120175605.23736-1-i@dan.games
The recent update on vulkan-sdk packages breaks the build of ppsspp on the
staging branch[1]. This patch tries to drops unused glslang libs from the
CMakeLists.txt file of ppsspp, following the recent changes made on
glslang[2].


dan (1):
gnu: ppsspp: Drop OGLCompiler and OSDependent from glslang libs.

gnu/packages/emulators.scm | 10 +++++++++-
1 file changed, 9 insertions(+), 1 deletion(-)

--
2.38.1
D
[PATCH 1/1] gnu: ppsspp: Drop OGLCompiler and OSDependent from glslang libs.
(address . 59416@debbugs.gnu.org)
20221120180058.24278-1-i@dan.games
* gnu/packages/emulators.scm (ppsspp) [arguments]: Drop OGLCompiler and
OSDependent from lists of glslang libraries.
---
gnu/packages/emulators.scm | 10 +++++++++-
1 file changed, 9 insertions(+), 1 deletion(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 28d3e0ca9a..2ed5420aca 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2021 dan <i@dan.games>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2317,7 +2318,14 @@ (define-public ppsspp
;; Since we are not including git as an input, PPSSPP is confused
;; about its version. Let's fix that here.
(substitute* "git-version.cmake"
- (("unknown") ,version))))))
+ (("unknown") ,version))
+ ;; We've updated the glslang in guix to match the latest vulkan-sdk
+ ;; version, while the glslang ppsspp vendored is a 2-year old
+ ;; version. We have to manually remove these from glslang libs
+ ;; list to successfully build the package. For more info, see:
+ ;; https://github.com/KhronosGroup/glslang/commit/7cd519511c32d7e86d901c7ed231cb84c652d18d
+ (substitute* "CMakeLists.txt"
+ (("OGLCompiler OSDependent") ""))))))
(build-system cmake-build-system)
(native-inputs (list pkg-config python))
(inputs (list bash
--
2.38.1
L
L
Liliana Marie Prikler wrote on 22 Nov 2022 21:16
Re: [PATCH staging 0/1] gnu: ppsspp: Drop OGLCompiler andOSDependent from glslang libs.
6abd2ac20099d8d67b6d3e051ec0a5c412b41ea1.camel@gmail.com
Am Montag, dem 21.11.2022 um 01:56 +0800 schrieb dan:
Toggle quote (6 lines)
> The recent update on vulkan-sdk packages breaks the build of ppsspp
> on the staging branch[1].  This patch tries to drops unused glslang
> libs from the CMakeLists.txt file of ppsspp, following the recent
> changes made on glslang[2].
>
> [1]: http://ci.guix.gnu.org/build/1751089/details
You probably want to update this link, but ppsspp on staging is
currently waiting on CI.

Toggle quote (5 lines)
> [2]:
> https://github.com/KhronosGroup/glslang/commit/7cd519511c32d7e86d901c7ed231cb84c652d18d
>
> dan (1):
>   gnu: ppsspp: Drop OGLCompiler and OSDependent from glslang libs.
Have you tested whether this actually works as intended, i.e. whether
OpenGL and Linux-specific features continue to work?

Cheers
M
M
Maxim Cournoyer wrote on 21 Mar 2023 14:09
Re: bug#59416: [PATCH staging 0/1] gnu: ppsspp: Drop OGLCompiler andOSDependent from glslang libs.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
874jqes126.fsf_-_@gmail.com
Hi Dan,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (18 lines)
> Am Montag, dem 21.11.2022 um 01:56 +0800 schrieb dan:
>> The recent update on vulkan-sdk packages breaks the build of ppsspp
>> on the staging branch[1].  This patch tries to drops unused glslang
>> libs from the CMakeLists.txt file of ppsspp, following the recent
>> changes made on glslang[2].
>>
>> [1]: http://ci.guix.gnu.org/build/1751089/details
> You probably want to update this link, but ppsspp on staging is
> currently waiting on CI.
>
>> [2]:
>> https://github.com/KhronosGroup/glslang/commit/7cd519511c32d7e86d901c7ed231cb84c652d18d
>>
>> dan (1):
>>   gnu: ppsspp: Drop OGLCompiler and OSDependent from glslang libs.
> Have you tested whether this actually works as intended, i.e. whether
> OpenGL and Linux-specific features continue to work?

Gentle ping :-).

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 21 Mar 2023 14:09
control message for bug #59416
(address . control@debbugs.gnu.org)
87355ys122.fsf@gmail.com
tags 59416 + moreinfo
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 59416@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59416
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch