[PATCH] gnu: Add hebcal.

  • Done
  • quality assurance status badge
Details
3 participants
  • Felix Lechner
  • Christopher Baines
  • (
Owner
unassigned
Submitted by
Felix Lechner
Severity
normal
F
F
Felix Lechner wrote on 20 Nov 2022 05:15
(address . guix-patches@gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
20221120041512.319-1-felix.lechner@lease-up.com
* gnu/packages/calendar.scm (hebcal): New variable.
* gnu/packages/golang.scm
(go-github-com-hebcal-hebcal-go,
go-github-com-hebcal-gematriya,
go-github-com-nathan-osman-go-sunrise): New variables.
---
gnu/packages/calendar.scm | 36 +++++++++++++++
gnu/packages/golang.scm | 95 +++++++++++++++++++++++++++++++++++++++
2 files changed, 131 insertions(+)

Toggle diff (168 lines)
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 6583810277..41c047f955 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -34,6 +34,7 @@ (define-module (gnu packages calendar)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system go)
#:use-module (guix build-system cmake)
#:use-module (guix build-system python)
#:use-module (gnu packages admin)
@@ -45,6 +46,7 @@ (define-module (gnu packages calendar)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages gtk)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages perl)
@@ -426,3 +428,37 @@ (define-public gsimplecal
launched again it closes the running instance. It can additionally be
configured to show the current time in different timezones.")
(license license:bsd-3))))
+
+(define-public hebcal
+ (let ((commit "2384bb88dc1a41a4a5ae57a29fb58b2dd49a475d")
+ (revision "0"))
+ (package
+ (name "hebcal")
+ (version (git-version "5.3.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hebcal/hebcal")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12rv3b51jb7wcjwmmizz9jkw7gh37yklys4xncvpzgxdkkfgmmjx"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/hebcal/hebcal"))
+ (native-inputs
+ (list go-github-com-hebcal-hebcal-go
+ go-github-com-pborman-getopt))
+ (synopsis "Perpetual Jewish Calendar with holidays and prayer times")
+ (description "Hebcal is a program which converts between Hebrew and Gregorian
+dates, and generates lists of Jewish holidays for any year past, present or future.
+Shabbat and holiday candle lighting and havdalah times are approximated based on
+location.
+
+It can also show daily prayer times, the weekly Torah reading (Parashat HaShavua)
+and the daily leaf of Talmud (Daf Yomi). The program can furthermore help with the
+counting of the Omer or with the calculation of Hebrew yahrzeits, birthdays or
+anniversaries.")
+ (home-page "https://github.com/hebcal/hebcal")
+ (license license:gpl2+))))
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b3df51ed5f..1d5493ad40 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2485,6 +2485,101 @@ (define-public go-gopkg-in-go-playground-validator-v9
@end itemize")
(license license:expat)))
+(define-public go-github-com-nathan-osman-go-sunrise
+ (let ((commit "c8f9f1eb869135f07378e7e3c5ec7a005f806c73")
+ (revision "0"))
+ (package
+ (name "go-github-com-nathan-osman-go-sunrise")
+ (version (git-version "1.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nathan-osman/go-sunrise")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "017zwzx05r5spxcs07dp6bnh7waknzsd819k7aqd8kr819v3x9in"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/nathan-osman/go-sunrise"))
+ (home-page "https://github.com/nathan-osman/go-sunrise")
+ (synopsis "Calculates the sunrise and sunset times for a given location")
+ (description
+ "To calculate the sunrise and sunset times, you will need the date of your
+observation and the geographical coordinates in latitude and longitude for the
+location.")
+ (license license:expat))))
+
+(define-public go-github-com-hebcal-gematriya
+ (let ((commit "fe3043f73e415eb82727701d10f2fb40f87675e9")
+ (revision "0"))
+ (package
+ (name "go-github-com-hebcal-gematriya")
+ (version (git-version "1.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hebcal/gematriya")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xmnb2i80dy380yv8c4pd04bbyqgbc7c40p8hz1vqj2lhbm6jabf"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/hebcal/gematriya"))
+ (home-page "https://github.com/hebcal/gematriya")
+ (synopsis "Provides a system of writing numbers as Hebrew letters")
+ (description
+ "Prints numbers as Hebrew letters. Numerical values are represented using
+letters of the Hebrew alef-bet (alphabet).")
+ (license license:bsd-2))))
+
+(define-public go-github-com-hebcal-hebcal-go
+ (let ((commit "d42e881860cfc9e8249fc79f268091c3c4d36b0d")
+ (revision "0"))
+ (package
+ (name "go-github-com-hebcal-hebcal-go")
+ (version (git-version "0.9.11" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hebcal/hebcal-go")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1m9akb8pwxchpaci05gambshrzw626gsrfhl25f36vjl7mq5292n"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/hebcal/hebcal-go"
+ ;; Source-only package
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Source-only package
+ (delete 'build))))
+ (propagated-inputs
+ (list go-github-com-hebcal-gematriya
+ go-github-com-nathan-osman-go-sunrise
+ go-github-com-stretchr-testify))
+ (home-page "https://github.com/hebcal/hebcal-go")
+ (synopsis "Library module for Hebcal, a perpetual Jewish Calendar")
+ (description
+ "This library converts between Hebrew and Gregorian dates, and generates lists
+of Jewish holidays for any year (past, present or future). Shabbat and holiday candle
+lighting and havdalah times are approximated based on location.
+
+Torah readings (Parashat HaShavua), Daf Yomi, and counting of the Omer can also be
+specified. Hebcal also includes algorithms to calculate yahrzeits, birthdays and
+anniversaries.")
+ (license license:gpl2+))))
+
(define-public go-github-com-aws-sdk
(package
(name "go-github-com-aws-sdk")

base-commit: ac09fcb955e9358c330d728693759ca1a2e20542
--
2.38.1
(
COGZOGMMBNA7.1XXAF4N4K3AYQ@guix-framework
Heya,

On Sun Nov 20, 2022 at 4:15 AM GMT, Felix Lechner via Guix-patches via wrote:
Toggle quote (6 lines)
> * gnu/packages/calendar.scm (hebcal): New variable.
> * gnu/packages/golang.scm
> (go-github-com-hebcal-hebcal-go,
> go-github-com-hebcal-gematriya,
> go-github-com-nathan-osman-go-sunrise): New variables.

Please send one patch per package.

-- (
F
F
Felix Lechner wrote on 20 Nov 2022 14:47
[PATCH 1/4] gnu: Add go-github-com-nathan-osman-go-sunrise.
(address . 59399@debbugs.gnu.org)
20221120134802.19051-1-felix.lechner@lease-up.com
* gnu/packages/golang.scm
(go-github-com-nathan-osman-go-sunrise): New variable.
---
gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b3df51ed5f..e697cd4af6 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2485,6 +2485,33 @@ (define-public go-gopkg-in-go-playground-validator-v9
@end itemize")
(license license:expat)))
+(define-public go-github-com-nathan-osman-go-sunrise
+ (let ((commit "c8f9f1eb869135f07378e7e3c5ec7a005f806c73")
+ (revision "0"))
+ (package
+ (name "go-github-com-nathan-osman-go-sunrise")
+ (version (git-version "1.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nathan-osman/go-sunrise")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "017zwzx05r5spxcs07dp6bnh7waknzsd819k7aqd8kr819v3x9in"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/nathan-osman/go-sunrise"))
+ (home-page "https://github.com/nathan-osman/go-sunrise")
+ (synopsis "Calculates the sunrise and sunset times for a given location")
+ (description
+ "To calculate the sunrise and sunset times, you will need the date of your
+observation and the geographical coordinates in latitude and longitude for the
+location.")
+ (license license:expat))))
+
(define-public go-github-com-aws-sdk
(package
(name "go-github-com-aws-sdk")

base-commit: ac09fcb955e9358c330d728693759ca1a2e20542
--
2.38.1
F
F
Felix Lechner wrote on 20 Nov 2022 14:47
[PATCH 2/4] gnu: Add go-github-com-hebcal-gematriya.
(address . 59399@debbugs.gnu.org)
20221120134802.19051-2-felix.lechner@lease-up.com
* gnu/packages/golang.scm
(go-github-com-hebcal-gematriya): New variable.
---
gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e697cd4af6..4e0f62906a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2512,6 +2512,32 @@ (define-public go-github-com-nathan-osman-go-sunrise
location.")
(license license:expat))))
+(define-public go-github-com-hebcal-gematriya
+ (let ((commit "fe3043f73e415eb82727701d10f2fb40f87675e9")
+ (revision "0"))
+ (package
+ (name "go-github-com-hebcal-gematriya")
+ (version (git-version "1.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hebcal/gematriya")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xmnb2i80dy380yv8c4pd04bbyqgbc7c40p8hz1vqj2lhbm6jabf"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/hebcal/gematriya"))
+ (home-page "https://github.com/hebcal/gematriya")
+ (synopsis "Provides a system of writing numbers as Hebrew letters")
+ (description
+ "Prints numbers as Hebrew letters. Numerical values are represented using
+letters of the Hebrew alef-bet (alphabet).")
+ (license license:bsd-2))))
+
(define-public go-github-com-aws-sdk
(package
(name "go-github-com-aws-sdk")
--
2.38.1
F
F
Felix Lechner wrote on 20 Nov 2022 14:48
[PATCH 3/4] gnu: Add go-github-com-hebcal-hebcal-go.
(address . 59399@debbugs.gnu.org)
20221120134802.19051-3-felix.lechner@lease-up.com
* gnu/packages/golang.scm
(go-github-com-hebcal-hebcal-go): New variable.
---
gnu/packages/golang.scm | 42 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4e0f62906a..1d5493ad40 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2538,6 +2538,48 @@ (define-public go-github-com-hebcal-gematriya
letters of the Hebrew alef-bet (alphabet).")
(license license:bsd-2))))
+(define-public go-github-com-hebcal-hebcal-go
+ (let ((commit "d42e881860cfc9e8249fc79f268091c3c4d36b0d")
+ (revision "0"))
+ (package
+ (name "go-github-com-hebcal-hebcal-go")
+ (version (git-version "0.9.11" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hebcal/hebcal-go")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1m9akb8pwxchpaci05gambshrzw626gsrfhl25f36vjl7mq5292n"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/hebcal/hebcal-go"
+ ;; Source-only package
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Source-only package
+ (delete 'build))))
+ (propagated-inputs
+ (list go-github-com-hebcal-gematriya
+ go-github-com-nathan-osman-go-sunrise
+ go-github-com-stretchr-testify))
+ (home-page "https://github.com/hebcal/hebcal-go")
+ (synopsis "Library module for Hebcal, a perpetual Jewish Calendar")
+ (description
+ "This library converts between Hebrew and Gregorian dates, and generates lists
+of Jewish holidays for any year (past, present or future). Shabbat and holiday candle
+lighting and havdalah times are approximated based on location.
+
+Torah readings (Parashat HaShavua), Daf Yomi, and counting of the Omer can also be
+specified. Hebcal also includes algorithms to calculate yahrzeits, birthdays and
+anniversaries.")
+ (license license:gpl2+))))
+
(define-public go-github-com-aws-sdk
(package
(name "go-github-com-aws-sdk")
--
2.38.1
F
F
Felix Lechner wrote on 20 Nov 2022 14:48
[PATCH 4/4] gnu: Add hebcal.
(address . 59399@debbugs.gnu.org)
20221120134802.19051-4-felix.lechner@lease-up.com
* gnu/packages/calendar.scm (hebcal): New variable.
---
gnu/packages/calendar.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 6583810277..41c047f955 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -34,6 +34,7 @@ (define-module (gnu packages calendar)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system go)
#:use-module (guix build-system cmake)
#:use-module (guix build-system python)
#:use-module (gnu packages admin)
@@ -45,6 +46,7 @@ (define-module (gnu packages calendar)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages gtk)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages perl)
@@ -426,3 +428,37 @@ (define-public gsimplecal
launched again it closes the running instance. It can additionally be
configured to show the current time in different timezones.")
(license license:bsd-3))))
+
+(define-public hebcal
+ (let ((commit "2384bb88dc1a41a4a5ae57a29fb58b2dd49a475d")
+ (revision "0"))
+ (package
+ (name "hebcal")
+ (version (git-version "5.3.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hebcal/hebcal")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12rv3b51jb7wcjwmmizz9jkw7gh37yklys4xncvpzgxdkkfgmmjx"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/hebcal/hebcal"))
+ (native-inputs
+ (list go-github-com-hebcal-hebcal-go
+ go-github-com-pborman-getopt))
+ (synopsis "Perpetual Jewish Calendar with holidays and prayer times")
+ (description "Hebcal is a program which converts between Hebrew and Gregorian
+dates, and generates lists of Jewish holidays for any year past, present or future.
+Shabbat and holiday candle lighting and havdalah times are approximated based on
+location.
+
+It can also show daily prayer times, the weekly Torah reading (Parashat HaShavua)
+and the daily leaf of Talmud (Daf Yomi). The program can furthermore help with the
+counting of the Omer or with the calculation of Hebrew yahrzeits, birthdays or
+anniversaries.")
+ (home-page "https://github.com/hebcal/hebcal")
+ (license license:gpl2+))))
--
2.38.1
(
Re: [PATCH 1/4] gnu: Add go-github-com-nathan-osman-go-sunrise.
COH693SRWB97.OL42UKOEYP88@guix-framework
Heya,

Thanks for splitting them! A few remarks:

On Sun Nov 20, 2022 at 1:47 PM GMT, Felix Lechner wrote:
Toggle quote (3 lines)
> * gnu/packages/golang.scm
> (go-github-com-nathan-osman-go-sunrise): New variable.

Indentation for this should look something like:

* gnu/packages/golang.scm (go-github-com-nathan-osman-go-sunrise):
New variable.

Toggle quote (8 lines)
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm

> @@ -2485,6 +2485,33 @@ (define-public go-gopkg-in-go-playground-validator-v9

> + (arguments
> + '(#:import-path "github.com/nathan-osman/go-sunrise"))

Please use

(list #:import-path ...)

instead.

Toggle quote (2 lines)
> + (synopsis "Calculates the sunrise and sunset times for a given location")

Maybe change this to:

(synopsis "Calculate sunrise and sunset times in Go")

Toggle quote (5 lines)
> + (description
> + "To calculate the sunrise and sunset times, you will need the date of your
> +observation and the geographical coordinates in latitude and longitude for the
> +location.")

How about this:

(description
"This package provides a Go library for calculating sunrise and
sunset times from geographical coordinates and a date.")

-- (
(
Re: [PATCH 2/4] gnu: Add go-github-com-hebcal-gematriya.
COH6AS41JDUB.1A0POYSCST9TT@guix-framework
Heya,

On Sun Nov 20, 2022 at 1:47 PM GMT, Felix Lechner wrote:
Toggle quote (11 lines)
> * gnu/packages/golang.scm
> (go-github-com-hebcal-gematriya): New variable.

> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm

> @@ -2512,6 +2512,32 @@ (define-public go-github-com-nathan-osman-go-sunrise

> + (arguments
> + '(#:import-path "github.com/hebcal/gematriya"))

(list ...)

Toggle quote (2 lines)
> + (synopsis "Provides a system of writing numbers as Hebrew letters")

(synopsis "Print numbers as Hebrew letters in Go")

Toggle quote (4 lines)
> + (description
> + "Prints numbers as Hebrew letters. Numerical values are represented using
> +letters of the Hebrew alef-bet (alphabet).")

(description
"This package provides a Go library for printing numbers as
Hebrew letters.")

-- (
(
Re: [PATCH 3/4] gnu: Add go-github-com-hebcal-hebcal-go.
COH6FWA9FBCY.X6XZ7G03DIAS@guix-framework
On Sun Nov 20, 2022 at 1:48 PM GMT, Felix Lechner wrote:
Toggle quote (18 lines)
> * gnu/packages/golang.scm
> (go-github-com-hebcal-hebcal-go): New variable.

> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm

> @@ -2538,6 +2538,48 @@ (define-public go-github-com-hebcal-gematriya

> + (arguments
> + (list
> + #:import-path "github.com/hebcal/hebcal-go"
> + ;; Source-only package
> + #:tests? #f
> + #:phases
> + #~(modify-phases %standard-phases
> + ;; Source-only package
> + (delete 'build))))

Indent it like this:

(list #:import-path "githu.com/hebcal/hebcal-go"
#:tests? #f ;source-only package
#:phases
#~(modify-phases %standard-phases
;; Source-only package.
(delete 'build)))

Toggle quote (5 lines)
> + (propagated-inputs
> + (list go-github-com-hebcal-gematriya
> + go-github-com-nathan-osman-go-sunrise
> + go-github-com-stretchr-testify))

``go-github-com-stretchr-testify'' should probably be in native-inputs,
since it's used only in tests.

Toggle quote (2 lines)
> + (synopsis "Library module for Hebcal, a perpetual Jewish Calendar")

(synopsis "Go library for the Hebcal perpetual Jewish calendar")

Toggle quote (9 lines)
> + (description
> + "This library converts between Hebrew and Gregorian dates, and generates lists
> +of Jewish holidays for any year (past, present or future). Shabbat and holiday candle
> +lighting and havdalah times are approximated based on location.
> +
> +Torah readings (Parashat HaShavua), Daf Yomi, and counting of the Omer can also be
> +specified. Hebcal also includes algorithms to calculate yahrzeits, birthdays and
> +anniversaries.")

(description
"This package provides a library for conversion between Hebrew
and Georgian dates, and generation of lists of Jewish holidays for
a given year. Shabbat and holiday candle lighting and havdalah times
are approximated based on location.

Torah readings, Daf Yomi, and counting of the Omer can also be
specified. Algorithms are included to calculate yahrzeits, birthdays,
and anniversaries.")

-- (
(
Re: [bug#59399] [PATCH 3/4] gnu: Add go-github-com-hebcal-hebcal-go.
COH6HX3KHRW3.18N368QM0WU3V@guix-framework
On Sun Nov 20, 2022 at 2:02 PM GMT, ( via Guix-patches via wrote:
Toggle quote (10 lines)
> (description
> "This package provides a library for conversion between Hebrew
> and Georgian dates, and generation of lists of Jewish holidays for
> a given year. Shabbat and holiday candle lighting and havdalah times
> are approximated based on location.
>
> Torah readings, Daf Yomi, and counting of the Omer can also be
> specified. Algorithms are included to calculate yahrzeits, birthdays,
> and anniversaries.")

s/Georgian/Gregorian/ (I misread that in the original description :))

-- (
(
Re: [PATCH 4/4] gnu: Add hebcal.
COH6JF9WQ7BT.2GWQ2QDIH7304@guix-framework
On Sun Nov 20, 2022 at 1:48 PM GMT, Felix Lechner wrote:
Toggle quote (11 lines)
> * gnu/packages/calendar.scm (hebcal): New variable.

> --- a/gnu/packages/calendar.scm
> +++ b/gnu/packages/calendar.scm

> @@ -426,3 +428,37 @@ (define-public gsimplecal

> + (build-system go-build-system)
> + (arguments
> + '(#:import-path "github.com/hebcal/hebcal"))

(list ...)

Toggle quote (4 lines)
> + (native-inputs
> + (list go-github-com-hebcal-hebcal-go
> + go-github-com-pborman-getopt))

I think these both need to be regular inputs.

Toggle quote (2 lines)
> + (synopsis "Perpetual Jewish Calendar with holidays and prayer times")

(synopsis "Perpetual Jewish calendar program")

Toggle quote (10 lines)
> + (description "Hebcal is a program which converts between Hebrew and Gregorian
> +dates, and generates lists of Jewish holidays for any year past, present or future.
> +Shabbat and holiday candle lighting and havdalah times are approximated based on
> +location.
> +
> +It can also show daily prayer times, the weekly Torah reading (Parashat HaShavua)
> +and the daily leaf of Talmud (Daf Yomi). The program can furthermore help with the
> +counting of the Omer or with the calculation of Hebrew yahrzeits, birthdays or
> +anniversaries.")

(description
"Hebcal is a program for converting between Hebrew and Gregorian
dates, and generating lists of Jewish holidays for a given year.
Shabbat, holiday candle lighting, and havdalah times are approximated
using your location.

It can also show daily prayer times, the weekly Torah reading, and
the daily leaf of Talmud. The program can help with counting of the
Omer or with calculation of Hebrew yahrzeits, birthdays, or
anniversaries.")

-- (
F
F
Felix Lechner wrote on 20 Nov 2022 18:23
[PATCH 1/4] gnu: Add go-github-com-nathan-osman-go-sunrise.
(address . 59399@debbugs.gnu.org)
20221120172402.26408-1-felix.lechner@lease-up.com
* gnu/packages/golang.scm (go-github-com-nathan-osman-go-sunrise):
New variable.
---
gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b3df51ed5f..78443b81a5 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2485,6 +2485,32 @@ (define-public go-gopkg-in-go-playground-validator-v9
@end itemize")
(license license:expat)))
+(define-public go-github-com-nathan-osman-go-sunrise
+ (let ((commit "c8f9f1eb869135f07378e7e3c5ec7a005f806c73")
+ (revision "0"))
+ (package
+ (name "go-github-com-nathan-osman-go-sunrise")
+ (version (git-version "1.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nathan-osman/go-sunrise")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "017zwzx05r5spxcs07dp6bnh7waknzsd819k7aqd8kr819v3x9in"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/nathan-osman/go-sunrise"))
+ (home-page "https://github.com/nathan-osman/go-sunrise")
+ (synopsis "Calculate sunrise and sunset times in Go")
+ (description
+ "This package provides a Go library for calculating sunrise and
+sunset times from geographical coordinates and a date.")
+ (license license:expat))))
+
(define-public go-github-com-aws-sdk
(package
(name "go-github-com-aws-sdk")

base-commit: ac09fcb955e9358c330d728693759ca1a2e20542
--
2.38.1
F
F
Felix Lechner wrote on 20 Nov 2022 18:24
[PATCH 3/4] gnu: Add go-github-com-hebcal-hebcal-go.
(address . 59399@debbugs.gnu.org)
20221120172402.26408-3-felix.lechner@lease-up.com
* gnu/packages/golang.scm (go-github-com-hebcal-hebcal-go):
New variable.
---
gnu/packages/golang.scm | 43 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2dc7091b4b..ff290213cd 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2537,6 +2537,49 @@ (define-public go-github-com-hebcal-gematriya
Hebrew letters.")
(license license:bsd-2))))
+(define-public go-github-com-hebcal-hebcal-go
+ (let ((commit "d42e881860cfc9e8249fc79f268091c3c4d36b0d")
+ (revision "0"))
+ (package
+ (name "go-github-com-hebcal-hebcal-go")
+ (version (git-version "0.9.11" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hebcal/hebcal-go")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1m9akb8pwxchpaci05gambshrzw626gsrfhl25f36vjl7mq5292n"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/hebcal/hebcal-go"
+ ;; Source-only package
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Source-only package
+ (delete 'build))))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-hebcal-gematriya
+ go-github-com-nathan-osman-go-sunrise))
+ (home-page "https://github.com/hebcal/hebcal-go")
+ (synopsis "Go library for the Hebcal perpetual Jewish calendar")
+ (description
+ "This package provides a library for conversion between Hebrew
+and Gregorian dates, and generation of lists of Jewish holidays for
+a given year. Shabbat and holiday candle lighting and havdalah times
+are approximated based on location.
+
+Torah readings, Daf Yomi, and counting of the Omer can also be
+specified. Algorithms are included to calculate yahrzeits, birthdays,
+and anniversaries.")
+ (license license:gpl2+))))
+
(define-public go-github-com-aws-sdk
(package
(name "go-github-com-aws-sdk")
--
2.38.1
F
F
Felix Lechner wrote on 20 Nov 2022 18:24
[PATCH 2/4] gnu: Add go-github-com-hebcal-gematriya.
(address . 59399@debbugs.gnu.org)
20221120172402.26408-2-felix.lechner@lease-up.com
* gnu/packages/golang.scm (go-github-com-hebcal-gematriya):
New variable.
---
gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 78443b81a5..2dc7091b4b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2511,6 +2511,32 @@ (define-public go-github-com-nathan-osman-go-sunrise
sunset times from geographical coordinates and a date.")
(license license:expat))))
+(define-public go-github-com-hebcal-gematriya
+ (let ((commit "fe3043f73e415eb82727701d10f2fb40f87675e9")
+ (revision "0"))
+ (package
+ (name "go-github-com-hebcal-gematriya")
+ (version (git-version "1.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hebcal/gematriya")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xmnb2i80dy380yv8c4pd04bbyqgbc7c40p8hz1vqj2lhbm6jabf"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/hebcal/gematriya"))
+ (home-page "https://github.com/hebcal/gematriya")
+ (synopsis "Print numbers as Hebrew letters in Go")
+ (description
+ "This package provides a Go library for printing numbers as
+Hebrew letters.")
+ (license license:bsd-2))))
+
(define-public go-github-com-aws-sdk
(package
(name "go-github-com-aws-sdk")
--
2.38.1
F
F
Felix Lechner wrote on 20 Nov 2022 18:24
[PATCH 4/4] gnu: Add hebcal.
(address . 59399@debbugs.gnu.org)
20221120172402.26408-4-felix.lechner@lease-up.com
* gnu/packages/calendar.scm (hebcal): New variable.
---
gnu/packages/calendar.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 6583810277..32a8f23f19 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -34,6 +34,7 @@ (define-module (gnu packages calendar)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system go)
#:use-module (guix build-system cmake)
#:use-module (guix build-system python)
#:use-module (gnu packages admin)
@@ -45,6 +46,7 @@ (define-module (gnu packages calendar)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages gtk)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages perl)
@@ -426,3 +428,38 @@ (define-public gsimplecal
launched again it closes the running instance. It can additionally be
configured to show the current time in different timezones.")
(license license:bsd-3))))
+
+(define-public hebcal
+ (let ((commit "2384bb88dc1a41a4a5ae57a29fb58b2dd49a475d")
+ (revision "0"))
+ (package
+ (name "hebcal")
+ (version (git-version "5.3.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hebcal/hebcal")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12rv3b51jb7wcjwmmizz9jkw7gh37yklys4xncvpzgxdkkfgmmjx"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/hebcal/hebcal"))
+ (inputs
+ (list go-github-com-hebcal-hebcal-go
+ go-github-com-pborman-getopt))
+ (synopsis "Perpetual Jewish Calendar program")
+ (description
+ "Hebcal is a program for converting between Hebrew and Gregorian
+dates, and generating lists of Jewish holidays for a given year.
+Shabbat, holiday candle lighting, and havdalah times are approximated
+using your location.
+
+It can also show daily prayer times, the weekly Torah reading, and
+the daily leaf of Talmud. The program can help with counting of the
+Omer or with calculation of Hebrew yahrzeits, birthdays, or
+anniversaries.")
+ (home-page "https://github.com/hebcal/hebcal")
+ (license license:gpl2+))))
--
2.38.1
(
Re: [PATCH 1/4] gnu: Add go-github-com-nathan-osman-go-sunrise.
COHAS8YU6FFE.1644QHD4P6QJ2@guix-framework
Heya,

On Sun Nov 20, 2022 at 5:23 PM GMT, Felix Lechner wrote:
Toggle quote (11 lines)
> * gnu/packages/golang.scm (go-github-com-nathan-osman-go-sunrise):
> New variable.

> * gnu/packages/golang.scm (go-github-com-hebcal-gematriya):
> New variable.

> * gnu/packages/golang.scm (go-github-com-hebcal-hebcal-go):
> New variable.

> * gnu/packages/calendar.scm (hebcal): New variable.

All LGTM!

-- (
C
C
Christopher Baines wrote on 24 Nov 2022 10:48
Re: [bug#59399] [PATCH 1/4] gnu: Add go-github-com-nathan-osman-go-sunrise.
87wn7kznqq.fsf@cbaines.net
"( via Guix-patches" via <guix-patches@gnu.org> writes:

Toggle quote (18 lines)
> Heya,
>
> On Sun Nov 20, 2022 at 5:23 PM GMT, Felix Lechner wrote:
>> * gnu/packages/golang.scm (go-github-com-nathan-osman-go-sunrise):
>> New variable.
>
>> * gnu/packages/golang.scm (go-github-com-hebcal-gematriya):
>> New variable.
>
>> * gnu/packages/golang.scm (go-github-com-hebcal-hebcal-go):
>> New variable.
>
>> * gnu/packages/calendar.scm (hebcal): New variable.
>
> All LGTM!
>
> -- (

Thanks both! I've gone ahead and pushed these patches to master as
963e86af87216e8c1f4967e8047e8de415bb1000.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmN/Pg1fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XeFohAAoNHwYg476h4o0rxD3cQ2CwTpfJtNp6+c
d0fybdDkcgmjTLDMr9osq4yyVwTQIQX1wZa/dHN2MzEIQ7VKjgw8AYD/EFwEeIt0
livTlhPJjnKGG+mww1yraPQ/U2+F9MwIHPH7YgxuLqqE7gDba+fZXts8zpLFFxdj
sPFUuzljoRZC+vE7gznY107rX2kf1WFoklzAQZOFg0w553YfI5XhHfgnsJjM5ylO
JXjtkYfbuksOUzNWr3I+HNI4K7vl7n3X7wqdXX/i1tfDF13MqBUP3HOhzIxErk88
tMXmB1E1u1EidTEK6b8PrGeVGS60qLYY1sdcS82EIWyZcUlrfgaGUB+eDIb+XOsi
OhAP7J0CBkjpCsiEAi4udRdb6vn5ArjxgjX4Ia8FGmXJ17/Yvt+VROAp8B8k0TYk
eOgzsj2Mz6z5u29GiID9S3So4MS5aMdgxxzW5UtDZQ3bShGkVdYQSLDhSh80ZUpj
+xWa+aBPyiKdI7DmEV8ZcTALBcTuay2DUKlA52F0GoiOuCCd31RtRbPtzYzIHrST
7GMvdlvLsW/ypk8N3AlfjKQzrKpu09T97HjkDgR2vEvkVUXypoFryQNCIOjBYeyS
bP4zcOG91EBsj6yURBGuK4USRW6OF3XqivThwHssIfq9IauZOCILVd9WDpYtbOwR
srSd4rdSeXk=
=YDqH
-----END PGP SIGNATURE-----

?