[PATCH 0/1] gnu: Add Virality Engine

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 2 years ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221119224230.30143-1-sharlatanus@gmail.com
Hi Guix team!

This is a final patch which summarised my efforts to bring Virality Game
Engine to Guix.

There is one thing to note, some of the packages which are in Guix right now
were merged into Virality code base recently and upstream development
completely closed by the author (see README note):

Here is a list of them:
Toggle quote (6 lines)
> 10188: (url "https://git.mfiano.net/mfiano/origin")
> 12838: (url "https://git.mfiano.net/mfiano/pngload.git")
> 16850: (url "https://git.mfiano.net/mfiano/shadow")
> 16889: (url "https://git.mfiano.net/mfiano/umbra")

Other proposal I would think of is to move cl-trial and cl-vriality from
lisp-xyz.scm to game-development.scm as it's more logically bound to that
module.

Toggle quote (4 lines)
> ./pre-inst-env guix build sbcl-virality cl-virality --rounds=2
> /gnu/store/cgljdd5vm8anxf9v0ips2vbalv6fp23k-cl-virality-0.3.0
> /gnu/store/8y3qv6f8w71l4zf1d4953xjq82a1mw01-sbcl-virality-0.3.0

Sharlatan Hellseher (1):
gnu: Add cl-virality

gnu/packages/lisp-xyz.scm | 66 +++++++++++++++++++++++++++++++++++++++
1 file changed, 66 insertions(+)


base-commit: bd0ff2d39bc7d3b497d74c3431ef77a1cf2515c4
prerequisite-patch-id: 679d60737b0daafbb9c5e2db480ac538b59d5889
prerequisite-patch-id: dceb083c0c80f3986ab02546b763ac4d69342a11
prerequisite-patch-id: 636da9a70d66737b8978d362c192df0820fe0cd7
prerequisite-patch-id: cf2ad82da6f03a7f44d2af4872682e3921ebc001
prerequisite-patch-id: 99bb09ac0a5fd8d0f837a33f3810fc9be47da3f2
prerequisite-patch-id: bd774bf62993e83ea51423f56474b6802739df10
--
2.38.0
Sharlatan Hellseher wrote 2 years ago
[PATCH 1/1] gnu: Add cl-virality
(address . 59391@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221119224341.30219-1-sharlatanus@gmail.com
* gnu/packages/lisp-xyz.scm (cl-virality, sbcl-virality): New variables.
---
gnu/packages/lisp-xyz.scm | 66 +++++++++++++++++++++++++++++++++++++++
1 file changed, 66 insertions(+)

Toggle diff (79 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 5b0d03586f..d46c07ec10 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -19164,6 +19164,72 @@ (define-public ecl-trial
(define-public cl-trial
(sbcl-package->cl-source-package sbcl-trial))
+(define-public sbcl-virality
+ (package
+ (name "sbcl-virality")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bufferswap/ViralityEngine")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "virality" version))
+ (sha256
+ (base32 "0hvjcvyd628jh4if6swk1wrfb9qdlnpk9ax1y3jarr8ms7ghfcdb"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:asd-systems '("virality"
+ "vorigin"
+ "vorigin.test"
+ "vshadow"
+ "vumbra"
+ "vutils")))
+ (inputs
+ (list sbcl-3b-bmfont
+ sbcl-babel
+ sbcl-cl-cpus
+ sbcl-cl-graph
+ sbcl-cl-opengl
+ sbcl-cl-ppcre
+ sbcl-cl-slug
+ sbcl-closer-mop
+ sbcl-fast-io
+ sbcl-global-vars
+ sbcl-glsl-packing
+ sbcl-jsown
+ sbcl-lparallel
+ sbcl-pngload
+ sbcl-printv
+ sbcl-queues
+ sbcl-sdl2
+ sbcl-serapeum
+ sbcl-split-sequence
+ sbcl-static-vectors
+ sbcl-trivial-features
+ sbcl-varjo))
+ (home-page "https://github.com/bufferswap/ViralityEngine")
+ (synopsis "Component-based game engine written in Common Lisp")
+ (description
+ "Virality Engine provides a system and workflow that helps describe the
+elements needed to write 2D or 3D games. It was designed with several domain
+specific languages that make it easier to describe, manipulate, and use assets
+commonly found in game making. Such assets include (but are not limited to)
+textures, materials, shader programs, and scene trees of actors that are
+available for instantiation. Virality Engine also knows how to accept input
+from keyboards and most joysticks and gamepads.
+
+The component system is a hybrid model between an ECS and an object model. The
+components are defined similar to CLOS defclass, and regular generic methods
+can be used with them. Components are added to Actors which represent game
+concepts like players, scenery, effects, etc. We define a component protocol
+invoked by Virality Engine to move your components to the next state and
+render them each frame.")
+ (license license:expat)))
+
+(define-public cl-virality
+ (sbcl-package->cl-source-package sbcl-virality))
+
(define-public sbcl-cl-liballegro
(let ((commit "49f632ce97fc4f835bf5d450588793234b980a64")
(revision "1"))
--
2.38.0
Guillaume Le Vaillant wrote 2 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 59391-done@debbugs.gnu.org)
87cz9hybyo.fsf@kitej
Patch pushed as 9c2d6ddfbed949d55230cb785d0245f5ef21daa6.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCY3ov7w8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+iZAD+L3yb2Alg3E59lUuHWUKOFU0rAw60k6RdrAAh
i32LPs0A+wXKiRk+9S9GfmRaGhW1FI4pVcuwDH5b4lYIfNiwXlgP
=J0CM
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59391@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59391
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help