[PATCH] gnu: Add cl-ucons.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Paul A. Patience
Owner
unassigned
Submitted by
Paul A. Patience
Severity
normal
P
P
Paul A. Patience wrote on 19 Nov 2022 05:46
(address . guix-patches@gnu.org)(name . Paul A. Patience)(address . paul@apatience.com)
20221119044601.296448-1-paul@apatience.com
* gnu/packages/lisp-xyz.scm (sbcl-ucons, cl-ucons, ecl-ucons): New
variables.
---
gnu/packages/lisp-xyz.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index d1f6b9b5e2..04d1d32651 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -3810,6 +3810,44 @@ (define-public cl-trivial-garbage
(define-public ecl-trivial-garbage
(sbcl-package->ecl-package sbcl-trivial-garbage))

+(define-public sbcl-ucons
+ (let ((commit "d976810ef2b12a2caaf55bd0f258272e9b79f3be")
+ (revision "0"))
+ (package
+ (name "sbcl-ucons")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/marcoheisig/ucons")
+ (commit commit)))
+ (file-name (git-file-name "cl-ucons" version))
+ (sha256
+ (base32 "17aj47pdjiywnf33hl46p27za2q0pq5ar3fpqxaqskggxrfxmijl"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ (list sbcl-alexandria
+ sbcl-atomics
+ sbcl-bordeaux-threads
+ sbcl-named-readtables
+ sbcl-trivia))
+ (home-page "https://github.com/marcoheisig/ucons")
+ (synopsis "Unique conses for Common Lisp")
+ (description "UCONS is a Common Lisp library providing unique conses.
+Unique conses are different from regular conses in that, in addition to their
+@code{car} and @code{cdr}, they maintain a table of past users. Also, the
+@code{cdr} of each ucons is restricted to other uconses or @code{nil}.
+Uconses are meant for those situations where even reusing regular conses (to
+avoid consing) is too computationally expensive.")
+ (license license:expat))))
+
+(define-public cl-ucons
+ (sbcl-package->cl-source-package sbcl-ucons))
+
+(define-public ecl-ucons
+ (sbcl-package->ecl-package sbcl-ucons))
+
(define-public sbcl-closer-mop
(let ((commit "19c9d33f576e10715fd79cc1d4f688dab0f241d6"))
(package
--
2.38.0
G
G
Guillaume Le Vaillant wrote on 19 Nov 2022 13:03
(name . Paul A. Patience)(address . paul@apatience.com)(address . 59376-done@debbugs.gnu.org)
878rk76ti0.fsf@kitej
Patch pushed as 854bdb7ba9abd6392da823f723553df03077e9a7.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCY3jGJw8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/LAAD/Xpp4TP+ehhG0sE7rjBtJqdyQtkMctg0b4Zng
EmILtLUA/i2hhSKev7ByiECnwNVzKyFTpce69+pRJZtSwc2qk1p1
=JcTn
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59376@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59376
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch