[PATCH] gnu: Add cl-typo.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Paul A. Patience
Owner
unassigned
Submitted by
Paul A. Patience
Severity
normal
P
P
Paul A. Patience wrote on 19 Nov 2022 05:11
(address . guix-patches@gnu.org)(name . Paul A. Patience)(address . paul@apatience.com)
20221119041128.292591-1-paul@apatience.com
* gnu/packages/lisp-xyz.scm (sbcl-typo, cl-typo, ecl-typo): New
variables.
---
gnu/packages/lisp-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 1498a9657d..d1f6b9b5e2 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -6934,6 +6934,42 @@ (define-public ecl-type-i
;; The tests get stuck indefinitly
'(#:tests? #f))))

+(define-public sbcl-typo
+ (let ((commit "0e883490f81edf2a1be4e5b101d1caec78d7853b")
+ (revision "0"))
+ (package
+ (name "sbcl-typo")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/marcoheisig/Typo")
+ (commit commit)))
+ (file-name (git-file-name "cl-typo" version))
+ (sha256
+ (base32 "08cmkjl3f77rfhxbjyd6f3kinhzak30mdfphnpf73sh1vw4v0vym"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ (list sbcl-alexandria
+ sbcl-closer-mop
+ sbcl-introspect-environment
+ sbcl-trivia
+ sbcl-trivial-arguments
+ sbcl-trivial-garbage))
+ (home-page "https://github.com/marcoheisig/Typo")
+ (synopsis "Portable type inference library for Common Lisp")
+ (description
+ "Typo is a portable library for Common Lisp that does approximate
+reasoning about types, but without consing.")
+ (license license:expat))))
+
+(define-public cl-typo
+ (sbcl-package->cl-source-package sbcl-typo))
+
+(define-public ecl-typo
+ (sbcl-package->ecl-package sbcl-typo))
+
(define-public sbcl-optima
(let ((commit "373b245b928c1a5cce91a6cb5bfe5dd77eb36195")
(revision "1"))
--
2.38.0
G
G
Guillaume Le Vaillant wrote on 19 Nov 2022 13:02
(name . Paul A. Patience)(address . paul@apatience.com)(address . 59375-done@debbugs.gnu.org)
87cz9j6tj9.fsf@kitej
Patch pushed as c3267528b5a0231b0920d25dff9a927ebd6c5440.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCY3jF+g8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8m1wD9HfnF1fC+AEW+Mo+GzvsR0mBKGaR7gzl7HjTM
vDKJYlwBAIcEZ4NVNg5V4rEmJEShxWJ1b2m4RbMILVuR1PKX3r1l
=dE0f
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59375@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59375
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch