linux-libre 6 breaks OpenGL on nouveau driver for nvidia 8800 GTS 640 Mo card

  • Done
  • quality assurance status badge
Details
2 participants
  • Tobias Alexandra Platen
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 18 Nov 2022 16:47
linux-libre 6 breaks OpenGL on nouveau driver
(name . bug-guix)(address . bug-guix@gnu.org)
87h6yw463e.fsf@gmail.com
Hi,

When booting my Guix System with linux-libre 6.0.8, nouveau silently
fails to render OpenGL. It includes symptoms such as:

1. Getting stuck on the GDM screen, which makes use of OpenGL
2. Not being able to use Qt5 or Qt6 applications, which renders via
OpenGL.
3. the 'glxgears' program from mesa-utils displays frozen gears (not
turning)

My graphic card is an old nvidia 8800 GTS with 640 MiB of video RAM.

Workaround: Adding the '(kernel linux-libre-5.15)' to my OS definition
fixes it.

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 20 Nov 2022 14:42
(address . 59361@debbugs.gnu.org)
87h6yt3foi.fsf@gmail.com
Hello,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (16 lines)
> Hi,
>
> When booting my Guix System with linux-libre 6.0.8, nouveau silently
> fails to render OpenGL. It includes symptoms such as:
>
> 1. Getting stuck on the GDM screen, which makes use of OpenGL
> 2. Not being able to use Qt5 or Qt6 applications, which renders via
> OpenGL.
> 3. the 'glxgears' program from mesa-utils displays frozen gears (not
> turning)
>
> My graphic card is an old nvidia 8800 GTS with 640 MiB of video RAM.
>
> Workaround: Adding the '(kernel linux-libre-5.15)' to my OS definition
> fixes it.

Now reported upstream at

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 27 Nov 2022 18:04
(address . 59361@debbugs.gnu.org)
87y1rwpbw8.fsf@gmail.com
Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (23 lines)
> Hello,
>
> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>
>> Hi,
>>
>> When booting my Guix System with linux-libre 6.0.8, nouveau silently
>> fails to render OpenGL. It includes symptoms such as:
>>
>> 1. Getting stuck on the GDM screen, which makes use of OpenGL
>> 2. Not being able to use Qt5 or Qt6 applications, which renders via
>> OpenGL.
>> 3. the 'glxgears' program from mesa-utils displays frozen gears (not
>> turning)
>>
>> My graphic card is an old nvidia 8800 GTS with 640 MiB of video RAM.
>>
>> Workaround: Adding the '(kernel linux-libre-5.15)' to my OS definition
>> fixes it.
>
> Now reported upstream at
> https://gitlab.freedesktop.org/drm/nouveau/-/issues/192.

The commit that regressed was found via git bisect, by using the
following in my system configuration:

Toggle snippet (28 lines)
modified guix/hurd.scm
@@ -1,6 +1,7 @@
(use-modules (gnu)
+ (guix git)
(guix modules)
(guix store)
(srfi srfi-1)
@@ -98,6 +99,21 @@

+(define make-linux-libre* (@@ (gnu packages linux) make-linux-libre*))
+
+(define (linux-source commit)
+ (git-checkout
+ (url "file:///home/maxim/src/linux")
+ (commit commit)))
+
+(define %linux-commit "889fcbe949bdd8470931a90b91f273ca18c510c1")
+
+(define-public %linux-kernel
+ (make-linux-libre* "5.19" "0" (linux-source %linux-commit) '("x86_64-linux")
+ #:configuration-file (@@ (gnu packages linux) kernel-config)
+ #:extra-version "stock"
+ #:build-doc? #f))
+
(define %mapped-devices
(list (mapped-device

And changing the value of %linux-commit for each git bisect. The
original git-checkout clone took forever (multiple hours), but after the
initial clone done, each kernel build took about 20 minutes on a fast
machine.

The offending Linux commit is 889fcbe949bdd8470931a90b91f273ca18c510c1 [0]


--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 13 Jan 2023 22:08
control message for bug #59361
(address . control@debbugs.gnu.org)
877cxqf8h2.fsf@gmail.com
retitle 59361 linux-libre 6 breaks OpenGL on nouveau driver for nvidia 8800 GTS 640 Mo card
quit
M
M
Maxim Cournoyer wrote on 1 May 18:31 +0200
Re: bug#59361: linux-libre 6 breaks OpenGL on nouveau driver for nvidia 8800 GTS 640 Mo card
(address . 59361-done@debbugs.gnu.org)
874jbh8pff.fsf@gmail.com
Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (16 lines)
> Hi,
>
> When booting my Guix System with linux-libre 6.0.8, nouveau silently
> fails to render OpenGL. It includes symptoms such as:
>
> 1. Getting stuck on the GDM screen, which makes use of OpenGL
> 2. Not being able to use Qt5 or Qt6 applications, which renders via
> OpenGL.
> 3. the 'glxgears' program from mesa-utils displays frozen gears (not
> turning)
>
> My graphic card is an old nvidia 8800 GTS with 640 MiB of video RAM.
>
> Workaround: Adding the '(kernel linux-libre-5.15)' to my OS definition
> fixes it.

I tried using linux-libre 6.8.8 today (Guix commit
df3d30819e650a490ef39dd6692740bb13263c75), which has Mesa 24.0.4, and
can no longer reproduce the problem described above.

I'm thus happily closing this!

--
Thanks,
Maxim
Closed
T
T
Tobias Alexandra Platen wrote on 5 May 15:42 +0200
8cf2de6ebbf68fc17e87be6ee1c0e1d70b31e6b3.camel@platen-software.de
That is interesting. Does anybody know which old GPUs will
work with linux-libre. On my Talos II, I noticed that even
old nvidia GPUs do not work, the POWER9 will shutdown the
link to GPU. I guess only AMD and Intel CPUs will work,
and maybe also the RK3399 which I was unable to test.

Alex

On Wed, 2024-05-01 at 12:31 -0400, Maxim Cournoyer wrote:
Toggle quote (30 lines)
> Hi,
>
> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>
> > Hi,
> >
> > When booting my Guix System with linux-libre 6.0.8, nouveau
> > silently
> > fails to render OpenGL.  It includes symptoms such as:
> >
> > 1. Getting stuck on the GDM screen, which makes use of OpenGL
> > 2. Not being able to use Qt5 or Qt6 applications, which renders via
> > OpenGL.
> > 3. the 'glxgears' program from mesa-utils displays frozen gears
> > (not
> > turning)
> >
> > My graphic card is an old nvidia 8800 GTS with 640 MiB of video
> > RAM.
> >
> > Workaround: Adding the '(kernel linux-libre-5.15)' to my OS
> > definition
> > fixes it.
>
> I tried using linux-libre 6.8.8 today (Guix commit
> df3d30819e650a490ef39dd6692740bb13263c75), which has Mesa 24.0.4, and
> can no longer reproduce the problem described above.
>
> I'm thus happily closing this!
>
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59361@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59361
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch