[PATCH] gnu: Add delve.

  • Done
  • quality assurance status badge
Details
2 participants
  • Matthew James Kraai
  • Ludovic Courtès
Owner
unassigned
Submitted by
Matthew James Kraai
Severity
normal

Debbugs page

Matthew James Kraai wrote 2 years ago
(address . guix-patches@gnu.org)(name . Matthew James Kraai)(address . kraai@ftbfs.org)
20221118122506.26095-1-kraai@ftbfs.org
* gnu/packages/debug.scm (delve): New variable.
---
gnu/packages/debug.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 0c7f97b386..f06e869efe 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2022 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2022 Matthew James Kraai <kraai@ftbfs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -34,6 +35,8 @@ (define-module (gnu packages debug)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system go)
+ #:use-module (guix gexp)
#:use-module (gnu packages)
#:use-module (gnu packages attr)
#:use-module (gnu packages autotools)
@@ -856,3 +859,29 @@ (define-public seer-gdb
(home-page "https://github.com/epasveer/seer")
;; Note: Some icons in src/resources are creative commons 3.0 and/or 4.0.
(license license:gpl3+)))
+
+(define-public delve
+ (package
+ (name "delve")
+ (version "1.9.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-delve/delve")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07jch3yd1pgqviyy18amn23gazbzi7l51f210c3vmc707v3vbbqr"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/go-delve/delve/cmd/dlv"
+ #:unpack-path "github.com/go-delve/delve"
+ #:install-source? #f
+ #:phases #~(modify-phases %standard-phases (delete 'check))))
+ (propagated-inputs (list go))
+ (home-page "https://github.com/go-delve/delve")
+ (synopsis "Debugger for the Go programming language")
+ (description "Delve is a debugger for the Go programming language.")
+ (license license:expat)))
--
2.38.0
Ludovic Courtès wrote 2 years ago
(name . Matthew James Kraai)(address . kraai@ftbfs.org)(address . 59357-done@debbugs.gnu.org)
87lenmlv4r.fsf@gnu.org
Hi,

Matthew James Kraai <kraai@ftbfs.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/debug.scm (delve): New variable.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59357@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59357
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help