[PATCH 0/3] gnu: WIP Add cl-graph

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 18 Nov 2022 00:47
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221117234754.5396-1-sharlatanus@gmail.com
Hi Guix team!

This patch series includes last inputs for cl-graph, but not cl-graph itself
as build phase failes with error:

Toggle quote (6 lines)
> Unhandled SB-INT:SIMPLE-FILE-ERROR in thread #<SB-THREAD:THREAD "main thread" RUNNING
> {100B108083}>:
> Error opening #P"/gnu/store/718rs4smnilaf2fhf4mqbxlkc4qicka3-sbcl-cl-containers-0.12.1-3.3d1df53/lib/common-lisp/sbcl/cl-containers/dev/utilities-integration-tmp1CXFJSK9.fasl":
>
> Permission denied

I've got WIP package in my personal repo
I'll to figure out why it's failing, but if anyone may take a look it would be
great too!

Toggle quote (10 lines)
> ./pre-inst-env guix build cl-asdf-system-connections cl-metacopy sbcl-cl-mathstats sbcl-asdf-system-connections sbcl-metacopy ecl-cl-mathstats ecl-asdf-system-connections ecl-cl-mathstats --rounds=2
> /gnu/store/0cj01ffnbhvrm8kaw4mi81xh92mv6v32-ecl-cl-mathstats-0.8.2-1.4df38ea
> /gnu/store/jylgizsq3gv16024jfd54z71ygkbn10a-ecl-asdf-system-connections-0.8.4-1.9f08524
> /gnu/store/0cj01ffnbhvrm8kaw4mi81xh92mv6v32-ecl-cl-mathstats-0.8.2-1.4df38ea
> /gnu/store/cg5iip9ncl345wxc9n34zpraswkznb8a-sbcl-metacopy-0.2.0-1.1b5bf44
> /gnu/store/lmmv8r7rzkfs7why6wlgbz9dg6rg4cf2-sbcl-asdf-system-connections-0.8.4-1.9f08524
> /gnu/store/lnq9a5rq4clfx7w6hvjwj14h7i7adqyi-sbcl-cl-mathstats-0.8.2-1.4df38ea
> /gnu/store/8k7hljl0fvk7qg23443sq4llsv7q6sy1-cl-metacopy-0.2.0-1.1b5bf44
> /gnu/store/s9vhj3sf645ydi9vadmjfbm79nwj07yi-cl-asdf-system-connections-0.8.4-1.9f08524

Sharlatan Hellseher (3):
gnu: Add cl-asdf-system-connections
gnu: Add cl-metacopy
gnu: Add sbcl-cl-mathstats

gnu/packages/lisp-xyz.scm | 94 +++++++++++++++++++++++++++++++++++++++
1 file changed, 94 insertions(+)


base-commit: 83c9e00ffbd41776c003f6992e9d613a5434fff9
prerequisite-patch-id: 679d60737b0daafbb9c5e2db480ac538b59d5889
--
2.38.0
S
S
Sharlatan Hellseher wrote on 18 Nov 2022 00:50
[PATCH 1/3] gnu: Add cl-asdf-system-connections
(address . 59344@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221117235020.5587-1-sharlatanus@gmail.com
* gnu/packages/lisp-xyz.scm (cl-asdf-system-connections,
ecl-asdf-system-connections, sbcl-asdf-system-connections): New variables.
---
gnu/packages/lisp-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 45fcb108f0..8df8579111 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -616,6 +616,34 @@ (define-public ecl-asdf-finalizers
(define-public cl-asdf-finalizers
(sbcl-package->cl-source-package sbcl-asdf-finalizers))
+(define-public sbcl-asdf-system-connections
+ (let ((commit "9f085240febccccff99d9d3bb687fcaafffd3f5e")
+ (revision "1"))
+ (package
+ (name "sbcl-asdf-system-connections")
+ (version (git-version "0.8.4" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gwkkwg/asdf-system-connections")
+ (commit commit)))
+ (file-name (git-file-name "asdf-system-connections" version))
+ (sha256
+ (base32 "06kg0m8bv383qq3r34x0f8hz6p6zxcw02qn7kj960vcnrp5a5b3y"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/gwkkwg/asdf-system-connections")
+ (synopsis "Common Lisp ASDF system auto-loading extantion")
+ (description "This package povides Common Lisp ASDF system auto-loading
+extantion.")
+ (license license:expat))))
+
+(define-public ecl-asdf-system-connections
+ (sbcl-package->ecl-package sbcl-asdf-system-connections))
+
+(define-public cl-asdf-system-connections
+ (sbcl-package->cl-source-package sbcl-asdf-system-connections))
+
(define-public sbcl-net.didierverna.asdf-flv
(package
(name "sbcl-net.didierverna.asdf-flv")
--
2.38.0
S
S
Sharlatan Hellseher wrote on 18 Nov 2022 00:50
[PATCH 3/3] gnu: Add sbcl-cl-mathstats
(address . 59344@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221117235020.5587-3-sharlatanus@gmail.com
* gnu/packages/lisp-xyz.scm (cl-mathstats, ecl-cl-mathstats,
sbcl-cl-mathstats): New variables.
---
gnu/packages/lisp-xyz.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 9e5d5e76d8..1c63f12c39 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -16508,6 +16508,38 @@ (define-public ecl-bodge-math
(define-public cl-bodge-math
(sbcl-package->cl-source-package sbcl-bodge-math))
+(define-public sbcl-cl-mathstats
+ (let ((commit "4df38ea1b9de069cf939919253565a9ca9538eca")
+ (revision "1"))
+ (package
+ (name "sbcl-cl-mathstats")
+ (version (git-version "0.8.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gwkkwg/cl-mathstats")
+ (commit commit)))
+ (file-name (git-file-name "cl-mathstats" version))
+ (sha256
+ (base32 "0gsjvmkmnxc4hp5z9mkm5vsllywqyg7kx8jgz88vnx47yj3va1s8"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ (list sbcl-lift))
+ (inputs
+ (list sbcl-cl-containers sbcl-metatilities-base))
+ (home-page "https://github.com/gwkkwg/cl-mathstats")
+ (synopsis "Common Lisp collection of mathematical routines")
+ (description
+ "This package provides Common Lisp math and statistics routines.")
+ (license license:expat))))
+
+(define-public ecl-cl-mathstats
+ (sbcl-package->ecl-package sbcl-cl-mathstats))
+
+(define-public cl-mathstats
+ (sbcl-package->cl-source-package sbcl-cl-mathstats))
+
(define-public sbcl-bodge-blobs-support
(let ((commit "c5034ca5f4fc3a44dbadeba215a09afd59a404b0")
(revision "1"))
--
2.38.0
S
S
Sharlatan Hellseher wrote on 18 Nov 2022 00:50
[PATCH 2/3] gnu: Add cl-metacopy
(address . 59344@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221117235020.5587-2-sharlatanus@gmail.com
* gnu/packages/lisp-xyz.scm (cl-metacopy, sbcl-metacopy): New variables.
---
gnu/packages/lisp-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 8df8579111..9e5d5e76d8 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -17996,6 +17996,40 @@ (define-public ecl-simple-inferiors
(define-public cl-simple-inferiors
(sbcl-package->cl-source-package sbcl-simple-inferiors))
+(define-public sbcl-metacopy
+ (let ((commit "1b5bf443206cc1dea7801ae23d1167bd02122d30")
+ (revision "1"))
+ (package
+ (name "sbcl-metacopy")
+ (version (git-version "0.2.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gwkkwg/metacopy")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rzp112djgw5n76s6hy2aq92bc43p0zd5bgzvqwvgvws4pls42s9"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ (list sbcl-lift sbcl-asdf-system-connections))
+ (inputs
+ (list sbcl-contextl sbcl-moptilities))
+ (home-page "https://github.com/gwkkwg/metacopy")
+ (synopsis "Flexible Common Lisp shallow/deep copy mechanism")
+ (description
+ "This package provides flexible Common Lisp shallow/deep copy mechanism.")
+ (license license:expat))))
+
+;; NOTE: (Sharlatan-20221112T214131+0000): There is no ecl-moptilities variable
+;; required for tests.
+;;
+;; ecl-metacopy
+
+(define-public cl-metacopy
+ (sbcl-package->cl-source-package sbcl-metacopy))
+
(define-public sbcl-legit
(let ((commit "5f8a2d4c4f5fb8e53340eeef600433ee20e03fbe")
(revision "2"))
--
2.38.0
G
G
Guillaume Le Vaillant wrote on 18 Nov 2022 14:43
Re: [bug#59344] [PATCH 0/3] gnu: WIP Add cl-graph
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 59344@debbugs.gnu.org)
875yfccqvw.fsf@kitej
Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (16 lines)
> Hi Guix team!
>
> This patch series includes last inputs for cl-graph, but not cl-graph itself
> as build phase failes with error:
>
>> Unhandled SB-INT:SIMPLE-FILE-ERROR in thread #<SB-THREAD:THREAD "main thread" RUNNING
>> {100B108083}>:
>> Error opening #P"/gnu/store/718rs4smnilaf2fhf4mqbxlkc4qicka3-sbcl-cl-containers-0.12.1-3.3d1df53/lib/common-lisp/sbcl/cl-containers/dev/utilities-integration-tmp1CXFJSK9.fasl":
>>
>> Permission denied
>
> I've got WIP package in my personal repo
> https://git.sr.ht/~hellseher/ffab/tree/main/item/ffab/packages/lisp-xyz.scm#L265,
> I'll to figure out why it's failing, but if anyone may take a look it would be
> great too!

Patches 1 to 3 pushed as 89ebe054c5c32a6bb751548addda6fd31a27d099 and following.

Concerning cl-graph, it looks like it wants an optional subsystem of
cl-containers which is not compiled currently. Adding
cl-containers/with-moptilities and/or cl-containers/with-utilities and/or
cl-containers/with-variates to the 'asd-systems' argument in the package
definition of cl-containers should solve the issue.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCY3eN5A8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/n8wD+OdkX304EiLsOBpB77usjsjiZ7bHdRyp2vXj2
nFVWrCABAIleHs2jtLOeXlfhVb+Crdwdjd7nABQyE8TAPRR6ItMl
=rExl
-----END PGP SIGNATURE-----

S
S
Sharlatan Hellseher wrote on 18 Nov 2022 23:17
(name . Guillaume Le Vaillant)(address . glv@posteo.net)(address . 59344@debbugs.gnu.org)
CAO+9K5qcdex1iuaqpHmwrZnbNUxn7TU11WtRXcNTmArkok8p1A@mail.gmail.com
Hi Guillaume,

Thanks for your pointing that out! It looks like I've fixed the build now:

Toggle quote (6 lines)
> ./pre-inst-env guix build sbcl-cl-graph cl-graph sbcl-cl-containers cl-containers --rounds=2
> /gnu/store/xhcp5b79i332941219zdqh1pxnvbsvfp-cl-containers-0.12.1-4.3d1df53
> /gnu/store/iqbfp67yfa4dnkwq0fywfi84bmdgqcml-sbcl-cl-containers-0.12.1-4.3d1df53
> /gnu/store/nl7ykdxb1zzbq1qx387bd7iknay1s5h8-cl-graph-0.10.2-1.3cb7867
> /gnu/store/5r9jqnvr6nx4qhc37f3vda54am85ds07-sbcl-cl-graph-0.10.2-1.3cb7867

On Fri, 18 Nov 2022 at 13:51, Guillaume Le Vaillant <glv@posteo.net> wrote:
Toggle quote (29 lines)
>
> Sharlatan Hellseher <sharlatanus@gmail.com> skribis:
>
> > Hi Guix team!
> >
> > This patch series includes last inputs for cl-graph, but not cl-graph itself
> > as build phase failes with error:
> >
> >> Unhandled SB-INT:SIMPLE-FILE-ERROR in thread #<SB-THREAD:THREAD "main thread" RUNNING
> >> {100B108083}>:
> >> Error opening #P"/gnu/store/718rs4smnilaf2fhf4mqbxlkc4qicka3-sbcl-cl-containers-0.12.1-3.3d1df53/lib/common-lisp/sbcl/cl-containers/dev/utilities-integration-tmp1CXFJSK9.fasl":
> >>
> >> Permission denied
> >
> > I've got WIP package in my personal repo
> > https://git.sr.ht/~hellseher/ffab/tree/main/item/ffab/packages/lisp-xyz.scm#L265,
> > I'll to figure out why it's failing, but if anyone may take a look it would be
> > great too!
>
> Patches 1 to 3 pushed as 89ebe054c5c32a6bb751548addda6fd31a27d099 and following.
>
> Concerning cl-graph, it looks like it wants an optional subsystem of
> cl-containers which is not compiled currently. Adding
> cl-containers/with-moptilities and/or cl-containers/with-utilities and/or
> cl-containers/with-variates to the 'asd-systems' argument in the package
> definition of cl-containers should solve the issue.



--

… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
S
S
Sharlatan Hellseher wrote on 18 Nov 2022 23:19
[PATCH 1/2] gnu: cl-containers: Fix build for all systems
(address . 59344@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221118221905.11908-1-sharlatanus@gmail.com
From cl-containers.asd:

Toggle quote (4 lines)
> The CL-Containers system would enjoy having ~ asdf-system-connections
> around. See http://www.cliki.net/asdf-system-connections for details
> and download instructions.

* gnu/packages/lisp-xyz.scm (sbcl-cl-containers)[inputs]: Remove
labels. Add sbcl-asdf-system-connections, as suggested in worming.
[file-name]: Use string for the name field.
---
gnu/packages/lisp-xyz.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 345932dff9..58c97b5d68 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -7594,7 +7594,7 @@ (define-public ecl-metatilities-base
(define-public sbcl-cl-containers
(let ((commit "3d1df53c22403121bffb5d553cf7acb1503850e7")
- (revision "3"))
+ (revision "4"))
(package
(name "sbcl-cl-containers")
(version (git-version "0.12.1" revision commit))
@@ -7604,7 +7604,7 @@ (define-public sbcl-cl-containers
(uri (git-reference
(url "https://github.com/gwkkwg/cl-containers")
(commit commit)))
- (file-name (git-file-name name version))
+ (file-name (git-file-name "cl-containers" version))
(sha256
(base32
"18s6jfq11n8nv9k4biz32pm1s7y9zl054ry1gmdbcf39nisy377y"))))
@@ -7612,7 +7612,7 @@ (define-public sbcl-cl-containers
(native-inputs
(list sbcl-lift))
(inputs
- `(("metatilities-base" ,sbcl-metatilities-base)))
+ (list sbcl-metatilities-base sbcl-asdf-system-connections))
(arguments
'(#:phases
(modify-phases %standard-phases
--
2.38.0
S
S
Sharlatan Hellseher wrote on 18 Nov 2022 23:19
[PATCH 2/2] gnu: Add cl-graph
(address . 59344@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221118221905.11908-2-sharlatanus@gmail.com
* gnu/packages/lisp-xyz.scm (cl-graph, sbcl-cl-graph): New variables.
---
gnu/packages/lisp-xyz.scm | 45 +++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 58c97b5d68..fa0a1dfcaa 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -1976,6 +1976,51 @@ (define-public cl-hu.dwim.graphviz
(define-public ecl-hu.dwim.graphviz
(sbcl-package->ecl-package sbcl-hu.dwim.graphviz))
+(define-public sbcl-cl-graph
+ (let ((commit "3cb786797b24883d784b7350e7372e8b1e743508")
+ (revision "1"))
+ (package
+ (name "sbcl-cl-graph")
+ (version (git-version "0.10.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gwkkwg/cl-graph")
+ (commit commit)))
+ (file-name (git-file-name "cl-graph" version))
+ (sha256
+ (base32 "1748rj52f2jmd5jvsy9jwhn0zf73sjzjhwhnljvq6yi2kdqr30kl"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ ;; TODO: (Sharlatan-20221118T215839+0000): Tests failed
+ ;;
+ ;; https://github.com/gwkkwg/cl-graph/issues/17
+ ;;
+ `(#:tests? #f
+ #:asd-systems '("cl-graph" "cl-graph+hu.dwim.graphviz")))
+ (native-inputs
+ (list sbcl-lift sbcl-moptilities))
+ (inputs
+ (list sbcl-hu.dwim.graphviz
+ sbcl-cl-mathstats
+ sbcl-dynamic-classes
+ sbcl-metabang-bind
+ sbcl-metacopy
+ sbcl-metatilities-base))
+ (home-page "https://github.com/gwkkwg/cl-graph")
+ (synopsis "Common Lisp library for manipulating graphs and running graph algorithms")
+ (description
+ "This package provides a Graph manipulation utilities for Common Lisp.")
+ (license license:expat))))
+
+;; NOTE: (Sharlatan-20221118T214734+0000): No ECL supoort
+;;
+;; ecl-cl-graph
+
+(define-public cl-cl-graph
+ (sbcl-package->cl-source-package sbcl-cl-graph))
+
(define-public sbcl-babel
;; No release since 2014.
(let ((commit "f892d0587c7f3a1e6c0899425921b48008c29ee3")
--
2.38.0
G
G
Guillaume Le Vaillant wrote on 19 Nov 2022 13:00
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 59344-done@debbugs.gnu.org)
87leo76tls.fsf@kitej
Patches pushed as c9524eca895a85d8acbb4c75faa17c397faaffdd and
a02cd9623f1468205d7dee5f7545f4ed76007b4d.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCY3jFnw8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/z+gD/ZEw+fAIuEgHif51jngxivMEzeCmYrFIFQiqh
wu8w1hQA/RHBB8249/RHD0n4sx0YGzH0rMrefHmznFao52LSLI1E
=tvC/
-----END PGP SIGNATURE-----

Closed
?