[PATCH] gnu: Add alfa

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • (
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 16 Nov 2022 23:50
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221116225035.12435-1-sharlatanus@gmail.com
* gnu/packages/astronomy.scm (alfa): New variable.
---
gnu/packages/astronomy.scm | 53 ++++++++++++++++++++++++++++++++++++++
1 file changed, 53 insertions(+)

Toggle diff (66 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index bc31a12594..c5f0944219 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -86,6 +86,59 @@ (define-module (gnu packages astronomy)
#:use-module (ice-9 match)
#:use-module (srfi srfi-1))
+(define-public alfa
+ (package
+ (name "alfa")
+ (version "2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rwesson/ALFA")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "0aqxqar36822mh373awsl79j7zn8vik4yddyydsxv0c76gn4i2k3"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:parallel-build? #f
+ #:make-flags
+ #~(list (string-append "PREFIX=" #$output)
+ (string-append "VERSION=" #$version))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check)
+ (add-after 'install 'post-install-check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "make" "fittest")))))))
+ (inputs (list cfitsio gfortran))
+ (home-page "https://nebulousresearch.org/codes/alfa/")
+ (synopsis "Automated Line Fitting Algorithm")
+ (description
+ "This package provides @acronym{ALFA, Automatic line fitting algorithm}
+which can identify and fit hundreds of lines in emission line spectra in just a
+few seconds with following features:
+@itemize
+
+@item A population of synthetic spectra is generated using a reference line
+catalogue.
+
+@item The goodness of fit for each synthetic spectrum is calculated. The best
+sets of parameters are retained and the rest discarded.
+
+@item A new population of synthetic spectra is obtained by averaging pairs of
+the best performers.
+
+@item A small fraction of the parameters of the lines in the new generation are
+randomly altered.
+
+@item The process repeats until a good fit is obtained.
+@end itemize")
+ (license license:gpl3+)))
+
(define-public aocommon
(let ((commit "7329a075271edab8f6264db649e81e62b2b6ae5e")
(revision "1"))
--
2.38.0
S
S
Sharlatan Hellseher wrote on 26 Nov 2022 21:22
(address . 59323@debbugs.gnu.org)
CAO+9K5ouAELny9ktUXa6JxW+eq5hUgQy3uPSTtpSSdNAqv5sUQ@mail.gmail.com
Hi,
I see the QA is marked as failed but build statuses passed for 4/6 architectures
Is there anything I need to fix in the package?
Regards,
Oleg
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
(
COMIFDZ7SGFQ.2W5K6VU0FHHY6@guix-framework
On Sat Nov 26, 2022 at 8:22 PM GMT, Sharlatan Hellseher wrote:
Toggle quote (3 lines)
> I see the QA is marked as failed but build statuses passed for 4/6 architectures
> Is there anything I need to fix in the package?

If it's not *supposed* to build on those architectures, you can add a
``supported-systems'' field to the package, which will block the builds
for those archs on the CI, I think.

-- (
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEE6Vh10NblKE5doNlW7ImHg/nqI20FAmOCdxoACgkQ7ImHg/nq
I22NZwv+MPOqMG4lgTSzlX0ql0F7JcHe8RE2Fcf4xnd1LroXVcFc5m0EzWw7wsfw
Lg3/vol2JyrNRlikb1BWhJtv50IYXxx81qTubzEBy/K4QK++txC6JuSBsbIgcRcw
WUQfZvkQ+7uJT68ORqGv9ZDeg77lsFxbWawgHIuMPd8TU03cNEpABfaHsKSc/QTO
q+qpxdKoH0H6Wj9vubFVmJ4dhIeBtLVFKMBFwViMNpySBoMiWz7HhQCjZH0ZBsYm
Wb2OAdHvxIiZG5v/eyxpwQVJ4Hj87eG96jjDTCIkuU/OQCwpSKJ5/FbMtsEmzccT
HcVU/zfXo4AVLDWTGWaTYAQxpYMyNxkl+m83liaN2uVX7I1PHdhdhkBEPRNxEG7Z
joCpdgwZueYc7LyBOiOqCG4OazSQOXHLAsWsSJVHEdpSNJb8rYY7+xIImFEnKJdI
KX1GK4twvsdVUdUPwKMTm/ji3mmKslQWCzDXdcuKCwOU4CijbG+ZPdjd2BgDFLzE
LrNawoHg
=UhT1
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 1 Dec 2022 22:21
Re: bug#59323: [PATCH] gnu: Add alfa
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 59323-done@debbugs.gnu.org)
87o7smyg54.fsf@gnu.org
Hi,

Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/astronomy.scm (alfa): New variable.

I passed it through ‘guix style’ and changed the license to ‘gpl3’
because source headers specify “v3”, without the “or any later version”
wording.

According to https://qa.guix.gnu.org/issue/59323 it’s failing on
aarch64-linux and succeeds everywhere else; could you investigate why as
the next step and report it upstream?

Applied, thanks!

Ludo’.
Closed
L
L
Ludovic Courtès wrote on 1 Dec 2022 22:27
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 59323@debbugs.gnu.org)
87k03ayfuu.fsf@gnu.org
BTW, you might want to consider officially adding an “astronomy” team in
etc/teams.scm.in, with you as its first honorable member. WDYT?

Ludo’.
S
S
Sharlatan Hellseher wrote on 2 Dec 2022 00:37
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 59323@debbugs.gnu.org)
CAO+9K5qD-kexZ9gkpn0ncOF-J9U=dOgv-fRiMhPcL38ogtidxg@mail.gmail.com
Hi Ludo,
It's a great proposal :)!
I try my best too promote Guix in astronomy software communities by
mentioning in
issues, but I'm not an Astronomer or related to any research...
SunPy project will mention Guix in next documentation update
My aim to migrate Debian Astro package stack to Guix and start packaging
journey for Julia packages as Julia become very popular in big data researches.
Regards,
Oleg
On Thu, 1 Dec 2022 at 21:27, Ludovic Courtès <ludo@gnu.org> wrote:
Toggle quote (5 lines)
>
> BTW, you might want to consider officially adding an “astronomy” team in
> etc/teams.scm.in, with you as its first honorable member. WDYT?
>
> Ludo’.
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
L
L
Ludovic Courtès wrote on 2 Dec 2022 15:05
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 59323@debbugs.gnu.org)
87o7slsxxt.fsf@gnu.org
Hi,

Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (6 lines)
> It's a great proposal :)!
>
> I try my best too promote Guix in astronomy software communities by
> mentioning in
> issues, but I'm not an Astronomer or related to any research...

Note that being on a team means you’re knowledgeable about packages that
fall in the team’s scope, that you’re interested in contributing to
their maintenance, and that you’re willing to help other contributors in
this area. You don’t have to be a professional astronomer to do that. :-)

Toggle quote (6 lines)
> SunPy project will mention Guix in next documentation update
> https://github.com/sunpy/sunpy/issues/6634
>
> My aim to migrate Debian Astro package stack to Guix and start packaging
> journey for Julia packages as Julia become very popular in big data researches.

Nice!

Thanks,
Ludo’.
?