[PATCH 0/2] Update trash-cli to 0.22.10.20.

  • Done
  • quality assurance status badge
Details
2 participants
  • kiasoc5
  • Christopher Baines
Owner
unassigned
Submitted by
kiasoc5
Severity
normal

Debbugs page

kiasoc5 wrote 2 years ago
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20221116024639.31739-1-kiasoc5@disroot.org
kiasoc5 (2):
gnu: trash-cli: Update to 0.22.10.20.
gnu: trash-cli: Use G-expressions.

gnu/packages/shellutils.scm | 57 +++++++++++++++++++------------------
1 file changed, 29 insertions(+), 28 deletions(-)


base-commit: 5512915c3bd62e061bd47d440da02e0826c1d0e7
--
2.38.1
kiasoc5 wrote 2 years ago
[PATCH 1/2] gnu: trash-cli: Update to 0.22.10.20.
(address . 59296@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20221116024902.31966-1-kiasoc5@disroot.org
* gnu/packages/shellutils.scm (trash-cli): Update to 0.22.10.20.
[native-inputs]: Add python-parameterized and python-flexmock.
---
gnu/packages/shellutils.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index e70b9ef706..40f33f5227 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -369,7 +369,7 @@ (define-public envstore
(define-public trash-cli
(package
(name "trash-cli")
- (version "0.21.10.24")
+ (version "0.22.10.20")
(source
(origin
(method git-fetch)
@@ -379,7 +379,7 @@ (define-public trash-cli
(file-name (git-file-name name version))
(sha256
(base32
- "01is32lk6prwhajvlmgn3xs4fcpmiqivizcqkj9k80jx6mqjifzs"))))
+ "0hkn0hmwrag56g447ddqapib0s399a6b4a9wlliif6zmirxlww9n"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -410,6 +410,8 @@ (define-public trash-cli
(invoke "pytest")))))))
(native-inputs
(list python-pytest
+ python-parameterized
+ python-flexmock
python-mock
python-six))
(inputs (list coreutils))
--
2.38.1
kiasoc5 wrote 2 years ago
[PATCH 2/2] gnu: trash-cli: Use G-expressions.
(address . 59296@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20221116024902.31966-2-kiasoc5@disroot.org
* gnu/packages/shellutils.scm (trash-cli)[arguments]: Use G-expressions.
---
gnu/packages/shellutils.scm | 51 ++++++++++++++++++-------------------
1 file changed, 25 insertions(+), 26 deletions(-)

Toggle diff (64 lines)
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 40f33f5227..3fd98ecba8 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -382,32 +382,31 @@ (define-public trash-cli
"0hkn0hmwrag56g447ddqapib0s399a6b4a9wlliif6zmirxlww9n"))))
(build-system python-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'build 'patch-path-constants
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((libc (assoc-ref inputs "libc"))
- (coreutils (assoc-ref inputs "coreutils")))
- (substitute* "trashcli/list_mount_points.py"
- (("\"/lib/libc.so.6\".*")
- (string-append "\"" libc "/lib/libc.so.6\"\n"))
- (("\"df\"")
- (string-append "\"" coreutils "/bin/df\""))))))
- (add-before 'build 'fix-setup.py
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- (mkdir-p bin)
- (substitute* "setup.py"
- (("add_script\\('")
- (string-append "add_script('" bin "/" ))))))
- ;; Whenever setup.py is invoked, scripts in out/bin/ are
- ;; replaced. Thus we cannot invoke setup.py for testing.
- ;; Upstream also uses pytest.
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest")))))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'patch-path-constants
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((libc (search-input-file inputs "lib/libc.so.6"))
+ (df #$(file-append coreutils "/bin/df")))
+ (substitute* "trashcli/list_mount_points.py"
+ (("\"/lib/libc.so.6\".*")
+ (string-append "\"" libc "\"\n"))
+ (("\"df\"")
+ (string-append "\"" df "\""))))))
+ (add-before 'build 'fix-setup.py
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append #$output "/bin")))
+ (mkdir-p bin)
+ (substitute* "setup.py"
+ (("add_script\\('")
+ (string-append "add_script('" bin "/" ))))))
+ ;; Whenever setup.py is invoked, scripts in out/bin/ are
+ ;; replaced. Thus we cannot invoke setup.py for testing.
+ ;; Upstream also uses pytest.
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
(native-inputs
(list python-pytest
python-parameterized
--
2.38.1
Christopher Baines wrote 2 years ago
Re: [bug#59296] [PATCH 0/2] Update trash-cli to 0.22.10.20.
(name . kiasoc5)(address . kiasoc5@disroot.org)
875yfdeq9i.fsf@cbaines.net
kiasoc5 via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (7 lines)
> kiasoc5 (2):
> gnu: trash-cli: Update to 0.22.10.20.
> gnu: trash-cli: Use G-expressions.
>
> gnu/packages/shellutils.scm | 57 +++++++++++++++++++------------------
> 1 file changed, 29 insertions(+), 28 deletions(-)

Thanks! Pushed to master as 024a98cb83c6b7d6bebbd56645bc6534d77f3ebc.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmN2JIlfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XeAgQ//UsyieTsVWDsOqTlbf6qFbC69Fx7iRT2C
w3k+7fmJPJGdi/n1hruNXAqqkrYL4TupS2adHvc4BBjic/SXZcYr6mYVPXXIZzKB
3K+oQlUIZQMeVStbimKOsL9o3EB2hblsnQlcSQNAVAFjFIHdYhDk7BGpLvShgokq
6WWGQ09cOi+jTE13Y+iIvXikZYLi8tk39Ray56KzDrG6K4tovmKpY71tI6SMJgLv
zQqjQsSNilo9sLaQdHR0lrqwNrdGHOEm3tsDnBufzlDJVfJ+weVGgDAQx4fQjUQL
4CpBbB2p3J2XQObyUMoiEKK4vgoIbveYm6DoAS4EyjyxUNWLMuNW4MGA5qyTd14k
+Lu9pa2djsDDN+6JjoVz4SU33XMZqYiuS/O03mtGTnwflCdh1bWtogYG6OlBmVLB
IIvOrBBK2ilfw3nel1KJLWP4sVQVZmLZFiMyxAaNOxwwQnH2MXWxhm6SP1Yqbmsj
lGFENpnHIyQxFXSQ4hAfaUDyNl88ZZJJQoJiPZIuWzvqS2lk40xITMAum5F69GDZ
JMs6OjveFVHB9SVm7Zcdb0O20knLvbE9bFCzIgrqyO8xHU7LTYaX/uZrmy9N+3mq
VSIaH1gp4U6X10hlA+X3+xzYAhUVU7ZQjTFAgYRILLn7D7F/Xxf5Hw+2XMiSQUgV
7pA86oxaN0Y=
=8iY2
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 59296@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59296
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help