[PATCH 0/2] Update httpie to 3.2.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • kiasoc5
  • Christopher Baines
Owner
unassigned
Submitted by
kiasoc5
Severity
normal

Debbugs page

kiasoc5 wrote 2 years ago
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20221116015616.21261-1-kiasoc5@disroot.org
kiasoc5 (2):
gnu: httpie: Update to 3.2.1.
gnu: httpie: Use G-expressions.

gnu/packages/python-web.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)


base-commit: 5512915c3bd62e061bd47d440da02e0826c1d0e7
--
2.38.1
kiasoc5 wrote 2 years ago
[PATCH 1/2] gnu: httpie: Update to 3.2.1.
(address . 59294@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20221116020018.22337-1-kiasoc5@disroot.org
* gnu/packages/python-web.scm (httpie): Update to 3.2.1.
[propagated-inputs]: Add python-rich.
---
gnu/packages/python-web.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f6b4faf692..00a848610e 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -953,14 +953,14 @@ (define-public python-httplib2
(define-public httpie
(package
(name "httpie")
- (version "3.1.0")
+ (version "3.2.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "httpie" version))
(sha256
(base32
- "1npyfvrq0l56bil8rnpj78mav378mxx4zcqzq1jjx4aap1020jif"))))
+ "1v736y2h7lcyrnxs9y5sf4xwzgll7pc2s6r3ny929mm8lcn07h69"))))
(build-system python-build-system)
(arguments
;; The tests attempt to access external web servers, so we cannot run them.
@@ -973,6 +973,7 @@ (define-public httpie
python-pysocks
python-charset-normalizer
python-defusedxml
+ python-rich
python-multidict))
(home-page "https://httpie.io")
(synopsis "cURL-like tool for humans")
--
2.38.1
kiasoc5 wrote 2 years ago
[PATCH 2/2] gnu: httpie: Use G-expressions.
(address . 59294@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20221116020018.22337-2-kiasoc5@disroot.org
* gnu/packages/python-web.scm (httpie)[arguments]: Use G-expressions.
---
gnu/packages/python-web.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 00a848610e..6d9ebd928e 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -964,7 +964,7 @@ (define-public httpie
(build-system python-build-system)
(arguments
;; The tests attempt to access external web servers, so we cannot run them.
- '(#:tests? #f))
+ (list #:tests? #f))
(propagated-inputs
(list python-colorama
python-pygments
--
2.38.1
Christopher Baines wrote 2 years ago
Re: [bug#59294] [PATCH 1/2] gnu: httpie: Update to 3.2.1.
(name . kiasoc5)(address . kiasoc5@disroot.org)
87edu1eqbo.fsf@cbaines.net
kiasoc5 via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (6 lines)
> * gnu/packages/python-web.scm (httpie): Update to 3.2.1.
> [propagated-inputs]: Add python-rich.
> ---
> gnu/packages/python-web.scm | 5 +++--
> 1 file changed, 3 insertions(+), 2 deletions(-)

Looks good to me, I've pushed to master as
ce4896e85dfc667959b46c29191961f8280a364b.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmN2JDtfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XctgA//d0gbWMASJhs1MmohdzUkHMRusW1N3kDs
865mmcqgZJ7xngOI671+0rpsG6rpO55ScbcYudTbZnE5zNVbJNm6DhHBlPkACMOT
DyCRcV0BeP/iQr7IEhA0EOPBtdK30RpkA/sQl0G+phZJGAiLJK2VLdhIGgrhIFTM
9nIo5CUgMSoNXsz8NNSG2edRlnpnZgusHBrAXIuaUbIc1lskQ5yk6Lfeu7VDKE10
58DrZxfSSPFvsc9wEwVIJvXyiWHSwfG3CAKSAV6dF6UcU/5cZM09HabIz9FVVdvv
llGDp5hnAq3x61GT3QzvhPaubxda4fzRNA+MLDHNavOgYD9FlVw+pbX2aFbjdf4R
ZW+lTTc4KDc32xCacEae6xLQKr6jispLjJAkW147Tunrqnz5n3yGxve2vgxHSMSP
euPil54Ch0oShDcBcNa0UlvNjJi56U3C7lWICLm5Vmsm47Cp3GSz8DL+lc09ZLo5
boy4wkmrvvK40u5Z5KTWNvOagiIgX5OMtRNobLXVVmjHGtVt3E/QJGmufRnEJhuV
FBVEzxNvHBP8Dy78Qt/yXhU3eL1NAgXu6OaKf5kByEnXYwV9uNbTIThPt68gUwxG
029cxspfEP1EwJ4QM8wUhaw+DS1Rr4jijF51lxZotP4l/agT9jQmi/PrG+D4POJr
b+cnBj0SQCk=
=VdTF
-----END PGP SIGNATURE-----

Christopher Baines wrote 2 years ago
Re: [bug#59294] [PATCH 2/2] gnu: httpie: Use G-expressions.
(name . kiasoc5)(address . kiasoc5@disroot.org)
87a64peqac.fsf@cbaines.net
kiasoc5 via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (19 lines)
> * gnu/packages/python-web.scm (httpie)[arguments]: Use G-expressions.
> ---
> gnu/packages/python-web.scm | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
> index 00a848610e..6d9ebd928e 100644
> --- a/gnu/packages/python-web.scm
> +++ b/gnu/packages/python-web.scm
> @@ -964,7 +964,7 @@ (define-public httpie
> (build-system python-build-system)
> (arguments
> ;; The tests attempt to access external web servers, so we cannot run them.
> - '(#:tests? #f))
> + (list #:tests? #f))
> (propagated-inputs
> (list python-colorama
> python-pygments

I skipped pushing this patch as while I think I get what you're doing,
this change doesn't involve using G-expressions. At least with my
understanding of Guile, nothing is really changing here.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmN2JGtfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xem7hAAlkLlE1RYdB+sbRwtIWcEU46yBhoEl8Uf
BTG+83vJvADTz5O130jy2rmx5q6AHclm+u9gh6o0hzylP3K8+yjDft90BeKStP0k
NUVolqCb8i9LNefsknvsE/U7DNiQzCvJNt5dq17tINvXcgHzbrxdPeBWiATaKYe0
Bqk8B0YV2Q79eepgTv9Kwo0H+KNBmu/YkZp6Udax1q7u/28zNWx8jsMj5fHz4cuf
Q/aoyT36vfT+ulVaC/b+Fx8ZL1FJLpHcBdoNs+Lrv1ERk3hc76PBK6vezym5l8xP
MOCcFGbDnFGfHrHrg5+TMvsLNMTFERAg7GRJ229ygS+T3y7DyE17ELesV+aPPrMl
SLLnKizoVdXSlEiM65FP95m/aPOiIATM63vkrJjOeBO2lBGRVniZBOW6XMz5xvXt
vNoszLzMvUXj7CPCDddY3rm+gX4aBqTK1Go+cYU82OItsyHMt/gwPWu4TNjE8rJb
Eu1Uoy9YiXa8fpOFh7mL6UuAGPz04r+WSWvgJxCQJPNmPLZQfi7TbY9WXlwtCCAB
ijpBERAlk2Uhu+DezhGL83DRWgN89QpV1b0hg+XthXHNsPDvYsUhjPFoUWGpjKdq
/EdX1eCTW87Yli/xIvLAL5oLKBLa03dh/467+92e0IV7YugnL2iWOdG9HbmYp6YI
rWhsh10g/Kk=
=MMZ3
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 59294@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59294
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help