[PATCH] gnu: microscheme: Update to 0.9.4.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Fabio Natali
Owner
unassigned
Submitted by
Fabio Natali
Severity
normal

Debbugs page

Fabio Natali wrote 2 years ago
(address . guix-patches@gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
58c2d42a654e53ebfad7769f9295753ceec4f6a4.1668555644.git.me@fabionatali.com
---
Hi! Microscheme 0.9.4 has just been released [0]. Here is a little
patch to update the Guix package to that version. Thanks, best, F.


gnu/packages/avr.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/avr.scm b/gnu/packages/avr.scm
index 3cc5a6964e..a741f183d7 100644
--- a/gnu/packages/avr.scm
+++ b/gnu/packages/avr.scm
@@ -31,10 +31,12 @@ (define-module (gnu packages avr)
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
#:use-module (gnu packages)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages cross-base)
#:use-module (gnu packages flashing-tools)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages llvm)
#:use-module (gnu packages vim))
(define-public avr-binutils
@@ -148,7 +150,7 @@ (define-public avr-toolchain
(define-public microscheme
(package
(name "microscheme")
- (version "0.9.3")
+ (version "0.9.4")
(source
(origin
(method git-fetch)
@@ -156,7 +158,7 @@ (define-public microscheme
(url "https://github.com/ryansuchocki/microscheme")
(commit (string-append "v" version))))
(sha256
- (base32 "1r3ng4pw1s9yy1h5rafra1rq19d3vmb5pzbpcz1913wz22qdd976"))
+ (base32 "1bflwirpcd58bngbs6hgjfwxl894ni2gpdd4pj10pm2mjhyj5dgw"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
@@ -168,7 +170,7 @@ (define-public microscheme
#:make-flags
(list (string-append "PREFIX=" (assoc-ref %outputs "out")))))
(native-inputs
- (list unzip xxd))
+ (list clang cppcheck unzip xxd))
(home-page "https://github.com/ryansuchocki/microscheme/")
(synopsis "Scheme subset for Atmel microcontrollers")
(description
--
2.38.1
Guillaume Le Vaillant wrote 2 years ago
(name . Fabio Natali)(address . me@fabionatali.com)(address . 59291-done@debbugs.gnu.org)
877czv2pap.fsf@kitej
Patch pushed as 996f897cf17449198713b2412fa99185c0abe214.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCY3S0bg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+R8gD+Maz/ZzSmPicbYA0FDubyX+EDmXOOcrSi4DMS
2pCeiEoBAJfAXXlhaHA2fCfF4LquBbv0GjngYhtEO5P9grz/C2nY
=Hd9k
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59291@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59291
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help