Emacs-guix tab-completion returns gexp error

  • Open
  • quality assurance status badge
Details
3 participants
  • calcium
  • Joshua Hecker
  • Maxime Devos
Owner
unassigned
Submitted by
Joshua Hecker
Severity
normal
J
J
Joshua Hecker wrote on 13 Nov 2022 23:16
(address . bug-guix@gnu.org)
87mt8umrex.fsf@mailbox.org
To Guix,

Emacs-guix tab-completion or M-x guix-command returns:

Error in evaluating guile expression: ice-9/boot-9.scm:1685:16: In procedure raise-exception:
/home/crono/.config/guix/current/share/guile/site/3.0/guix/scripts/deploy.scm:177:7: Unknown # object: "#~"

Entering a new prompt. Type `,bt' for a backtrace or `,q' to continue.
scheme@(emacs-guix) [1]>

It seems to me that the repl doesnt have the gexp module loaded? I have
tried changing the guix-load-path and guix-compiled-load-path for
emacs. As well as loading the gexp module in both the emacs-guix and
internal repl.

For the "is this reproducible" question just in case:

Thank you,
-Joshua
J
J
Joshua Hecker wrote on 26 Nov 2022 21:45
87h6yl4f8b.fsf@mailbox.org
To Guix,

Just following up for the record, turning (setq guix-repl-use-server
nil) does fix the reading issue. For whats it worth at least we can
safely say it with how sockets (at least in for guile) handle gexp.
I will investigate further with do time.

stay safe,
-Joshua
C
C
calcium wrote on 15 Dec 2022 14:01
Emacs-guix tab-completion returns gexp error
(address . 59256@debbugs.gnu.org)
12c37abe-1c21-dc5f-8b0a-6c6f5c6618af@disroot.org
The problem can be tracked back from elisp procedure `guix-pcomplete-search-in-help` in guix-pcomplete.el to `guix-help-string` in guix-misc.el, to this problematic code :
```
(guix-eval-read "(help-string )")
```

The procedure help-string exists, as can be seen below :
```
(guix-eval-read
"(begin
(use-modules (ice-9 format))
(format #f \"~s\"
help-string))") ;; => "#<procedure help-string commands>"
```

but the object that `(help-string)` returns seems incompatible with guile's own repl/shell ....

The solution might be to just change the `help-string` procedure to return another kind of object, or to fix guile's repl/shell for that kind of object.
J
J
Joshua Hecker wrote on 2 Jan 2023 08:29
87h6x95r8h.fsf@mailbox.org
calcium <calcium@disroot.org> writes:

Toggle quote (25 lines)
> The problem can be tracked back from elisp procedure
> `guix-pcomplete-search-in-help` in guix-pcomplete.el to
> `guix-help-string` in guix-misc.el, to this problematic code :
>
> ```
> (guix-eval-read "(help-string )")
> ```
>
>
> The procedure help-string exists, as can be seen below :
>
> ```
> (guix-eval-read
> "(begin
> (use-modules (ice-9 format))
> (format #f \"~s\"
> help-string))") ;; => "#<procedure help-string commands>"
> ```
>
> but the object that `(help-string)` returns seems incompatible with guile's own repl/shell ....
>
> The solution might be to just change the `help-string` procedure to
> return another kind of object, or to fix guile's repl/shell for that
> kind of object.

Im certain it's not anyone procedure, but rather the internal repl being in a
socket file. I dont know how guile is handling sockets, but guile
(socketed) cant read '#' for some reason.

The next step might be going to the guile mailing list and getting some
answers there, cause guile has nil for documentation and I have come up
empty handed in looking for any answers for guile socket files. Either way, I
think emacs-guix is important enough to get this fix, so will do.

Stay safe,
-Joshua
M
M
Maxime Devos wrote on 3 Jan 2023 23:25
fb3497d7-50c2-e32e-5894-4a9f2d83cd86@telenet.be
I've heard about something about Guile sockets and REPLs, so I've
investigated a bit and I think I found a Guix bug instead of a Guile bug
(and is unrelated to sockets or REPLs):
In the error message, there is a mention of "#~". Perhaps somehow, no
hash extension (not sure about terminology) for G-exps installed?
This is confirmed by:
scheme@(emacs-guix) [2]> (fluid-ref* %read-hash-procedures 0)
$24 = ((#\. . #<procedure 7fbac9e323d0 at ice-9/boot-9.scm:2251:18 (c
port)>))
It's also not a matter of some parametrisation:
scheme@(emacs-guix) [2]> (fluid-ref* %read-hash-procedures 1)
$25 = ()
scheme@(emacs-guix) [2]> (fluid-ref* %read-hash-procedures 2)
$26 = ()
How does this happen? (after all, (guix scripts deploy) imports (guix gexp))
Going by the backtrace I get:
[...]
In guix/ui.scm:
2263:7 17 (run-guix . _)
In ice-9/boot-9.scm:
1747:15 16 (with-exception-handler #<procedure 7fbac4ead6c0 at
ice-9/boot-9.scm:1831:7 (exn)> _ #:unwind? _ #:unwind-for-type _)
In guix/ui.scm:
2184:20 15 (show-guix-help)
In srfi/srfi-1.scm:
691:23 14 (filter-map #<procedure source-file-command (file)> _ . _)
In ice-9/ports.scm:
433:17 13 (call-with-input-file _ _ #:binary _ #:encoding _
#:guess-encoding _)
In guix/ui.scm:
2109:16 12 (_ #<input:
/home/antipode/.config/guix/current/share/guile/site/3.0/guix/scripts/deploy.scm
22>)
In ice-9/read.scm:
734:20 11 (%read #<input:
/home/antipode/.config/guix/current/share/guile/site/3.0/guix/scripts/deploy.scm
22> #<procedure 7fbac42c5280 at ice-9/read.scm:862:8 (line column datum)> _)
210:5 10 (read-parenthesized #\))
[...]
That is, one of the earliest things that happen, is that (guix ui) reads
the file "(guix scripts deploy)" -- it doesn't do the reflection
equivalent of (use-module ...) which will run the imports before reading
the rest of the code.
As such, the hash extension isn't installed even though it is required
to read the file and even though the required module (guix gexp) is
listed in the imports!
To fix this, I propose modifying 'source-file-command' in (guix ui), by
adding a clause to
(match (read port)
(('define-command _ ('synopsis synopsis)
_ ...)
(command command-name synopsis 'main))
(('define-command _
('category category) ('synopsis synopsis)
_ ...)
(command command-name synopsis category))
((? eof-object?)
#f)
(_
(loop)))))))
which recognises (define-module [...] #:use-module MODULE ...),
and if MODULE is (guix gexp) or (srfi srfi-88), then does
(resolve-module 'MODULE #:ensure #false) before continuing with (loop).
(Untested!)
Greetings,
Maxime.
Attachment: OpenPGP_signature
J
J
Joshua Hecker wrote on 22 Mar 2023 07:10
874jqde2pl.fsf@mailbox.org
Maxime Devos <maximedevos@telenet.be> writes:

Sorry for getting back to you so late, life got in the way, work and
setting up my POWER9 machine :). But I still hope you can provide some
wisdom.

Toggle quote (4 lines)
> I've heard about something about Guile sockets and REPLs, so I've
> investigated a bit and I think I found a Guix bug instead of a Guile
> bug (and is unrelated to sockets or REPLs):

Im glad you found something different happening behind the scenes. I
only came to that conclusion because I loaded my own [default] geiser
repl with emacs-guix mode, and comparing that to the emacs-guix repl
that loads automatically.

Toggle quote (76 lines)
> In the error message, there is a mention of "#~". Perhaps somehow, no
> hash extension (not sure about terminology) for G-exps installed?
> This is confirmed by:
>
> scheme@(emacs-guix) [2]> (fluid-ref* %read-hash-procedures 0)
> $24 = ((#\. . #<procedure 7fbac9e323d0 at ice-9/boot-9.scm:2251:18 (c
> port)>))
>
> It's also not a matter of some parametrisation:
>
> scheme@(emacs-guix) [2]> (fluid-ref* %read-hash-procedures 1)
> $25 = ()
> scheme@(emacs-guix) [2]> (fluid-ref* %read-hash-procedures 2)
> $26 = ()
>
> How does this happen? (after all, (guix scripts deploy) imports (guix gexp))
>
> Going by the backtrace I get:
>
> [...]
> In guix/ui.scm:
> 2263:7 17 (run-guix . _)
> In ice-9/boot-9.scm:
> 1747:15 16 (with-exception-handler #<procedure 7fbac4ead6c0 at
> ice-9/boot-9.scm:1831:7 (exn)> _ #:unwind? _ #:unwind-for-type _)
> In guix/ui.scm:
> 2184:20 15 (show-guix-help)
> In srfi/srfi-1.scm:
> 691:23 14 (filter-map #<procedure source-file-command (file)> _ . _)
> In ice-9/ports.scm:
> 433:17 13 (call-with-input-file _ _ #:binary _ #:encoding _
> #:guess-encoding _)
> In guix/ui.scm:
> 2109:16 12 (_ #<input:
> /home/antipode/.config/guix/current/share/guile/site/3.0/guix/scripts/deploy.scm
> 22>)
> In ice-9/read.scm:
> 734:20 11 (%read #<input:
> /home/antipode/.config/guix/current/share/guile/site/3.0/guix/scripts/deploy.scm
> 22> #<procedure 7fbac42c5280 at ice-9/read.scm:862:8 (line column
> datum)> _)
> 210:5 10 (read-parenthesized #\))
> [...]
>
> That is, one of the earliest things that happen, is that (guix ui)
> reads the file "(guix scripts deploy)" -- it doesn't do the reflection
> equivalent of (use-module ...) which will run the imports before
> reading the rest of the code.
>
> As such, the hash extension isn't installed even though it is required
> to read the file and even though the required module (guix gexp) is
> listed in the imports!
>
> To fix this, I propose modifying 'source-file-command' in (guix ui),
> by adding a clause to
>
> (match (read port)
> (('define-command _ ('synopsis synopsis)
> _ ...)
> (command command-name synopsis 'main))
> (('define-command _
> ('category category) ('synopsis synopsis)
> _ ...)
> (command command-name synopsis category))
> ((? eof-object?)
> #f)
> (_
> (loop)))))))
>
> which recognises (define-module [...] #:use-module MODULE ...),
> and if MODULE is (guix gexp) or (srfi srfi-88), then does
> (resolve-module 'MODULE #:ensure #false) before continuing with
> (loop).
>
> (Untested!)

Very cool that you found this. I would love to test this out, is there
any formal way to apply this and have emacs point to the test guix?
Sorry for novice questions, any info to do the work would be much appreciated.

Stay safe,
-Joshua
M
?