[PATCH 1/2] gnu: rofi: Update to 1.7.5.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hilton Chain
  • Christopher Baines
Owner
unassigned
Submitted by
Hilton Chain
Severity
normal
H
H
Hilton Chain wrote on 13 Nov 2022 07:36
(address . guix-patches@gnu.org)
y76fsen2we0.wl-hako@ultrarare.space
* gnu/packages/xdisorg.scm (rofi): Update to 1.7.5.
[arguments]<#:phases>: Adjusted according to source change.
---
gnu/packages/xdisorg.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index c4cc351cad..c09e470460 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -1810,7 +1810,7 @@ (define-public xdpyprobe
(define-public rofi
(package
(name "rofi")
- (version "1.7.3")
+ (version "1.7.5")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/davatorium/rofi/"
@@ -1818,7 +1818,7 @@ (define-public rofi
version "/rofi-" version ".tar.xz"))
(sha256
(base32
- "0yxn9pmn9zp0k5ygnjqbj1pmp73g53wa47r145a8qcwqzxl8p1i5"))))
+ "138c4bl60p7namsb2pk8q5cdlxbdkli7zny192vk5jv5s5kczzya"))))
(build-system gnu-build-system)
(native-inputs
(list bison
@@ -1853,7 +1853,7 @@ (define-public rofi
(substitute* '("test/helper-expand.c")
(("~root") "/root")
(("~") "")
- (("g_get_home_dir \\(\\)") "\"/\"")))))))
+ (("g_get_home_dir\\(\\)") "\"/\"")))))))
(home-page "https://github.com/davatorium/rofi")
(synopsis "Application launcher")
(description "Rofi is a minimalist application launcher. It memorizes which

base-commit: c4025af8c11c3e9ea0c2747b6c475c916fb61d80
--
2.38.1
H
H
Hilton Chain wrote on 13 Nov 2022 07:39
[PATCH 2/2] gnu: Add rofi-wayland.
(address . 59241@debbugs.gnu.org)
y76edu72wah.wl-hako@ultrarare.space
* gnu/packages/xdisorg.scm (rofi-wayland): New variable.
---
gnu/packages/xdisorg.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index c09e470460..24e09f2b9f 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -1861,6 +1861,30 @@ (define-public rofi
by name.")
(license license:expat)))
+(define-public rofi-wayland
+ (let ((base rofi))
+ (package
+ (inherit rofi)
+ (name "rofi-wayland")
+ (version "1.7.5+wayland1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/lbonn/rofi"
+ "/releases/download/" version
+ "/rofi-" version ".tar.xz"))
+ (sha256
+ (base32
+ "09n71wv3nxpzpjmvqmxlxk0zfln3x2l8admfq571781p9hw0w6wp"))))
+ (build-system meson-build-system)
+ (inputs
+ (modify-inputs (package-inputs base)
+ (append wayland wayland-protocols)))
+ (description
+ (string-append
+ (package-description base)
+ " This package, @code{rofi-wayland}, provides additional wayland
+support.")))))
+
(define-public rofi-calc
(package
(name "rofi-calc")
--
2.38.1
C
C
Christopher Baines wrote on 19 Nov 2022 15:02
Re: [bug#59241] [PATCH 1/2] gnu: rofi: Update to 1.7.5.
(name . Hilton Chain)(address . hako@ultrarare.space)
87cz9javof.fsf@cbaines.net
Hilton Chain via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (6 lines)
> * gnu/packages/xdisorg.scm (rofi): Update to 1.7.5.
> [arguments]<#:phases>: Adjusted according to source change.
> ---
> gnu/packages/xdisorg.scm | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)

This and the following patch look good to me, I've pushed them to master
as 04b5450ad852735dfa50961d3afc789b2e52b407.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmN44iBfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdtHxAAlcgQcANN39HkeZjWVk0HOCna7Wc4sc1D
KTTqXD1mhSGR08jlIPvL2fIFEOIWJFzrcTTJFXsdvlONnfzm/0q0xTEaAs96LLyC
wXm+Sne6uR5v9oc5/HXhJs7oqyTwsJxOTwxdP1oRIryQgwDqwOIscZweDtHzcH3W
UVj2MQAZEfJnPwHdStfRNYnW0bpChGqUhA08YIWD6VGRofz0uk1zdHH0T01TWO7L
HJVSFV1gry+cHnUwM05tposcRDduEO4HcD2He4fCZPMHl7KohKf9m2hpgQFK8ba6
3XrU3en6Ld7UMsGWj7NnEqD8J6yVTXILMIKbXpSeoA2C1mrOmERGvFJO9HkTZg+B
ROEPjTQj+24vRtUqODy7FhIGlBAhUxQeX8AP/43uc8mgkYxFPt/DDaKDiF4OKE1C
eTx4YDQSYKyaltadnehacV5/5bSdvLCIzlXKibEKczN2/Xqpd7CpQlNXtFHmj3ch
h3f0DhqHVz1HwbAUB8hVtJOE+Ajv2LE79aGuWyLWqpdlBocM7Ru/dApTVp4nU3TO
iZXeYv481avF4WytNdpeVNwRoocBEnbH1sBoCteqpC/u3iLLvrlaozPQxiz2ALli
nEG8d4kyC0dFlTfpk1DA+ScSfpEeZaNigVCHoilPrGe4/IRy5B+DtGTICuZlSfvK
vQCnFc+ANrI=
=84Bv
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 59241@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59241
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch