[PATCH] gnu: %options: Add short flag -R for --list-transitive option.

  • Open
  • quality assurance status badge
Details
2 participants
  • jgart
  • (
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20221113032832.16933-1-jgart@dismail.de
* guix/scripts/refresh.scm (%options): Add short flag -R.
---
guix/scripts/refresh.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (32 lines)
diff --git a/guix/scripts/refresh.scm b/guix/scripts/refresh.scm
index 14329751f8..aff32c13de 100644
--- a/guix/scripts/refresh.scm
+++ b/guix/scripts/refresh.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -99,7 +100,7 @@ (define %options
(option '(#\r "recursive") #f #f
(lambda (opt name arg result)
(alist-cons 'recursive? #t result)))
- (option '("list-transitive") #f #f
+ (option '(#\R "list-transitive") #f #f
(lambda (opt name arg result)
(alist-cons 'list-transitive? #t result)))
@@ -157,7 +158,7 @@ (define (show-help)
(display (G_ "
-r, --recursive check the PACKAGE and its inputs for upgrades"))
(display (G_ "
- --list-transitive list all the packages that PACKAGE depends on"))
+ -R, --list-transitive list all the packages that PACKAGE depends on"))
(newline)
(display (G_ "
--keyring=FILE use FILE as the keyring of upstream OpenPGP keys"))
--
2.38.1
(
COB09N02M13I.FPNTROUKN6S5@guix-framework
On Sun Nov 13, 2022 at 3:28 AM GMT, jgart via Guix-patches via wrote:
Toggle quote (2 lines)
> gnu: %options: ...

This should be:

scripts: refresh: ...

Toggle quote (2 lines)
> * guix/scripts/refresh.scm (%options): Add short flag -R.

Other than that, LGTM! :)

-- (
J
[PATCH v2] guix: scripts: refresh: Add short flag -R for --list-transitive option.
(address . 59235@debbugs.gnu.org)
20221113150519.8114-1-jgart@dismail.de
* guix/scripts/refresh.scm (%options): Add short flag -R.

Here's v2 with your requests. Thanks for the review, paren.

all best,

jgart
---
guix/scripts/refresh.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (32 lines)
diff --git a/guix/scripts/refresh.scm b/guix/scripts/refresh.scm
index 14329751f8..aff32c13de 100644
--- a/guix/scripts/refresh.scm
+++ b/guix/scripts/refresh.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -99,7 +100,7 @@ (define %options
(option '(#\r "recursive") #f #f
(lambda (opt name arg result)
(alist-cons 'recursive? #t result)))
- (option '("list-transitive") #f #f
+ (option '(#\R "list-transitive") #f #f
(lambda (opt name arg result)
(alist-cons 'list-transitive? #t result)))
@@ -157,7 +158,7 @@ (define (show-help)
(display (G_ "
-r, --recursive check the PACKAGE and its inputs for upgrades"))
(display (G_ "
- --list-transitive list all the packages that PACKAGE depends on"))
+ -R, --list-transitive list all the packages that PACKAGE depends on"))
(newline)
(display (G_ "
--keyring=FILE use FILE as the keyring of upstream OpenPGP keys"))
--
2.38.1
J
[PATCH v3 1/2] guix: scripts: refresh: Add short flag -R for --list-transitive option.
(address . 59235@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
20221113153804.9781-1-jgart@dismail.de
* guix/scripts/refresh.scm (%options): Add short flag -R.

Here's v3 adding a doc entry.

all best,

jgart
---
guix/scripts/refresh.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (32 lines)
diff --git a/guix/scripts/refresh.scm b/guix/scripts/refresh.scm
index 14329751f8..aff32c13de 100644
--- a/guix/scripts/refresh.scm
+++ b/guix/scripts/refresh.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -99,7 +100,7 @@ (define %options
(option '(#\r "recursive") #f #f
(lambda (opt name arg result)
(alist-cons 'recursive? #t result)))
- (option '("list-transitive") #f #f
+ (option '(#\R "list-transitive") #f #f
(lambda (opt name arg result)
(alist-cons 'list-transitive? #t result)))
@@ -157,7 +158,7 @@ (define (show-help)
(display (G_ "
-r, --recursive check the PACKAGE and its inputs for upgrades"))
(display (G_ "
- --list-transitive list all the packages that PACKAGE depends on"))
+ -R, --list-transitive list all the packages that PACKAGE depends on"))
(newline)
(display (G_ "
--keyring=FILE use FILE as the keyring of upstream OpenPGP keys"))
--
2.38.1
J
[PATCH v3 2/2] doc: Mention --list-transitive short flag in the manual.
(address . 59235@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
20221113153804.9781-2-jgart@dismail.de
* doc/guix.texi (Invoking guix refresh): Mention -R short flag.
---
doc/guix.texi | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (22 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 3f76184495..b7f0775ae4 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -109,6 +109,7 @@ Copyright @copyright{} 2022 Reily Siegel@*
Copyright @copyright{} 2022 Simon Streit@*
Copyright @copyright{} 2022 (@*
Copyright @copyright{} 2022 John Kehayias@*
+Copyright @copyright{} 2022 jgart@*
Permission is granted to copy, distribute and/or modify this document
under the terms of the GNU Free Documentation License, Version 1.3 or
@@ -14135,6 +14136,7 @@ for compatibility with an upgraded @code{flex} package.
@table @code
@item --list-transitive
+@itemx -R
List all the packages which one or more packages depend upon.
@example
--
2.38.1
(
Re: [bug#59235] [PATCH v3 1/2] guix: scripts: refresh: Add short flag -R for --list-transitive option.
COBALP1ARAGJ.JG8X2Z4CTVBA@guix-framework
On Sun Nov 13, 2022 at 3:38 PM GMT, jgart via Guix-patches via wrote:
Toggle quote (2 lines)
> guix: scripts: refresh: ...

Nitpick again: it's just ``scripts: refresh: ...'' ;)

-- (
J
[PATCH v4 1/2] scripts: refresh: Add short flag -R for --list-transitive option.
(address . 59235@debbugs.gnu.org)
20221113162700.12084-1-jgart@dismail.de
* guix/scripts/refresh.scm (%options): Add short flag -R.

no probs, v4 thnx!
---
guix/scripts/refresh.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (32 lines)
diff --git a/guix/scripts/refresh.scm b/guix/scripts/refresh.scm
index 14329751f8..aff32c13de 100644
--- a/guix/scripts/refresh.scm
+++ b/guix/scripts/refresh.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -99,7 +100,7 @@ (define %options
(option '(#\r "recursive") #f #f
(lambda (opt name arg result)
(alist-cons 'recursive? #t result)))
- (option '("list-transitive") #f #f
+ (option '(#\R "list-transitive") #f #f
(lambda (opt name arg result)
(alist-cons 'list-transitive? #t result)))
@@ -157,7 +158,7 @@ (define (show-help)
(display (G_ "
-r, --recursive check the PACKAGE and its inputs for upgrades"))
(display (G_ "
- --list-transitive list all the packages that PACKAGE depends on"))
+ -R, --list-transitive list all the packages that PACKAGE depends on"))
(newline)
(display (G_ "
--keyring=FILE use FILE as the keyring of upstream OpenPGP keys"))
--
2.38.1
J
[PATCH v4 2/2] doc: Mention --list-transitive short flag in the manual.
(address . 59235@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
20221113162700.12084-2-jgart@dismail.de
* doc/guix.texi (Invoking guix refresh): Mention -R short flag.
---
doc/guix.texi | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (22 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 3f76184495..b7f0775ae4 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -109,6 +109,7 @@ Copyright @copyright{} 2022 Reily Siegel@*
Copyright @copyright{} 2022 Simon Streit@*
Copyright @copyright{} 2022 (@*
Copyright @copyright{} 2022 John Kehayias@*
+Copyright @copyright{} 2022 jgart@*
Permission is granted to copy, distribute and/or modify this document
under the terms of the GNU Free Documentation License, Version 1.3 or
@@ -14135,6 +14136,7 @@ for compatibility with an upgraded @code{flex} package.
@table @code
@item --list-transitive
+@itemx -R
List all the packages which one or more packages depend upon.
@example
--
2.38.1
?